Nach Klick auf Hyperlink wird Quellcode der gelinkten Seite angezeigt


Skandinavika

Mitglied
Hallo!

Ich habe auf meiner Startseite (default.html) Links auf verschiedene Unterseiten meiner Webseite (aspx-Seiten, die aus master-Seiten generiert wurden) gemacht. Wenn man auf die Links klickt, wird aber der Quellcode der jeweiligen Unterseite angezeigt. ? Was läuft da falsch und wie kann ich das Problem beseitigen Das Verlinken der aspx-Seiten untereinander funktioniert einwandfrei...

Vielen Dank schon mal für Eure Hilfe!
 

tombe

Erfahrenes Mitglied
Wird denn von der Startseite aus eine neue Seite geladen oder ist diese aspx-Datei vielleicht nur mittels FRAME/IFRAME dort eingebunden

Da du schreibst das Verlinken untereinander funktioniert gehe ich davon aus das ein Server installiert ist und auch richtig läuft !!
 

Skandinavika

Mitglied
Hi!
Es wird eine neue Seite geladen (ich habe bei target _blank angegeben, und es wird auch ein neues Fenster geöffnet, aber eben mit dem Code).
Die Anzeige untereinander verlinkter .htm-Seiten funktioniert übrigens auch, nur von der .html auf die .aspx-Seiten, das haut nicht hin.
 

tombe

Erfahrenes Mitglied
Im ersten Beitrag schreibst du:
Das Verlinken der aspx-Seiten untereinander funktioniert einwandfrei...

und nun:
untereinander verlinkter .htm-Seiten funktioniert übrigens auch,

Werden ASP Seiten denn überhaupt angezeigt? Nicht das es doch daran liegt das kein Server eingerichtet ist oder dieser nicht richtig eingestellt ist!!
 

Skandinavika

Mitglied
Wie finde ich raus, wie ein hoffentlich installierter Server eingestellt ist.
Tut mir leid wegen der dummen Frage, aber davon habe ich keine Ahnung.
 

tombe

Erfahrenes Mitglied
Also ich gehe jetzt mal davon aus das du an deinem PC/Notebook arbeitest.
In diesem Fall beantwortest du mit deiner Frage diese auch gleich denn einen Server müsstest du selber installiert haben und das wüßtest du ja dann.

Ich gehe jetzt auch mal davon auf das du Windows als Betriebssystem hast. Je nachdem welche Version du da hast, ist teilweise der Microsoft eigene IIS Server auf der CD dabei. Da ich von der Gegenpartei (PHP) komme, kann ich dir jetzt leider keinen Tip geben welchen du am besten installierst.

Hier aber mal ein Link zu einen Galileo OpenBook wo es genau darum geht: http://openbook.galileocomputing.de/asp/asp020001.htm
 

Skandinavika

Mitglied
Ähm, es ist vielleicht noch von Belang, dass das Notebook an einem Firmennetzwerk hängt?
Arbeitsplatz: Windows XP Professional 2002, SP2; Was den Firmenserver betrifft, müsste ich rasch in den Keller flitzen...
 

tombe

Erfahrenes Mitglied
Hoffentlich bist du noch nicht losgelaufen ;).

"XP Professional" ist schonmal sehr gut, das ist der ISS Server auf jeden Fall dabei. Erstellt du die Dateien lokal bei dir und stellst sie dann online oder wird das eine firmeninterne Seite die nur bei euch im Firmennetz läuft?

Dann müsste der ISS Server (oder ein vergleichbarer) auf eurem Server installiert werden. Das wird dann sicher komplizierter!!
 

tombe

Erfahrenes Mitglied
Na dann schau dir mal den obigen Link an. Damit kannst du das Problem lösen (und vielleicht auch sonst noch was lernen).
 

Skandinavika

Mitglied
Hmm, im Moment sehe ich nicht, wie ich damit das Problem beseitigen könnte. Die IIS habe ich installiert, das hilft bislang aber leider überhaupt nicht.

Noch eine Frage: Ist das nun "nur" ein lokales Problem?
 

tombe

Erfahrenes Mitglied
Die Frage ob generell keine ASP Dateien ausgeführt werden hast du bislang weder mt Ja noch mit Nein beantwortet. Deshalb ging ich davon aus (und tu es noch immer) das es ein lokales Problem ist weil kein Server installiert ist bzw. dieser nicht richtig arbeitet.

Wenn du die Dateien irgendwann mal online stellst, muss dort natürlich gewährleistet sein das ASP unterstützt und ausgeführt wird.
 

Skandinavika

Mitglied
Die Frage ob generell keine ASP Dateien ausgeführt werden hast du bislang weder mt Ja noch mit Nein beantwortet.

Nein, generell gilt das nicht. Die Website besteht von default.html einmal abgesehen, nur aus aspx-Seiten und den zugehörigen master-Seiten. In der Browser-Vorschau hat immer alles einwandfrei funktioniert. Erst als ich die Startseite angelegt und mit den aspx-Seiten verlinkt habe, traten in der Browser-Vorschau die beschriebenen Probleme auf, deshalb war ich einigermaßen überrascht, dass es überhaupt ein Problem gibt.
 
Zuletzt bearbeitet:

Luzie

Erfahrenes Mitglied
Hi
also mit Deinen Angaben kann man nicht wirklich viel anfangen.

Wie verlinkst Du denn? Über Controls? eher unwahrscheinlich von einer html-Seite.
Was ist das für eine neue Startseite? Eine aspx-Seite?
Wie arbeitest Du denn lokal? Mit dem Visual Web Developer 2005 oder höher? Dort ist übrigens ein lokaler Server installiert eben für lokale Anwendungen. Fehler werden dir dort direkt im Projekt präsentiert.
 

Skandinavika

Mitglied
Hallo, Luzie!

Ich habe beim Erstellen der Website mit den Masterseiten und den daraus generierten Unterseiten (. B. contact.aspx) angefangen, und erst danach die Startseite angefügt (default.html). Und eben die Links von default.hml nach z.B. contact.aspx funktionieren nicht.

Beispiel für einen solchen Link:
<a href="seiten_allgemein/contact.aspx" target="_blank">Kontakt</a>
oder:
<a href="seiten_holzbau_zimmerei/holzbau_zimmerei.aspx" target="_blank">
<img src="images/holzbau_balken_default.gif" alt="Holzbau & Zimmerei"
width="200px" height="775px" id="img1"
onmouseout="FP_swapImgRestore()"
onmouseover="FP_swapImg(1,1,/*id*/'img1',/*url*/'images/holzbau_balken_defaultsw.gif')" class="style1"
onclick="FP_playSound(/*url*/'seiten_allgemein/ding.wav')"/>
</a>

Ich arbeite übrigens mit Expression Web 2. IIS habe ich mittlerweile installiert, aber ich habe keinen Dunst, wie ich da Einstellungen vornehmen soll. Seit der Installation funktionieren nun Dinge nicht, die vorher reibungslos funktioniert haben (z. B. Klappmenus auf den aspx-Seiten).

Kannst du mir weiterhelfen?
 

Luzie

Erfahrenes Mitglied
Hi

eigentlich bist Du hier im falschen Board.
Es gibt ja für NET eine extra Abteilung im Forum.
Dort sitzen auch die Profis :) Vielleicht verschiebt Dich ja mal jemand dahin.
Vielleicht haben die noch andere Ideen außer Tombe und mir.

Ich arbeite noch nicht sehr lange mit ASP.NET.

Vielleicht solltest Du Dir mal den aktuellen Visual Web Developer herunterladen. Dort ist ein Server eingebaut. Ich finde das Tool einfach supergut. Es generiert Dir Applikationen, es zeigt Dir mögliche Fehler an, hat eine hervorragende Intelisense und und und... Zumindest hast Du so das Problem mit der lokalen Serveradministration nicht.

Also wenn das Verlinken innerhalb der aspx-Seiten funktioniert, warum legst Du Dir nicht als Startseite eine default.aspx an?