Nach Klick auf Hyperlink wird Quellcode der gelinkten Seite angezeigt


Skandinavika

Mitglied
Hmm, im Moment sehe ich nicht, wie ich damit das Problem beseitigen könnte. Die IIS habe ich installiert, das hilft bislang aber leider überhaupt nicht.

Noch eine Frage: Ist das nun "nur" ein lokales Problem?
 

tombe

Erfahrenes Mitglied
Die Frage ob generell keine ASP Dateien ausgeführt werden hast du bislang weder mt Ja noch mit Nein beantwortet. Deshalb ging ich davon aus (und tu es noch immer) das es ein lokales Problem ist weil kein Server installiert ist bzw. dieser nicht richtig arbeitet.

Wenn du die Dateien irgendwann mal online stellst, muss dort natürlich gewährleistet sein das ASP unterstützt und ausgeführt wird.
 

Skandinavika

Mitglied
Die Frage ob generell keine ASP Dateien ausgeführt werden hast du bislang weder mt Ja noch mit Nein beantwortet.

Nein, generell gilt das nicht. Die Website besteht von default.html einmal abgesehen, nur aus aspx-Seiten und den zugehörigen master-Seiten. In der Browser-Vorschau hat immer alles einwandfrei funktioniert. Erst als ich die Startseite angelegt und mit den aspx-Seiten verlinkt habe, traten in der Browser-Vorschau die beschriebenen Probleme auf, deshalb war ich einigermaßen überrascht, dass es überhaupt ein Problem gibt.
 
Zuletzt bearbeitet:

Luzie

Erfahrenes Mitglied
Hi
also mit Deinen Angaben kann man nicht wirklich viel anfangen.

Wie verlinkst Du denn? Über Controls? eher unwahrscheinlich von einer html-Seite.
Was ist das für eine neue Startseite? Eine aspx-Seite?
Wie arbeitest Du denn lokal? Mit dem Visual Web Developer 2005 oder höher? Dort ist übrigens ein lokaler Server installiert eben für lokale Anwendungen. Fehler werden dir dort direkt im Projekt präsentiert.
 

Skandinavika

Mitglied
Hallo, Luzie!

Ich habe beim Erstellen der Website mit den Masterseiten und den daraus generierten Unterseiten (. B. contact.aspx) angefangen, und erst danach die Startseite angefügt (default.html). Und eben die Links von default.hml nach z.B. contact.aspx funktionieren nicht.

Beispiel für einen solchen Link:
<a href="seiten_allgemein/contact.aspx" target="_blank">Kontakt</a>
oder:
<a href="seiten_holzbau_zimmerei/holzbau_zimmerei.aspx" target="_blank">
<img src="images/holzbau_balken_default.gif" alt="Holzbau & Zimmerei"
width="200px" height="775px" id="img1"
onmouseout="FP_swapImgRestore()"
onmouseover="FP_swapImg(1,1,/*id*/'img1',/*url*/'images/holzbau_balken_defaultsw.gif')" class="style1"
onclick="FP_playSound(/*url*/'seiten_allgemein/ding.wav')"/>
</a>

Ich arbeite übrigens mit Expression Web 2. IIS habe ich mittlerweile installiert, aber ich habe keinen Dunst, wie ich da Einstellungen vornehmen soll. Seit der Installation funktionieren nun Dinge nicht, die vorher reibungslos funktioniert haben (z. B. Klappmenus auf den aspx-Seiten).

Kannst du mir weiterhelfen?
 

Luzie

Erfahrenes Mitglied
Hi

eigentlich bist Du hier im falschen Board.
Es gibt ja für NET eine extra Abteilung im Forum.
Dort sitzen auch die Profis :) Vielleicht verschiebt Dich ja mal jemand dahin.
Vielleicht haben die noch andere Ideen außer Tombe und mir.

Ich arbeite noch nicht sehr lange mit ASP.NET.

Vielleicht solltest Du Dir mal den aktuellen Visual Web Developer herunterladen. Dort ist ein Server eingebaut. Ich finde das Tool einfach supergut. Es generiert Dir Applikationen, es zeigt Dir mögliche Fehler an, hat eine hervorragende Intelisense und und und... Zumindest hast Du so das Problem mit der lokalen Serveradministration nicht.

Also wenn das Verlinken innerhalb der aspx-Seiten funktioniert, warum legst Du Dir nicht als Startseite eine default.aspx an?
 

Neue Beiträge