Andere Browser andere Sitten

zyclop

Erfahrenes Mitglied
Hallo zusammen

ich habe das Problem das meine Website unter Chrome korrekt angezeigt wird und unter FF und IE überhaupt nicht. Der ganze Content rutscht nach unten. Ich habe jetzt mehrere Sachen versucht, auch mit dem Bugzilla komm ich nicht weiter.
Hat jemand eine Idee?

Link:

grz zyclop
 
Zuletzt bearbeitet:

zyclop

Erfahrenes Mitglied
Das Problem erscheint mit allen IE und FF Versionen.

Was mir komisch erscheint ist, dass die CSS Includes und Scripts anstatt vor dem Body Tag, danach folgen. Das ist komisch. Ich habe alles nochmals kontrolliert. Alle CSS Includes und Scripts Includes sind im Header. Beim Anzeigen mit Bugzilla werden sie jedoch im Body Tag angezeigt. Strange ist es schon. Und vorallem erscheint einfach dieses Zeichen ( ). Obwohl ich die Seite UTF-8 ohne BOM gespeichert habe.



Seht euch mal die Seite an. Ist schei***, weil da doch einige Buchungen laufen. Wäre cool wenn mir jemand helfen kann.
 
M

Maik

Moin,

an deiner Stelle würde ich erstmal das Markup validieren, denn laut dem Validator stimmt da u.a. mit deinen DIV-Blöcken etwas nicht.

Von daher verschiebe ich den Thread vom CSS-Forum ins HTML-Forum, da ich in deinem Stylesheet auch keinen Fehler entdecken kann, der für dieses Darstellungsproblem verantwortlich wäre.

Desweiteren taucht in deinem UTF8-Dokument ein "Byte Order Mark" auf, zu erkennen an der Zeichenfolge vor dem Doctype, womit die IE-Familie in den Quirksmode schaltet, was in ihnen negative Auswirkungen hat:

Code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">


mfg Maik
 
Zuletzt bearbeitet von einem Moderator:

zyclop

Erfahrenes Mitglied
Hab den Fehler gefunden.

Fehler erzeugte dieser Code:

HTML:
<div>
<img src="images/nav/..._<?=$forth_lang;?>.gif" alt="..." width="120" /></a>
</li>
</div>

Hab es so geändert
HTML:
<img src="images/nav/..._<?=$forth_lang;?>.gif" alt="..." width="120" /></a>
</li>

Obwohl das Div sauber gespeichert wurde erschien es auch korrekt, aber verrupfte das ganze Layout. Die Hyroglyphen sind immer noch da. Mach mich mal schlau wie ich dieses Lösen kann. Weiter muss ich den Markup noch mehr verbessern. Sieht schon aus, aber bei manchen sachen weiss ich auch nicht was ich da falsch gemacht habe. Z.B. bei folgenden:

Line 1, Column 1: character "ï" not allowed in prolog
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://ww…

Das Sieht bei mir so aus:
<meta http-equiv="content-type" content="text/html; charset=UTF-8"/>

Error Line 2, Column 13: there is no attribute "XMLNS"
<html xmlns="http://www.w3.org/1999/xhtml">

Der Fehler:

You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead).

This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information.

How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute. If you received this error when using the <embed> element to incorporate flash media in a Web page, see the FAQ item on valid flash.

Verstehe das nicht ganz. Wenn jemand lust hat mir bei der korrektur dieses Markups zu helfen wäre ich sehr dankbar.

gruss zyclop

Danke Maik, dieses mal habe ich gedacht ich hätte alles versucht, aber vor lauter bäumen habe ich den Validator total vergessen.

Hab den Fehler des Divs gefunden.
Ich habe das Div nach dem Link aber vor dem Bild gemacht. Darum sollte es so aussehen.

HTML:
<div>
	<li><a onclick="window.open(this.href,'af','resizable=no,location=no,menubar=no,scrollbars=auto,status=no,toolbar=no,fullscreen=no,dependent=no,width=920,height=600,status'); return false" href="booking/">
	<img src="images/nav/Ancona-Durres--Bari-Durres_<?=$forth_lang;?>.gif" alt="Ancona - Durres / Bari - Durres" width="120" /></a>
	</li>
</div>

Vorher war es so
HTML:
	<li><a onclick="window.open(this.href,'af','resizable=no,location=no,menubar=no,scrollbars=auto,status=no,toolbar=no,fullscreen=no,dependent=no,width=920,height=600,status'); return false" href="booking/">
<div>
	<img src="images/nav/Ancona-Durres--Bari-Durres_<?=$forth_lang;?>.gif" alt="Ancona - Durres / Bari - Durres" width="120" /></a>
	</li>
</div>

Das geht natürlich nicht :S
 
M

Maik

Line 1, Column 1: character "ï" not allowed in prolog
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://ww…

Das Sieht bei mir so aus:
<meta http-equiv="content-type" content="text/html; charset=UTF-8"/>

Error Line 2, Column 13: there is no attribute "XMLNS"
<html xmlns="http://www.w3.org/1999/xhtml">

[...]

Verstehe das nicht ganz. Wenn jemand lust hat mir bei der korrektur dieses Markups zu helfen wäre ich sehr dankbar.

gruss zyclop
Beim utf8-kodierten Speichern muß die Option "UTF8 ohne BOM" gewählt werden.

mfg Maik
 

zyclop

Erfahrenes Mitglied
Wenn ich das mache erhalte ich folgende Meldung:

Warning Character Encoding mismatch!

The character encoding specified in the HTTP header (iso-8859-1) is different from the value in the XML declaration (utf-8). I will use the value from the HTTP header (iso-8859-1).

Habe es dann auf das geändert:

<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">

Und das File als ANSI gespeichert.

Fehler ist aber immernoch der selbe.

Strange nicht?

grz
 
Zuletzt bearbeitet:
M

Maik

Und das File als ANSI gespeichert.

Fehler ist aber immernoch der selbe.

Strange nicht?
Hast du auch die übrigen Komponenten, die in die Seite includet werden, auf "ANSI" umgestellt? Ich erinnere mich da beispielsweise an ein JS-File.

Gut möglich, dass du auch zunächst erstmal die BOM-Syntax vor dem Speichern aus dem Quellcode entfernen mußt.

mfg Maik
 

zyclop

Erfahrenes Mitglied
Jap. Habe alle Seiten gestartet und als ANSI gespeichert. Komisch nicht...kannst du mir evtl. zu den anderen Fehlern noch tipps geben`?

grz zyclop
 

Sven Mintel

Mitglied
Moin,

Jap. Habe alle Seiten gestartet und als ANSI gespeichert. Komisch nicht...kannst du mir evtl. zu den anderen Fehlern noch tipps geben`?

grz zyclop

Mit welchem Editor arbeitest du?
Wir hatten schon öfters Themen mit änlicher Problematik, wo bspw. Dreamweaver Dokumente anders(Zeichensatz,BOM) speicherte, als eigentlich angegeben.
Mein Editor sagt mir bspw. das gleiche wie der Validator---das Dokument ist in UTF8.

Vorschlag: probiere mal einen anderen Editor.
 

zyclop

Erfahrenes Mitglied
Hallo zusammen

Ich arbeite mit dem Notepad. Gut dann werde ich es einmal mit einem anderen versuchen. Hat jemand einen guten Vorschlag?

grz zyclop