3d-verschiebung und multimaterial...

hackler

Mitglied
hallo leute,
und wieder mal eine anfängerfrage....:)
ich ärgere mich jetzt schon eine zeit lang mit 3d-verschiebungen in einem untermaterial in einem multimaterial herum. hat man das map aktiviert, werden sämtliche oberflächen des multimaterials vollkommen unkenntlich gerendert.
bei einem normalen material funktioniert die 3d-verschiebung wunderbar, bloß hilft mir das jetzt nichts, weil ich multimaterial verwende....
kann es sein, daß das irgendwie ein fehler im programm ist, oder hab ich da was wesentliches übersehen? :confused:
bin gespannt, ob schon mal jemand ein ähnliches problem hatte!
grüße hackler
 

locat

Grünschnabel
Heisst das du hast z.B. eine Landschaft mit mehreren Materialien die aber nicht korrekt angezeigt werden oder wie?

Z.B. Ebene -> 3D-Versch. > Poly bearbeiten (Materialien festgelegt) -> UVW-Mapping

Und trotzdem sieht man die Konturen der aufgelegten Maps nicht?
Falls das so ist, schau mal beim "UVW-Mapping" ob du es vernüftig eingepasst hast und evt. muss der Hacken "Originalgröße des Map" rausgenommen werden.
Bei mir gehts so.
 

hackler

Mitglied
nene,
so einfach ist die sache leider nicht.
in meinem fall handelt es sich um ein gebäude, wobei jede wand ein eigenes material mit eigenem map ist. das ding ist als bearbeitbares netz aufgebaut. solang jetzt noch kein 3d-verschiebungsmap drauf ist funktionierts tadellos. wenn ich aber bei einem einzigen untermaterial ein 3d-versch.map dazugebe, werden sämtliche wände vollkommen falsch gemappt.
d.h.3d-verschiebung allein machts noch nicht -- der effekt tritt auf wenn ich in den oberflächeneigenschaft des netzobjekts die option "unterteilungs-3d-verschiebung" aktiviere.
hatte mir schon gedacht, daß die sache mit 3d-versch. an sich komplizierter ist, aber bei einfachen materialien funktionierts vollkommen problemlos.
--> sehr seltsam! :confused:
 

cycovery

Erfahrenes Mitglied
Mach nen screenshot des Material/Map Navigators (die zwei kleinen kügelchen im mapeditor) von deinem KOMPLETTEN Multimaterial und zeig das zusammen mit einem rendering des problems.
 

hackler

Mitglied
so,
hoffe, das problem wird dadurch deutlich. der einzige unterschied zwischen den beiden renderings ist das häkchen bei den oberflächeneigenschaften "unterteilungs-3d-versch.".
braucht es da noch einen zusätzlichen modfikator?
wie gesagt, bei einem einfachen material funktionierts wunderbar.
vielen dank schon mal für die bemühungen!
 

Anhänge

  • screenshot.jpg
    screenshot.jpg
    109,4 KB · Aufrufe: 48
  • ohne_3Dverschiebung.jpg
    ohne_3Dverschiebung.jpg
    36,8 KB · Aufrufe: 39
  • mit_3Dverschiebung.jpg
    mit_3Dverschiebung.jpg
    18,6 KB · Aufrufe: 35

hackler

Mitglied
uije,
hat niemand eine idee, was da schief läuft? die einzige möglichkeit, die ich dann seh, um die 3d-maps reinzukriegen, ist wohl, daß ich von hand die flächenzahl im netz erhöhe.
überhaupt gar keine angenehme methode.... :eek:
 

cycovery

Erfahrenes Mitglied
benutzt du etwa oberhalb deiner uvw-map modifier irgend einen modifier der die topologie deines meshs verändert?
 

hackler

Mitglied
aha, und schon wieder etwas schlauer.
hab die sache jetzt an einem kleinen testobjekt nochmal ausprobiert.
--> mit mapping koordinaten, die in die geometrie eingebettet sind funktionierts. mit uvw-map-modifikatoren nicht. ganz schön lästig!
mit diesen chanel-geschichten hab ich mich leider noch nie ausgekannt...:confused:
 

Zinken

Erfahrenes Mitglied
Kann es sein, daß Du einfach 20 UVW-Modifikatoren mit dem gleichen Map-Channel übereinenader gestapelt hast?
Das würde Dein Problem schon erklären. In dem Fall werden die Koordinaten ja immer wieder überschrieben und nur der oberste Modifikator hat überhaupt Auswirkungen auf das Objekt.
Wenn Deine Wandflächen jeweils nur aus einem einzelnenPolygon bestehen, reicht ein einziger UVW-Map-Modifikator, den Du auf 'Fläche/Face' stellt.
Eventuell mußt Du dann noch die Drehung Deiner Maps im Materialeditor anpassen.
Ansonsten bleibt eigentlich nur der Weg über 'UVW zuweisen / Unwrap UVW' und Handarbeit.
Oder halt 20 mal UVW-Map mit 20 verschiedenen Kanälen - was ich allerdings eher nicht empfehlen würde. Dabei mußt Du dann im Materialeditor in den Bitmap-Eigenschaften
auch jeweils den zugehörigen Kanal einstellen.
 
Zuletzt bearbeitet: