Debian 9 Update Problem?


Status
Dieses Thema wurde gelöst! Zur Lösung gehen…

Shorty1968

Erfahrenes Mitglied
#1
Hallo ich versuche meinen Server einem Update zu Unterziehen von Debian 8 zu Debian 9 und zwar wen ich in Putty an Folgendem Punkt komme Package configuration,dort wähle ich eine Sprache aus drücke Enter und komme immer wider in das Erste Fenster es geht einfach nicht weiter.

Wie komme ich weiter oder kann das Überspringen das das Update weiter geht?
 

Anhänge

Shorty1968

Erfahrenes Mitglied
#3
Ich bin wie folgt vorgegangen,ich habe im Ersten Fenster mit der Enter Taste das <OK> angeklickt dann im Zweiten fenster mit der Tab Taste das <OK> makiert und Enter gedrückt danach sprang es wider zum Ersten Fenster und so geht es immer und immer wider.
 

Technipion

Erfahrenes Mitglied
#4
Das ist eine klassische Listbox im Terminal. Du musst mit Leertaste Optionen aus-/abwählen (angezeigt durch ein Sternchen in ihrer [ ]-Box) und dann mit Pfeiltaste Rechts auf das Ok wechseln und durch Enter bestätigen.
 

Shorty1968

Erfahrenes Mitglied
#6
Sorry muss mich noch mal melden,das Update hat geklappt aber nun schein ich ein Problem mit dem Plesk Installer zu haben.

wen ich den aufrufe über Plesk und etwas Installieren möchte bekomme ich.

Installation wird nicht fortgesetzt

Die Ausführung von apg-get ist mit folgender Meldung fehlgeschlagen:
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
plesk-php70-imagick : Depends: libmagickcore-6.q16-3 (>= 8:6.9.6.8) but it is not going to be installed
Depends: libmagickwand-6.q16-3 (>= 8:6.9.6.8) but it is not going to be installed
plesk-php71-imagick : Depends: libmagickcore-6.q16-3 (>= 8:6.9.6.8) but it is not going to be installed
Depends: libmagickwand-6.q16-3 (>= 8:6.9.6.8) but it is not going to be installed
plesk-php72-imagick : Depends: libmagickcore-6.q16-3 (>= 8:6.9.6.8) but it is not going to be installed
Depends: libmagickwand-6.q16-3 (>= 8:6.9.6.8) but it is not going to be installed
 

Shorty1968

Erfahrenes Mitglied
#7
*EDIT*
Ich konnte den Fehler beheben,ich weiss nun aber nicht genau ob es das enfernen von PHP7 war oder folgender Shell befehl apt-get update && apt-get dist-upgrade
 
Zuletzt bearbeitet:

Shorty1968

Erfahrenes Mitglied
#8
Installation wird nicht fortgesetzt

Die Ausführung von apg-get ist mit folgender Meldung fehlgeschlagen:
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
plesk-php70-imagick : Depends: libmagickcore-6.q16-3 (>= 8:6.9.6.8) but it is not going to be installed
Depends: libmagickwand-6.q16-3 (>= 8:6.9.6.8) but it is not going to be installed
plesk-php71-imagick : Depends: libmagickcore-6.q16-3 (>= 8:6.9.6.8) but it is not going to be installed
Depends: libmagickwand-6.q16-3 (>= 8:6.9.6.8) but it is not going to be installed
plesk-php72-imagick : Depends: libmagickcore-6.q16-3 (>= 8:6.9.6.8) but it is not going to be installed
Depends: libmagickwand-6.q16-3 (>= 8:6.9.6.8) but it is not going to be installed
Das ist nun wider da und ich weiss nicht wie oder was ich da beheben beziehungsweisse Installieren kann/muss?
 

Technipion

Erfahrenes Mitglied
#9
Ganz ruhig Shorty, das klingt als hättest du dich beim Installieren irgendwo verzettelt.

Also zunächst aktualisierst du mal die Paketlisten:
Bash:
sudo apt update
Jetzt versuchst du mal das System auf den neuesten Stand zu bringen:
Bash:
sudo apt upgrade
Wahrscheinlich werden da jetzt Fehler angezeigt. Versuche dann mal sie zu beheben:
Bash:
sudo apt -f install
Danach nochmal sudo apt upgrade versuchen. Werden dann noch Fehler angezeigt?

Gruß Technipion
 

Shorty1968

Erfahrenes Mitglied
#10
Vielen dank ich musste deine befehle ohne sudo mit sudo gingen sie leider nicht.

Das ergebniss nach dem letzten apt upgrade ist wie Folgt.
Code:
root@computer-fun-area:~# apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  passenger-dev plesk-dovecot plesk-modsecurity-crs plesk-php71-bcmath
  plesk-php71-dba plesk-php71-enchant plesk-php71-ldap plesk-php71-mbstring
  plesk-php71-mysql plesk-php71-odbc plesk-php71-opcache plesk-php71-pdo
  plesk-php71-pspell plesk-php71-soap plesk-php71-xml plesk-php71-xmlrpc
  plesk-php72-dba plesk-php72-enchant plesk-php72-ldap plesk-php72-mbstring
  plesk-php72-mysql plesk-php72-odbc plesk-php72-opcache plesk-php72-pdo
  plesk-php72-pgsql plesk-php72-process plesk-php72-pspell plesk-php72-soap
  plesk-php72-xmlrpc plesk-php73-bcmath plesk-php73-dba plesk-php73-enchant
  plesk-php73-ldap plesk-php73-mbstring plesk-php73-mysql plesk-php73-odbc
  plesk-php73-opcache plesk-php73-pdo plesk-php73-pgsql plesk-php73-process
  plesk-php73-pspell plesk-php73-soap plesk-php73-xml plesk-php73-xmlrpc
  psa-horde
0 upgraded, 0 newly installed, 0 to remove and 45 not upgraded.
N: Ignoring file 'plesk.list.ai_back' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'plesk.list.ai_back' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
Ich bekomme beim Plesk Installer in Plesk Folgendes angezeigt.
Code:
Für Ihr Betriebssystem 
( 'Debian' 'Linux' '9.8' 'x86_64' ) sind keine Produkte
 von der ausgewählten Quelle verfügbar.

Sie können versuchen, eine andere Quelle zu verwenden.
 

Technipion

Erfahrenes Mitglied
#13
Okay. Also es gäbe noch die Holzhammermethode sudo apt dist-upgrade, allerdings kann die auch Pakete entfernen und in (ganz) seltenen Fällen sogar das System zerschießen.

Die "schönere" Variante wäre, wenn du einfach die zurückgehaltenen Pakete manuell installierst. Also
Bash:
sudo apt install passenger-dev plesk-dovecot plesk-modsecurity-crs plesk-php71-bcmath \
  plesk-php71-dba plesk-php71-enchant plesk-php71-ldap plesk-php71-mbstring \
  plesk-php71-mysql plesk-php71-odbc plesk-php71-opcache plesk-php71-pdo \
  plesk-php71-pspell plesk-php71-soap plesk-php71-xml plesk-php71-xmlrpc \
  plesk-php72-dba plesk-php72-enchant plesk-php72-ldap plesk-php72-mbstring \
  plesk-php72-mysql plesk-php72-odbc plesk-php72-opcache plesk-php72-pdo \
  plesk-php72-pgsql plesk-php72-process plesk-php72-pspell plesk-php72-soap \
  plesk-php72-xmlrpc plesk-php73-bcmath plesk-php73-dba plesk-php73-enchant \
  plesk-php73-ldap plesk-php73-mbstring plesk-php73-mysql plesk-php73-odbc \
  plesk-php73-opcache plesk-php73-pdo plesk-php73-pgsql plesk-php73-process \
  plesk-php73-pspell plesk-php73-soap plesk-php73-xml plesk-php73-xmlrpc \
  psa-horde
Das sollte das Problem eigentlich lösen. Und weil du viel gebastelt hast, gibt es bestimmt auch noch einiges mit sudo apt autoremove aufzuräumen.
 

Shorty1968

Erfahrenes Mitglied
#14
Kann es sein das eventuell das Plesk welches noch von Debian 8 ist zu Probleme führt und für das Debian 9 noch ein Update benötigt den es kommt immer noch zu Fehlern.
Code:
root@computer-fun-area:~# apt install passenger-dev plesk-dovecot plesk-modsecurity-crs plesk-php71-bcmath \
>   plesk-php71-dba plesk-php71-enchant plesk-php71-ldap plesk-php71-mbstring \
>   plesk-php71-mysql plesk-php71-odbc plesk-php71-opcache plesk-php71-pdo \
>   plesk-php71-pspell plesk-php71-soap plesk-php71-xml plesk-php71-xmlrpc \
>   plesk-php72-dba plesk-php72-enchant plesk-php72-ldap plesk-php72-mbstring \
>   plesk-php72-mysql plesk-php72-odbc plesk-php72-opcache plesk-php72-pdo \
>   plesk-php72-pgsql plesk-php72-process plesk-php72-pspell plesk-php72-soap \
>   plesk-php72-xmlrpc plesk-php73-bcmath plesk-php73-dba plesk-php73-enchant \
>   plesk-php73-ldap plesk-php73-mbstring plesk-php73-mysql plesk-php73-odbc \
>   plesk-php73-opcache plesk-php73-pdo plesk-php73-pgsql plesk-php73-process \
>   plesk-php73-pspell plesk-php73-soap plesk-php73-xml plesk-php73-xmlrpc \
>   psa-horde
Reading package lists... Done
Building dependency tree
Reading state information... Done
plesk-modsecurity-crs is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 passenger-dev : Depends: passenger (= 5.3.5-debian9.0.18110217) but 5.3.5-debian8.0.18110217 is to be installed
 plesk-dovecot : Depends: plesk-dovecot-core (= 2.3.4.1-debian9.0.19031416) but 2.3.4.1-debian8.0.19031416 is to be installed
 plesk-php71-bcmath : Depends: plesk-php71 (= 7.1.28-debian.9.190405.1021) but 7.1.28-debian.8.190405.1021 is to be installed
 plesk-php71-dba : Depends: plesk-php71 (= 7.1.28-debian.9.190405.1021) but 7.1.28-debian.8.190405.1021 is to be installed
 plesk-php71-enchant : Depends: plesk-php71 (= 7.1.28-debian.9.190405.1021) but 7.1.28-debian.8.190405.1021 is to be installed
 plesk-php71-ldap : Depends: plesk-php71 (= 7.1.28-debian.9.190405.1021) but 7.1.28-debian.8.190405.1021 is to be installed
 plesk-php71-mbstring : Depends: plesk-php71 (= 7.1.28-debian.9.190405.1021) but 7.1.28-debian.8.190405.1021 is to be installed
 plesk-php71-mysql : Depends: plesk-php71 (= 7.1.28-debian.9.190405.1021) but 7.1.28-debian.8.190405.1021 is to be installed
 plesk-php71-odbc : Depends: plesk-php71 (= 7.1.28-debian.9.190405.1021) but 7.1.28-debian.8.190405.1021 is to be installed
 plesk-php71-opcache : Depends: plesk-php71 (= 7.1.28-debian.9.190405.1021) but 7.1.28-debian.8.190405.1021 is to be installed
 plesk-php71-pdo : Depends: plesk-php71 (= 7.1.28-debian.9.190405.1021) but 7.1.28-debian.8.190405.1021 is to be installed
 plesk-php71-pspell : Depends: plesk-php71 (= 7.1.28-debian.9.190405.1021) but 7.1.28-debian.8.190405.1021 is to be installed
 plesk-php71-soap : Depends: plesk-php71 (= 7.1.28-debian.9.190405.1021) but 7.1.28-debian.8.190405.1021 is to be installed
 plesk-php71-xml : Depends: plesk-php71 (= 7.1.28-debian.9.190405.1021) but 7.1.28-debian.8.190405.1021 is to be installed
 plesk-php71-xmlrpc : Depends: plesk-php71 (= 7.1.28-debian.9.190405.1021) but 7.1.28-debian.8.190405.1021 is to be installed
 plesk-php72-dba : Depends: plesk-php72 (= 1:7.2.17-debian.9.190405.1021) but 1:7.2.17-debian.8.190405.1021 is to be installed
 plesk-php72-enchant : Depends: plesk-php72 (= 1:7.2.17-debian.9.190405.1021) but 1:7.2.17-debian.8.190405.1021 is to be installed
 plesk-php72-ldap : Depends: plesk-php72 (= 1:7.2.17-debian.9.190405.1021) but 1:7.2.17-debian.8.190405.1021 is to be installed
 plesk-php72-mbstring : Depends: plesk-php72 (= 1:7.2.17-debian.9.190405.1021) but 1:7.2.17-debian.8.190405.1021 is to be installed
 plesk-php72-mysql : Depends: plesk-php72 (= 1:7.2.17-debian.9.190405.1021) but 1:7.2.17-debian.8.190405.1021 is to be installed
 plesk-php72-odbc : Depends: plesk-php72 (= 1:7.2.17-debian.9.190405.1021) but 1:7.2.17-debian.8.190405.1021 is to be installed
 plesk-php72-opcache : Depends: plesk-php72 (= 1:7.2.17-debian.9.190405.1021) but 1:7.2.17-debian.8.190405.1021 is to be installed
 plesk-php72-pdo : Depends: plesk-php72 (= 1:7.2.17-debian.9.190405.1021) but 1:7.2.17-debian.8.190405.1021 is to be installed
 plesk-php72-pgsql : Depends: plesk-php72 (= 1:7.2.17-debian.9.190405.1021) but 1:7.2.17-debian.8.190405.1021 is to be installed
 plesk-php72-process : Depends: plesk-php72 (= 1:7.2.17-debian.9.190405.1021) but 1:7.2.17-debian.8.190405.1021 is to be installed
 plesk-php72-pspell : Depends: plesk-php72 (= 1:7.2.17-debian.9.190405.1021) but 1:7.2.17-debian.8.190405.1021 is to be installed
 plesk-php72-soap : Depends: plesk-php72 (= 1:7.2.17-debian.9.190405.1021) but 1:7.2.17-debian.8.190405.1021 is to be installed
 plesk-php72-xmlrpc : Depends: plesk-php72 (= 1:7.2.17-debian.9.190405.1021) but 1:7.2.17-debian.8.190405.1021 is to be installed
 plesk-php73-bcmath : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-dba : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-enchant : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-ldap : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-mbstring : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-mysql : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-odbc : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-opcache : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-pdo : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-pgsql : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-process : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-pspell : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-soap : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-xml : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 plesk-php73-xmlrpc : Depends: plesk-php73 (= 1:7.3.4-debian.9.190405.1021) but 1:7.3.4-debian.8.190405.1021 is to be installed
 psa-horde : Depends: psa-php-configurator but it is not going to be installed
N: Ignoring file 'plesk.list.ai_back' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'plesk.list.ai_back' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: Unable to correct problems, you have held broken packages.
root@computer-fun-area:~# apt autoremove
E: Invalid operation autoremove
root@computer-fun-area:~# apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  passenger-dev plesk-dovecot plesk-php71-bcmath plesk-php71-dba
  plesk-php71-enchant plesk-php71-ldap plesk-php71-mbstring plesk-php71-mysql
  plesk-php71-odbc plesk-php71-opcache plesk-php71-pdo plesk-php71-pspell
  plesk-php71-soap plesk-php71-xml plesk-php71-xmlrpc plesk-php72-dba
  plesk-php72-enchant plesk-php72-ldap plesk-php72-mbstring plesk-php72-mysql
  plesk-php72-odbc plesk-php72-opcache plesk-php72-pdo plesk-php72-pgsql
  plesk-php72-process plesk-php72-pspell plesk-php72-soap plesk-php72-xmlrpc
  plesk-php73-bcmath plesk-php73-dba plesk-php73-enchant plesk-php73-ldap
  plesk-php73-mbstring plesk-php73-mysql plesk-php73-odbc plesk-php73-opcache
  plesk-php73-pdo plesk-php73-pgsql plesk-php73-process plesk-php73-pspell
  plesk-php73-soap plesk-php73-xml plesk-php73-xmlrpc psa-horde
0 upgraded, 0 newly installed, 0 to remove and 44 not upgraded.
N: Ignoring file 'plesk.list.ai_back' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'plesk.list.ai_back' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
 

Technipion

Erfahrenes Mitglied
#15
Ich habe mal schnell gegoogelt. Bin z.B. hier gelandet:
Unable to upgrade/install Plesk on Ubuntu/Debian: the following packages have unmet dependencies
Oder hier:
Plesk update fails: The following packages have unmet dependencies

Es scheint da wohl öfters vorzukommen, dass Paketquellen falsch konfiguriert werden. Beim Plesk-Support hat man geraten, den Systemadministrator darüber zu informieren. Ist vielleicht das klügste Shorty, bevor du jetzt manuell in der /etc/apt/sources.list rumhantierst. Gibt es einen Admin den du anschreiben kannst?
 

Shorty1968

Erfahrenes Mitglied
#16
Nein ich bin der Admin und ich mache es Learning by Doing,nur das was da steht habe ich alles schon durch und laut Google passt das was in meiner /etc/apt/sources.list1 steht und bei mir heist sie sources.list1 warum auch immer.
 

Technipion

Erfahrenes Mitglied
#17
Okay daran sind gleich mehrere Dinge merkwürdig. Du bist der Admin aber kein sudoer? Machst du das etwa alles als root?

Außerdem: Die Konfiguration mit deinen Paketlisten kommt mir komisch vor. Kannst du mal die Ausgabe von den folgenden beiden Kommandos posten?
Bash:
ls -a /etc/apt/
cat /etc/apt/sources.list
Gruß Technipion
 

Shorty1968

Erfahrenes Mitglied
#18
Ja mache das alles in root was ist falsch daran?

Ich versuche gerade
Code:
plesk repair all
wenn das durch ist und auch nicht Hilfe mache ich das von dir.

*EDIT*
Code:
root@computer-fun-area:~# ls -a /etc/apt/
.           listchanges.conf  sources.list1   trusted.gpg~
..          preferences.d     sources.list.d  trusted.gpg.d
apt.conf.d  sources.list~     trusted.gpg
 

Technipion

Erfahrenes Mitglied
#19
Okay. Ja versuch ruhig.

Ja mache das alles in root was ist falsch daran?
Jein. Eigentlich ist es guter Stil auf den root-Account möglichst zu verzichten. Am besten ihn sogar komplett von der SSH sperren. Also mein beherzter Tipp an dich: Richte dir einen Benutzeraccount ein (z.B. "shorty") und gib ihm sudo-Rechte. Danach kannst du in der SSH-Konfiguration den root-Account sperren.

Weil ich nehme mal stark an du bist mit der Maschine am Netz?

Mit grep "Failed" /var/log/auth.log kannst du dir anzeigen lassen, wie oft jemand versucht hat sich als root einzuloggen aber das falsche Passwort hatte. In der Regel werden Server die am Netz sind regelrecht bombardiert von Botnetzen. Und wenn du jetzt auch noch ein "schwaches" root-Passwort hast (schwach heißt hier <= 16 Zufallszeichen) blüht dir unter Umständen übles.
Auf meinem vServer hab ich gerade mal sudo grep "Failed" /var/log/auth.log | wc -l ausgeführt. Sind innerhalb von 2 Tagen jetzt schon wieder 26.944 Loginversuche. Es gibt da zwar Techniken (z.B. fail2ban) aber der beste Schutz ist, wenn gar kein root-Account aktiv ist.
Kannst ja die Tage hier nen neuen Thread aufmachen, falls du das tun willst.
 

Shorty1968

Erfahrenes Mitglied
#20
Ich werde deinen Tip umsetzen,sofern ich es hin bekomme habe es noch nie gemacht.

Ich habe versucht meinen vServer mal Komplett Neu mit Debian 9 und Plesk auf zu setzen da habe ich genau die selben Probleme und sogar noch mehr z.b. lässt sich da sogar das FTP Passwort eines Kunden nicht mehr ändern.
 
Status
Dieses Thema wurde gelöst! Zur Lösung gehen…