1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Zählenwenns mit Datum

Dieses Thema im Forum "Office-Anwendungen" wurde erstellt von jerry0110, 7. Februar 2018.

  1. jerry0110

    jerry0110 Erfahrenes Mitglied

    Hallo zusammen,

    ich habe eine Frage zu Zählenwenns.

    Ich habe folgende Formel:

    Code (Text):
    1. =ZÄHLENWENNS('SQL-Ergebnisse'!$B:$B;">=1.7.2017";'SQL-Ergebnisse'!$B:$B;"<1.8.2017";'SQL-Ergebnisse'!$D:$D;"A1")+ZÄHLENWENNS('SQL-Ergebnisse'!$B:$B;">=1.7.2017";'SQL-Ergebnisse'!$B:$B;"<1.8.2017";'SQL-Ergebnisse'!$D:$D;"A2")
    In Spalte B der SQL ist das Datum. In Spalte D ein Ergebnis.
    In meiner Tabelle habe ich jetzt am Anfagen z. B. Juli stehen. Und ich möchte alle aus Juli haben. So ist der o. g. Code entstanden. Jetzt möchte ich mir das gerne noch vereinfachen, weil ich ja noch weitere Monate habe und statt im Code ">=1.7.2017" -> A19 schreiben, weil auf A19 Juli steht. Und dann bei "<1.8.2017" -> A20 schreiben.

    Das klappt leider nicht. Ich habe alles ausprobiert. Aber er setzte alles in Anführungsstriche, somit wird der Wert der Zelle nicht ausgelesen. Gibt es dafür irgendeine Lösung?
     
  2. Yaslaw

    Yaslaw n/a Moderator

    Was genau steht in A19?
    Ich sehe da 3 Möglicheiten und alle müssten verschieden gehandhabt werden:
    1. "Juli"
    2. "01.07.2017"
    3. 7
    Also, was steht da genau?
     
  3. jerry0110

    jerry0110 Erfahrenes Mitglied

    Juli 2017
     
  4. Yaslaw

    Yaslaw n/a Moderator

    Als Text?
     
  5. jerry0110

    jerry0110 Erfahrenes Mitglied

    Als Datum
     
  6. Yaslaw

    Yaslaw n/a Moderator

    Achso Dann steht der 1.7.2017 dahinter und die Formatierung extrahiert den Monat und das Jahr.
    OK, ich habe eine Lösung. Sie ist aber fürs englische Excel und muss noch umgeschrieben werden.

    Der Punkt ist, dass Ein Datum als Integer-Zahl gespeichert wird. Für den Vergleich muss es aber als Datumstext daherkommen.
    Mein Test: In D2 steht Juli 2017 als Datum:
    Code (Text):
    1. =COUNTIFS(A3:A17;"<" & TEXT(D2; "MM/TT/JJJJ") )
    Im Deutsch heisst es wahrscheinlich
    Code (Text):
    1. =ZÄHLENWENNS(A3:A17;"<" & TEXT(D2; "TT.MM.JJJJ") )
    2. ev auch
    3. =ZÄHLENWENNS(A3:A17;"<" & TEXT(D2; "MM/TT/JJJJ") )
    Hier noch ein Test um es zu veranschaulichen
    2018-02-07_125029.jpg
     
  7. jerry0110

    jerry0110 Erfahrenes Mitglied

    Perfekt, Danke!!! Läuft Anwandfrei. Hier mein Code

    =ZÄHLENWENNS('SQL-Ergebnisse'!$B:$B;">=" & TEXT(A18;"TT.MM.JJJJ");'SQL-Ergebnisse'!$B:$B;"<" & TEXT(A19;"TT.MM.JJJJ");'SQL-Ergebnisse'!$D:$D;"A1")+ZÄHLENWENNS('SQL-Ergebnisse'!$B:$B;">=" & TEXT(A18;"TT.MM.JJJJ");'SQL-Ergebnisse'!$B:$B;"<" & TEXT(A19;"TT.MM.JJJJ");'SQL-Ergebnisse'!$D:$D;"A2")
    Code (Text):
    1. =ZÄHLENWENNS('SQL-Ergebnisse'!$B:$B;">=" & TEXT(A18;"TT.MM.JJJJ");'SQL-Ergebnisse'!$B:$B;"<" & TEXT(A19;"TT.MM.JJJJ");'SQL-Ergebnisse'!$D:$D;"A1")+ZÄHLENWENNS('SQL-Ergebnisse'!$B:$B;">=" & TEXT(A18;"TT.MM.JJJJ");'SQL-Ergebnisse'!$B:$B;"<" & TEXT(A19;"TT.MM.JJJJ");'SQL-Ergebnisse'!$D:$D;"A2")
     
Die Seite wird geladen...