XAMPP PUT Methode not allowed

dsNDesign

Erfahrenes Mitglied
Hei,
ich arbeite gerade mit XAMPP unter Linux.

Wenn ich die PUT Methode ausführen möchte, kommt immer die Fehlermeldung "The PUT method is not allowed for the requested URL."

Ich weiß, dass diese Methoden standardmäßig deaktiviert / eingeschränkt sind, jedoch weiß ich nicht, wie ich diese aktiviere. Kann mir da jemand helfen?

Gruß
 

dsNDesign

Erfahrenes Mitglied
Ich habe jetzt mal in der httpd.conf unter /opt/lampp/etc die <Limit> und <LimitExcept> Zeilen hinzugefügt:

Code:
<Directory "/opt/lampp/htdocs">
    AllowOverride FileInfo AuthConfig Limit
    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
    <Limit PUT DELETE GET POST OPTIONS>
        Order allow,deny
        Allow from all
    </Limit>
    <LimitExcept PUT DELETE GET POST OPTIONS>
        Order deny,allow
        Deny from all
    </LimitExcept>

    Options Indexes FollowSymLinks ExecCGI Includes
    AllowOverride All
    Require all granted
</Directory>

Jedoch ohne Erfolg. Immer noch der Fehler "The PUT method is not allowed..."

UPDATE:
Wenn ich noch "Dav on" hinzufüge, bekomme ich bei der PUT Methode einen 500er Internal Server Error.
The server encountered an internal error and was
unable to complete your request. Either the server is
overloaded or there was an error in a CGI script.

GET und POST funktioniert nach wie vor
 
Zuletzt bearbeitet:

Neue Beiträge