UnsupportedClassVersionError


hippokeng

Grünschnabel
Halleluja!

Beim Verwenden des jdbc-Treibers sqljdbc42.jar mit der Java-Version jdk1.8.0_111 und zugehöriger jre bekomme ich die folgende Fehlermeldung:

UnsupportedClassVersionError: ...jdbc/SQLServerDriver has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0.

Ist denn meine jdk 1.8.0_111 schon sooo alt, oder liegt der Fehler woanders? Kann man sich evtl. auch Treiber runterladen, welche mit einer älteren jre compiliert worden sind?

Vielen Dank und viele Grüße
hippokeng
 

hippokeng

Grünschnabel
Lieber ComFreek,

vielen Dank für Deine Antwort, damit hat's funktioniert. Zwar noch nicht die DB (die habe ich ja auch noch nicht angefaßt :)), aber mindestens einmal das Erkennen des Treibers. Etwas seltsam finde ich diesen Neuerungswahn dennoch, aber dann muß man es wohl mit Einstein halten:

Man muß die Welt nicht verstehen, man muß sich in ihr nur zurechtfinden.

Gruß, hippokeng.
 

Neue Beiträge