unscharfe, pixelige Kanten

thommytomtom

Grünschnabel
hallo...ich bin leider kein großer profi in 3D max und habe auch prombt ein Problem an dem ich scheitere.

Ich habe in rhino ein Modell gebaut und als 3DS in Studio Max exportiert. Soweit so gut. Licht gesetzt, material drauf, global illumination und final gathering an. dann mal gerendert.
und nun das problem:
das fertige rendering hat an einigen kanten extrem unscharfe bzw kantige Ränder bzw schattenverläufe.
Das passiert immer an den Kanten an denen sich zwei flächen 'scheinbar' (im 2d Bild)überlagern. Die anderen werden wunderbar scharf. Ich häng zur erklärung mal ein Bild an.

Interessant ist vielleicht noch, das die final gathering stufe ohne probleme durchläuft und dann von den kaputten kanten nichts zu sehen ist. erst beim eigentlichen rendern tritt der fehler auf.

Weiß jemand einen Rat oder kann mir helfen? Ich hab schon so viel rumprobiert. Aber wie gesagt, ich bin leider kein Profi und kann die meisten Einstellungen nicht einschätzen.

Vielen Dank schon mal...
tom.
 

Anhänge

  • übung1.jpg
    übung1.jpg
    154 KB · Aufrufe: 74

Zinken

Erfahrenes Mitglied
Sieht irgendwie aus, als würdest Du Schattenmaps mit einer unglaublich niedrigen Auflösung benutzen...
Um das Problem einzukreisen, solltest Du erstmal allen Schnickschnack, wie FG und GI, deaktivieren und auch bei der Lichtquelle den Schattenwurf abschalten.
Anschließend mal ein anderes Schattenmodell versuchen (Raytrace) und nacheinander wieder FG und GI aktivieren.
Dann siehst Du ja, an welcher Stelle das Problem auftritt.

Wenn Du bei einer einfachen Lichtquelle mit Raytrace-Schatten auch schon so ein Ergebnis bekommst, kannst Du Dich mal auf die Suche nach deckungsgleichen Polygonen machen.
Hast Du nach dem Import eigentlich ein Polygonodell oder immer noch NURBS?
 

thommytomtom

Grünschnabel
hm...das hab ich teilweise schon probiert.
ich hatte bisher nur ein skylight gesetzt. da kann man die schatten wohl nicht abschalten. jetzt hab ich mal gi und fg ausgeschaltet und einzeln wieder dazu. ohne besserung. anderes licht verwendet: nichts.

an der rhino zeichnung liegt es glaub ich nicht. ich exportiere immer polygone. hatte noch nie probleme dieser art.

wie funktioniert das mit dem raytracing oder shadow mapping? ich habe da schon einiges probiert, aber nie eine wirkliche Änderung festgestellt.

danke für die Hilfe...

tom
 

thommytomtom

Grünschnabel
ha! ich glaube ich habe gerade eine zimelich wichtige Entdeckung gemacht.
ich hatte ja bereits geschrieben, das das Problem immer bei kanten auftritt hinter denen eine fläche liegt (->bild).
die flächen hatten bisher alle das gleiche material. jetzt hab ich das hinten liegende material geändert, und siehe da: die kante ward scharf.

das proclme scheint also da zu liegen, das der renderer beim rendern nicht weiß wie er mit dem übergang an der kante umgehen soll, weil vor und hinter der kante ds gleiche material liegt.

gibt es eine einstellung in der man das regeln kann? ich will nicht jedem objekt ein anderes material geben :(

danke.
tom.