Umfrage: Welche PHP-Version wird verwendet?

Welche PHP-Version wird eingesetzt?

  • PHP 5.3

    Abstimmungen: 7 58,3%
  • PHP 5.3 (mit PHAR)

    Abstimmungen: 1 8,3%
  • PHP 5.2 und kleiner

    Abstimmungen: 4 33,3%
  • PHP 4

    Abstimmungen: 0 0,0%

  • Anzahl der Umfrageteilnehmer
    12

ComFreek

Mod | @comfreek
Moderator
Du schreibst PHP 5.2 und kleiner, wozu hast du denn dann noch PHP 4?
Oder meinstest du mit "kleiner" die Subversionen?
 

Flex

(aka Felix Jacobi)
Das ist so etwas schwierig zu beantworten.

Entwicklungsumgebung läuft mit mehreren PHP Versionen, je nach Bedarf des Produktionsservers. Meist nutze ich die gleiche Version des Live Servers und aus Kompatibilitätsgründen dann noch den aktuellsten 5.3 Build.
Ansonsten kommt es aber leider immer noch manchmal vor, dass ein Kunde PHP4 wünscht... Das ist eigentlich ein Graus, aber manche Leute sehen bis heute den Wechsel nicht ein.

Auf meinem Paket läuft momentan PHP 5.2.9 standardmäßig und ich kann per .htaccess wählen zwischen 5.3.1 und 4.4.9.
 

ComFreek

Mod | @comfreek
Moderator
@saftmeister: Mir ist gerade (ja noch mal ;)) aufgefallen, dass man eine Umfrage zu einem Thread hinzufügen kann, ohne einen neuen zu erstellen. Du musst oben beim Threadanfang auf "Themenoptionen" und dann auf "Umfrage hinzufügen" klicken.
Aber das geht nur, wenn man das Thema selbst erstellt hat.