ubuntu fährt nicht runter


bluex

Erfahrenes Mitglied
#1
Hallo

Mein Ubuntu fährt nicht so ganz runter. Es kommt blos das Ubuntubild und der Balken baut sich ab. Mehr passiert dann nicht. Bild bleibt stehen und Recher läuft weiter.
Woran könnte das liegen? auf meinem laptop hab ich dieses Problem nicht. gollgle spuckt da auch nichts richriges aus und ubuntuusers scheint offline zu sein 0o

MfG
blueX
 

Security

Erfahrenes Mitglied
#2
Geh beim Hochfahren in den Grub-Bootloader mit der ESC-Taste.

Lösche dann einfach den eintrag "quiet splash".
Jetzt hast du keinen bootspashmehr und es wird der alles angezeigt.

Fahr den PC runter, und sag uns was dann am Ende steht wenn er nichts mehr macht.
 

Navy

Freiwillige Serverwehr
#3
Nein. Nicht Escape sondern "e". Und darüber hinaus sollte das Drücken von Alt+F1 während des Bootens/Runterfahrens ausreichen um eventuelle Fehlermeldungen lesen zu können.

edit: Um ins grub-menü zu kommen ist eventuell doch ein "escape" nötig. Je nach Konfiguration.
 
Zuletzt bearbeitet:

Security

Erfahrenes Mitglied
#4
Um in den Bootloader zu kommen muss man Escape drücken, wenn man im bootlaoder ist muss man e zum editieren drücken, das steht dann aber auch da.

Und es ist auch Ctrl+Alt+F1 und es ist ein Virtuelle Console wenn ich mich nicht falsch entsinne, würde nicht garantieren, das es klappt. Die andere Variante ist idiotensicher.
 

Navy

Freiwillige Serverwehr
#5
Und es ist auch Ctrl+Alt+F1 und es ist ein Virtuelle Console wenn ich mich nicht falsch entsinne, würde nicht garantieren, das es klappt. Die andere Variante ist idiotensicher.
Nein. Das zusätzliche [Ctrl] brauchst Du nur aus X heraus, nicht jedoch im Bootsplash oder anderen Terminals. Und ob es ein tty, ein pty oder sonstwas ist (tatsächlich ist es ein tty), ist letztendlich egal, da dort ja schließlich die Ausgaben laden.
 

bluex

Erfahrenes Mitglied
#7
Hallo.

Dank für eure Hilfe :)

Ja also ich bekomme da folgende Meldungen:

NetwokManager: <info> Caught termination signal

NetworkManager: <debug> [1219687551.035181] nm_print_open_socks(); Open Sockets List:

NetworkManager: <debug> [1219687551.035725] nm_print_open_socks(); Open Sockets List Done.

NetworkManager: Deactivating device eth0.

NetworkManager: <warn> nm_hal_deinit(): libhal shutdown failed - Connection in closed

NetworkManager: <warn> nm_dbus_init(): nm_dbus_init() could not get the sytem bus. Make shure the message bus daemon is running!

NetworkManager: nm_dbus_signal_device_status_change: assertion `cb_data->data->dbus_connection' failed
NetworkManager: nm_dbus_signal_device_status_change: assertion `cb_data->data->dbus_connection' failed
NetworkManager: nm_dbus_signal_device_status_change: assertion `cb_data->data->dbus_connection' failed
[ 2503.157146] System halted.
MfG
blueX
 

Navy

Freiwillige Serverwehr
#8
Wie sieht Dein Booteintrag in der /boot/grub/menu.lst aus?

Normalerweise sollte ACPI (bzw. APM) eingeschaltet sein, es kann sein, dass diese Optionen dort deaktiviert sind.
 

Navy

Freiwillige Serverwehr
#10
Nächste mögliche Ursache: Du hast ACPI im BIOS deaktiviert

Oder aber ACPI oder APM wird bei Dir nicht gleaden. Was sagt denn lsmod? Werden diese Module angezeigt?
 

bluex

Erfahrenes Mitglied
#11
Hi

Also lsmod flüstert mir folgendes:

Module Size Used by
isofs 36388 1
udf 88612 0
ipv6 267780 8
af_packet 23812 2
rfcomm 41744 2
l2cap 25728 13 rfcomm
bluetooth 61156 4 rfcomm,l2cap
ppdev 10372 0
apm 22616 2
cpufreq_stats 7104 0
cpufreq_conservative 8712 0
cpufreq_powersave 2688 0
cpufreq_userspace 5284 0
cpufreq_ondemand 9740 0
freq_table 5536 2 cpufreq_stats,cpufreq_ondemand
iptable_filter 3840 0
ip_tables 14820 1 iptable_filter
x_tables 16132 1 ip_tables
lp 12324 0
snd_via82xx 29464 3
snd_ac97_codec 101028 1 snd_via82xx
ac97_bus 3072 1 snd_ac97_codec
snd_pcm_oss 42144 0
snd_mixer_oss 17920 1 snd_pcm_oss
snd_pcm 78596 3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_page_alloc 11400 2 snd_via82xx,snd_pcm
evdev 13056 1
nvidia 4718832 32
snd_seq_dummy 4868 0
snd_mpu401 9448 0
snd_mpu401_uart 9728 2 snd_via82xx,snd_mpu401
parport_pc 36260 1
parport 37832 3 ppdev,lp,parport_pc
snd_seq_oss 35584 0
snd_seq_midi 9376 0
snd_rawmidi 25760 2 snd_mpu401_uart,snd_seq_midi
analog 13600 0
snd_seq_midi_event 8320 2 snd_seq_oss,snd_seq_midi
gameport 16008 2 snd_via82xx,analog
snd_seq 54224 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 24836 2 snd_pcm,snd_seq
i2c_viapro 9876 0
snd_seq_device 9612 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
i2c_core 24832 2 nvidia,i2c_viapro
pcspkr 4224 0
via_agp 11136 1
via_ircc 27796 0
snd 56996 19 snd_via82xx,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_dummy,snd_mpu401,snd_mpu401_uart,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
agpgart 34760 2 nvidia,via_agp
shpchp 34452 0
irda 203068 1 via_ircc
soundcore 8800 1 snd
pci_hotplug 30880 1 shpchp
crc_ccitt 3072 1 irda
ext3 136712 1
jbd 48404 1 ext3
mbcache 9600 1 ext3
sg 36880 0
sr_mod 17956 1
cdrom 37408 1 sr_mod
sd_mod 30720 3
pata_acpi 8320 0
ata_generic 8324 0
usbhid 31872 0
hid 38784 1 usbhid
floppy 59588 0
pata_via 13316 3
libata 159344 3 pata_acpi,ata_generic,pata_via
ehci_hcd 37900 0
uhci_hcd 27024 0
scsi_mod 151436 4 sg,sr_mod,sd_mod,libata
usbcore 146028 4 usbhid,ehci_hcd,uhci_hcd
8139too 27520 0
8139cp 24704 0
mii 6400 2 8139too,8139cp
fbcon 42912 0
tileblit 3456 1 fbcon
font 9472 1 fbcon
bitblit 6784 1 fbcon
softcursor 3072 1 bitblit
fuse 50708 3
Also apm scheint wohl da zu sein wenn ich des richtig interpretiere ... schade 0o


MfG
blueX
 

bluex

Erfahrenes Mitglied
#13
Bios hab i noch nich geguckt wo steht des da denn 0o

Hab gerad in /etc/modules entdeckt das apm da ganich aufgelistet ist da stehen blos fuse und lp drinnen ich schreib apm mal einfach dazu .... oder muss da acpi rein

Danke für deine Hilfe, du bewahrst mich gerad davor wieder windoof zu installieren xD

MfG
blueX :)

EDIT:// ahhh seh gerad in dem log noch den Eintrag: pata_acpi 8320 0

Werd dann gleich mal ins Bios gucken wo ich des da an machen kann .. Wenn ich boote kommt immer irgendeine Meldung mit acpi nur die is so kurz zu sehen das i ned weis was da steht.
 
Zuletzt bearbeitet:

Navy

Freiwillige Serverwehr
#14
Bios hab i noch nich geguckt wo steht des da denn 0o
Ich kenn Dein BIOS nicht. Hangel Dich durch die Menüs und guck nach ob da irgendwas von "ACPI disabled" steht.

Hab gerad in /etc/modules entdeckt das apm da ganich aufgelistet ist da stehen blos fuse und lp drinnen ich schreib apm mal einfach dazu .... oder muss da acpi rein
APM ist bereits geladen, da musst DU nirgends etwas ändern. Wenn acpi=force nicht will, dann füge "apm=power-off" der grub-Kernelzeile hinzu.

Danke für deine Hilfe, du bewahrst mich gerad davor wieder windoof zu installieren xD
Warum solltest Du ein kleines Problem gegen ein großes tauschen wollen?
 

bluex

Erfahrenes Mitglied
#15
Warum solltest Du ein kleines Problem gegen ein großes tauschen wollen?
Hmm naja für mich ist jedes vermeindlich kleine Problem in Linux, im Moment noch ein riesen Problem xD Bei Windoof is man es ja schon gewohnt... da kann mich nichts mehr schocken ^^

Also in meinem Bios ist acpi enabled
und dann kann ich da noch auswählen :

suspend type:
  • s1(pos)
  • s3(str)

Im Moment ist s1 aktiv ...


//EDIT: ah hab schon gefunden. werd es bei S1 belassen .
 
Zuletzt bearbeitet:

Laudian

Erfahrenes Mitglied
#16
Offtopic on:

Dafuer ist in Linux eigentlich jedes Problem auch loesbar, wenn man sich etwas darum bemueht, unter Windows bin ich da anderer Meinung, da tun die Fehler eher das, was sie wollen, ohne eine definitive Loesung zuzulassen ... ;)

Offtopc off.
 

bluex

Erfahrenes Mitglied
#17
Hmm also des hat noch nichts gebracht. Werd es jetzt mit versuchen:

ist das so richtig ?

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=6928a20b-e354-4f31-97d1-5eb9f87b7cfe ro
acpi=force
apm=power-off
 

Navy

Freiwillige Serverwehr
#18
Nein. Das muss in die Zeile deiner Bootoption, wo auch "kernel" steht.
Ungefähr so:

Code:
title           Server main (x64)
root            (hd0,0)
kernel          $BOOTPARAMETER $DEINEOPTIONEN
[...]
Du kannst während des Bootens auch einfach ESC drücken, auf die Bootzeile gehen und diese mit E bearbeiten. Das ist schneller und Deine Änderungen sind beim nächsten mal wieder weg, also ideal zum ausprobieren.
 

bluex

Erfahrenes Mitglied
#19
Gut OK dann scheut es nun also so aus:

title Ubuntu 8.04.1, kernel 2.6.24-19-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.24-19-generic root=UUID=6928a20b-e354-4f31-97d1-5eb9f87b7cfe ro quiet splash acpi=force apm=power-off
initrd /boot/initrd.img-2.6.24-19-generic
quiet
Dann mal gucken :)
 

bluex

Erfahrenes Mitglied
#20
Geilomat... Danke vielmals.

Es geht :)

Das hat mich im Verständnis was den Bootvorgang angeht um einiges weiter gebracht.
Klasse dann sind jetzt fast alle Probleme behoben :)

MfG
blueX
 

Neue Beiträge