Scrolltool aus WP entfernen

Sprint

Erfahrenes Mitglied
Update:
Das Problem hat sich gelöst. Das problematische Script war nicht wirklich zu Wordpress 5.x kompatibel oder es funktioniert unter v6 nicht mehr. Ich habe ein Update auf Wordpress 6 gefahren und nun scrollt die Seite wie sie soll. Und auch das Zittern des Counters ist bei mir weg.

Danke euch für eure Tips und Denkanstöße.
 

basti1012

Erfahrenes Mitglied
Dann gebe ich dir auch mal ein Update:
Optisch sieht es besser aus ,kein Geruckel mehr und so .
Habe aber wieder neuen Fehler in der Konsole.
Code:
VM113:1 Uncaught TypeError: Cannot read properties of undefined (reading 'webkit')
    at wheel (eval at <anonymous> (frontend.js?ver=6.0.2:1:1), <anonymous>:1:228)


Vielleicht habt ihr den ja auch
 

basti1012

Erfahrenes Mitglied
Ich habe in den frondent Script das komplette erste eval auskommentiert.
Der Fehler ist weg und es scheint noch alles zulaufen.Kann es aber nicht richtig testen, dazu müsste ich deine komplette Seite kopieren, um das alles richtig zu testen.

Oder kann man sowas auch über die Konsole auskommentieren und dann auf deiner Seite testen?
Weiß das einer von euch?
 
B

ByeBye 284669

Auweia, was macht ihr da? Hier wird WordPress eingesetzt und dass das Problem durch ein Plugin oder das Theme ausgelöst wird, ist eigentlich klar. Also nach und nach die Plugins deaktivieren und testen, ob das Problem behoben ist. Wenn alle Plugins deaktiviert sind und das Problem immer noch existiert, dann entweder ein anderes Theme nutzen oder den Hersteller kontaktieren.
 

Sprint

Erfahrenes Mitglied
Prinzipiell gebe ich m.scatello Recht. Aber über den Browser mal was zu testen, ist nun mal die schnellere und einfachere Variante.
Über den Theme Editor hab ich zum Spaß mal die komplette frontend.js auskommentiert. Die Seite läuft scheinbar völlig ohne Probleme weiter.

Werde das am Montag im Büro mal lokal durchprobieren. Bis dahin läuft die Seite auch so.
 

Sprint

Erfahrenes Mitglied
Inzwischen bin ich der Ursache deutlich näher gekommen. Das Problem liegt in dem Template, bei dem eine veraltete Funktion jQuery.browser benutzt wird. Die ist seit Version 1.9 veraltet und Wordpress 6 nutzt inzwischen jQuery 3.6.0. Ich habe wie basti1012 das erste eval auskommentiert und die ursprüngliche Meldung ist weg, ohne daß sich auf der Seite auch nur ein Problem zeigt. Ich erhalte nur einen Referenzfehler auf eine Variable.

Im Moment frage ich mich echt, ob das wirklich den Aufwand, ein anderes Template zu installieren, Wert ist.
 

basti1012

Erfahrenes Mitglied
Wenn das doch mit den eval auskommentieren geht und keine negativen Änderungen auf deiner Seite sind, würde ich das so lassen.

Das mit den jquery.browser habe ich auch gelesen und bin nach weiteren googeln drauf gekommen das erste eval einfach auszukommentieren.

Bei mir gings und wenn es bei dir geht (ohne Fehler in der Konsole) würde ich es auch so lassen.
Du könntest ja nochmal in WP Forum nachfragen, was die sagen, weil die kennen ihr System besser als wir hier,.