Perl und Umlaute- verschieden Ergebnisse bei der Auslese in Browser


milea

Mitglied
Hallo,

leider kenn ich mich mit PERL kaum aus - aber halt ein bissel mit PHP. Ich habe einen neuen Job und muss mit dem von meinem Vorgänger die programmierten pl-Dateien arbeiten.
Und nun gibts ein Problem, was ich nicht versteh... ;)

Aus einer Access-DB werden mittels pl-Scripten Daten ausgelesen. In diesem Fall gehts um Landkreise.

Der Nutzer kann diese aus einer <select>-Liste auswählen. In der DB steht in der betreffenden Spalte genau der Eintrag (also mit Umlauten) wie im value der select-Liste

z.B
HTML:
<select class='textbox_1' name='textbox_2'><option value='Südland'>Südland</option>
- in der DB steht auch "Südland" - mit ü

Im IE funktioniert die Suche einwandfrei - alle relevanten Ergebnisse werden ausgegeben.
Anders sieht es im FF aus. Da wird bei allen, was mit Umlauten zu tun hat, gar nix gefunden. Wählt der Nutzer dort also "Südland" aus kommen keine Ergebnisse - im IE kommt alles, was ausgegeben werden soll.

Ich hab auch schon probiert das ganze ins UFT-8 zu Konvertieren indem ich bei diesem Teil der pl-Datei "<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">" eingefügt habe.

Code:
print <<"END_OF_HTML";
<html>
 <head>
  <title>suche</title>
  <link rel="stylesheet" href="../style.css">
<link rel="stylesheet" href="../menu1.css">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
 </head>

Daraufhin hat der FF nur Fragezeichen bei den Umlauten ausgespuckt.
Die Umlaute im perl-Teil hab ich wie folgt behandelt:
Code:
$suchbegriff_lkz = $Form{'textbox_2'};
$suchbegriff_lkz =~ s/\*//g;

Stimmt daran was nicht? Habe das aus einem Beispiel im Internet. Oder liegt das Ganze an etwas anderen? Warum interpretieren die Browser so unterschiedlich, dass bei manchen nicht mal Ergebnisse bei der Suchanfrage ausgeben werden?

Ich hoffe ihr könnt mir helfen...Vielen Dank schonmal im Vorraus!
 
Zuletzt bearbeitet:

Neue Beiträge