particles färben

Trebble56

Erfahrenes Mitglied
Moin,

Ich möchte nach langer zeit mal wieder particles verwenden und ihnen auch eine Farbe zuweisen. Leider bin ich dazu nicht mehr in der lage, weil die änderung aus irgendeinem Grund nicht zugelassen wird. ich klicke die particles an und weise ihnen ein neues material zu z.b. anisotropic und wenn ich dann die farbe ändern möchte kann ich zwar eine farbe auswählen aber sobald ich die maus vom dialog wegnehme und dieser sich schließt, sehe ich das es bei dem üblichen grau bleibt. Das grau ist als Triebwerksstrahl für eine Rakete allerdings nicht so ganz geeignet. Hat da jemand eine Idee was ich falsch mache ?

Ich meine ich hätte früher schonmal eine art silvesterfeuerwerk mit particles gemacht und da wäre das kein problem gewesen.

nparticles würde ich nur ungern verwenden da die scheinbar sehr sehr viel mehr leistung vom pc fordern und von anfang an nicht so fein sind. Falls jemand übrigens den genauen unterschied kennt würde ich den gern auch wissen. aus den google-ergenissen bin ich diesbezüglich nicht schlau geworden.

Und ich habe noch eine Frage für nebenbei: Es ist ein Bug wenn ich im mentalray render einen Teil meiner Bumpmaps nicht sehen kann oder?

UPDATE1: Ichh abe nach einem tutorial folgendes getan: particles ausgewählt , unter particleShape1 habe ich "Add Dynamic Atributes" ausgewählt und aud "Color" geklickt und im erscheinenden fenster "Add per Particle Attribute" ausgewählt und bestätigt. Dann habe ich unter "particlesShape1" , "Per Particle (Array) Attribute" ausgewählt und in der Zeile "RGBPP" mit rechtsklick eine Ramp eingefügt. Diese hatte allerdings nur zur folge das die particle jetzt eine bestimmte lebensdauer haben und danach verschwinden. Die Farbe blieb die gleiche (grau).

UPDATE2: Ich konte die Particle färben , allerdings nur mit einer Ramp die leider die Particle nicht nach ihrer Lebenszeit färbt. Ich hätte gern einen Abgasstrahl der zum ende hin rot wird und am anfang ein helles gelb hat.

Gefärbt habe ich folgendermaßen : Particles auswählen - InitialParticleSE auswählen - Shading Group Attributes öffnen - neben Surface material rechts auf das schwarz weiße Feld klicken - ramp auswählen.

UPDATE3: Ich habe ein neues projekt angelegt und die particle nochmal nach der methode von update1 gefärbt. Diesesmal hatte das keinen einfluss auf die lebensdauer und hat sogar in der normalen ansicht die farbe geändert sodass die particle am anfang gelb und am ende rot sind. Leider sind sie im mental ray render immer noch grau und in den anderen rendern gar nicht zu sehen.
 
Zuletzt bearbeitet:
P

pixelator

Hallo Trebble56

zuerst mußt du mal kontrollieren welchen Rendertyp von particles dein Emitter generiert.

particleShape1 > Render attributes. Mit dem software renderer lassen sich nur "cloud", "tube" und "blobby surface" rendern.

Alle anderen Typen siehst du nur mit dem Hardware Renderer.
Window > Rendering Editors > Hardware Render Buffer.

Alternativ kannst du z.B. dem Typ "points" über particles > Instancer ein mini Objekt zuweisen.
Ein NurbsKügelchen (oder was auch immer) ausserhalb der szene platzieren.
Kügelchen selektieren > Mit shift die particles hinzuwählen > Menü > particles > Instancer....
Farben und Material kommen dann vom instancer object.

Die Größe von "cloud", "tube" und "blobby surface" kann man, sobald sie erscheinen skalieren

Für Farbe und Darstellung haben cloud und tube den tab particleCloud1 im AE. Blobby surface kann man ein neues Material zuweisen.

Gruß pixelator
 
Zuletzt bearbeitet von einem Moderator:

Trebble56

Erfahrenes Mitglied
Also ich habe jetzt das Raumschiffprojekt neu importiert und die Lage sieht wie folgt aus: Der ermitter steht auf "points" demzufolge sehe ich im Software Render keine Particle , im HardwareRender sind sie grau , im HardwareRender2.0 sieht man sie auch nicht und im Mental Ray Render haben sie eine Farbe bekommen. Auch wenn ich es noch nicht geschafft hab das die Particle am anfang ihres "Lebens" hellgelb und am ende eher dunkel rot sind. Ich hatte mir überlegt das die Particle die den Abgasstrahl eines Triebwerks bilden , abkühlen und so der strahl am ende dunkler werden müsste. Daher der Versuch mit der farb-ramp .
 
P

pixelator

Die normalen (points) Particle erhalten ihren Verlauf über:

particleShape1 > Add Dynamic Attributes > Color > add per particle. ramp1 wird erzeugt im AE.
Lifespan spielt ´ne Rolle. Hier den passenden Wert suchen und timeline immer mal neustarten.

clouds erhalten ihren Verlauf über:
particleCloud1 > LifeColor s/w Kästchen klicken und Verlauf hinzufügen.

Ich würde die clouds bevorzugen. Schon alleine wegen der Transparenz. Siehe Bild.
 

Anhänge

  • particleFlame.jpg
    particleFlame.jpg
    126,5 KB · Aufrufe: 22
P

pixelator

Im Fernseh war nix und da hab ich mir nochmal deine Beschreibung angeguckt. In deinem Update1 ist glaube ich was schief gelaufen. Color angeklickt und per particle auswählen war richtig. Das erzeugt eine ramp und die gilt es im AE zu bearbeiten. Wie das ganze erscheint, bestimmt die lifespan deiner particles. Wenn du dir was anderes vorstellst machen wir weiter.....

Gruß pixelator
 

Trebble56

Erfahrenes Mitglied
Also in der Ansicht in der man arbeitet ist alles super da kommt der verlauf zustande, aber leider geht er beim Rendern irgendwie immer verloren hier 2 Bilder:

problemtriebwerk1.png

problemtriebwerk2.png

muss ich da vielleicht noch irgendeine option aktivieren oder sowas in der art?

Und danke schon mal für den tipp mit der transparenz bei den clouds ... ich werd das mal genauer ausprobieren, aus den ersten tests weiß ich aber leider auch schon das das problem mit der nicht mitgerenderten farbe auch hier besteht (nur das hier die standartfarbe hellblau statt grau gerendert wird) .
 
P

pixelator

Das hellblau kriegste weg wenn du unter particleCloud1 die life color als Verlauf anlegst.

Melde mich später nochmal
 
P

pixelator

So! Da ich schon ewig nicht mehr mit MR gerendert habe ist mir die graue Darstellung der meisten particle-Typen entfallen. Ich hab nochmal was experimentiert und hoffe das ich es jetzt Schritt für Schritt auf die Reihe kriege.

Create emitter directional -Y spread 0.2

particle Lifspan Constant / 10

MR rendert die particles grau

particles selektieren > neues Material > Lambert

Hypershade > Lambert2 MMB ins Arbeitsfeld ziehen

Maya > utilities > particle sampler dazuholen

particle sampler MMB auf Lambert2 ziehen > other >

outcolor vom sampler mit color vom Lambert2 verbinden

MR rendert die particles schwarz

particleShape1> Add dynamic Attributes > Color >per particle

RMB in die neue RGB PP Zeile und neuen Verlauf anlegen

timline neu starten!! und mit MR rendern > verlauf anpassen.

Gruß pixelator
 

Trebble56

Erfahrenes Mitglied
Super! Es funktioniert, ich weiß deine Ausdauer sehr zuschätzen . Jetzt hab ich nur noch eine Kleinigkeit : Kann ich den Particles jetzt noch irgendwie eine Glowintensity verpassen?
 
P

pixelator

Die einfachste Möglichkeit ist, den glow in lambert2 einzustellen. Die particles und lambert2 "sprechen ja miteinander" über den particle sampler den du im Hypershade eingefügt hast.

Ich schätze mal das du die Animation als film rendern willst. Daher empfehle ich dir mal das vorherige Thema (Problem: Glow-Effekt der nParticle heben sich gegenseitig auf?! ) zu lesen.
Animierter glow flickert nämlich gerne. Und zwar so das es als Effekt nicht zu gebrauchen ist.:)
Ist n bischen Gefrickele mit Glow und Halo, lohnt sich aber. Außerdem sieht man mal was alles so möglich ist mit den Einstellungen.

Gruß pixelator
 
Zuletzt bearbeitet von einem Moderator: