Anzeige

Netzwerkprobleme in der Firma


#1
Hallo,
gab so einen Fall bestimmt schon hunderte mal aber vielleicht hat jemand noch einen anderen Ansatz.

Gegebenheiten:
Stark verzweigtes Netzwerk mit um die 10-20 Switchen (alle Gigabit) und 100-200 Netzwerkgeräten.
Leitungen sind alle Cat 6/7 bzw. die Patchkabel S/FTP cat5e/6 geschirmt.
Netzwerkgeräte sind Ip-Kameras, Drucker, Mac, Pc, Handy, viele W-Lan AccessPoints etc.
Der Anschluss hat VDSL 50 über den Anlagenanschluss der Telekom. Router sind FritzBoxen (3390)
Die meisten Anschlüsse sind statisch vergeben.

In Wirklichkeit gibt es 2 Netzwerke die über eine Bridge (Synologystation) miteinander verbunden sind.
Das 2. Netz macht die Telekommunikation (SIP-Kommunikation, Telefonanlage, DECT) und die statische Route (in den Routern) dient nur
dazu, dass die Geräte die Uhrzeit aus dem Internet bekommen und zu Wartungszwecken um sie von überall zu erreichen.

Problem:
In der Firma wo ich arbeite gibt es seit Februar immer wieder Internetprobleme, davor hat 2 Jahrelang in der Kombination alles funktioniert.
Es ist recht merkwürdig, weil meistens alles geht und auch super schnell (VDSL 50), aber manchmal gibt es Aussetzer.
Das äußert sich z.B. in Ajax-Requests die nicht durchkommen oder eine komplette Ladeblockade von Webseiten für Sekunden selten auch Minuten. Manchmal gibt es auch einfach Geschwindigkeitseinbrüche (Bildersuche von Google lädt Bilder peu a peu nach)
Gibt keine feste Uhrzeit oder einen Auslöser.
Wichtig hierbei ist zu erwähnen, dass das interne Netzwerk dabei nicht beeinträchtig wird.
Ich kann sekundenschnell von überall aus mehrere GiB große Daten laden und versenden auch wenn das Internet gerade weg zu sein scheint.
Die internen Server sind auch alle erreichbar. Auch große Downloads brechen nicht ab.

Bisherige Analysen Vorgehensweisen:
In der FritzBox sind keine Fehler zu erkennen. Netzwerkmonitor zeigt eine niedrige Auslastung und Internet sowie DSL Verbindung.
Auch CRC-Fehler treten keine auf.
Verbindugnsabbrüche werden dort auch keine Dokumentiert.
Die FritzBox wurde auch schon gegen eine brandneue getauscht und manuell neu konfiguriert. Das hat nicht wirklich einen Erfolg gebracht.
Die Telekom hat nach mehrmaligen beschweren den Außendienst geschickt.
Dieser hat uns am DSLAM auf einen anderen Port gepackt. Laut der Analyse der Telekom gibt es aber keine Leitungsprobleme.
Ich hab auch schon die DNS Server gewechselt, weil ich dachte die der Telekom wären einfach überlastet. Das hatte auch keinen Effekt.

Wenn ich nebenbei permanent Pinge sehe ich von z.B. 160 Pings oft nur einen der nicht ins Internet kommt (sofern eine Störung vorliegt)
Auch traceroute liefert nur selten Probleme selbst wenn kein Internet da ist. Manchmal läuft es sich dann aber auch tot.
Speedtest.net zeigt auch nichts ungewöhnliches an, außer das die Seite eventuell nicht lädt.
Wireshark am lokalen Rechner bringt auch nicht viel hervor, vor Allem wenn ich nicht weiß wonach ich suchen soll.

Leider hab ich kein Hub bzw. Pc mit 2 Netzwerkanschlüssen da um mich zwischen den Anschluss und der Fb zu klemmen und dann dort Analysen zu machen. Das würde ich dann als nächstes irgendwie zusammenbasteln.

Vielleicht hat ja jemand andere Ideen außer systematisch Geräte abzuschalten, da dies leider nicht möglich ist :(

Mit freundlichen Grüßen
Larrywayn
 

Fragenfrager

Erfahrenes Mitglied
#2
Nur so eine Idee: Sofern Du keine Company-Connect Leitung hast, wird die Telekom i.d.R einmal pro Tag die Leitung trennen. Da kann es zu kurzen Auszeiten kommen. In der Fritz-Box kannst Du mWn hinterlegen, dass diese Zwangstrennung selbst durchgeführt wird die Uhrzeit bestimmen. Leg die mal auf irgendwann Nachts wenn keiner arbeitet.
 

ikosaeder

Teekannen-Agnostiker
#3
Die Fragen die man zuerst stellen muss:
Was hat sich im Februar geändert? Gab es neue Hardware, ein neues OS oder Updates? Wurden Netzwerkkomponenten ausgetauscht oder hinzu gefügt? Welche Geräte sind konkret betroffen: Nur die mit Windows oder alle Geräte, die ins Internet gehen?
Dann gibt es jede Menge Analyse Tools für Netzwerke, z.B. Wireshark. Vielleicht kann man die Switches und Router auch in einen Modus schalten bei dem ausführliche Logs erzeugt werden und die Logfiles dann auswerten.
(z.B. für Cisco Hardware:http://www.cisco.com/en/US/docs/sto...iguration/guides/cli_3_3_1/log.html#wp1229492)
Damit kann man die Ursache zunächst einmal eingrenzen und dann gezielter suchen.
Netzwerkprobleme, wie du sie beschrieben hast können auch durch erhöhte Prozessorlast verursacht werden. Gibt es vielleicht einen Virenscanner, der zwischendurch mit hoher Priorität nach Updates sucht?
 
#4
Vielen Dank für die Antworten erstmal.

Es hat sich im Februar nichts aktiv geändert.
Eventuell haben irgendwelche Mitarbeiter neue Handys die sich mit dem W-Lan verbinden. Das wäre aber die einzige Änderung.
Ansonsten kam im Januar nur ein neuer Mac dazu. Aber an der Netzwerkstruktur hat sich lange nichts geändert.

Betroffen sind alle Geräte ob Windows 7, Windows 8, Mac 10.8-10.9, Telefonanlage (E-Mail Versand), die ins Internet gehen.
Intern scheint nichts betroffen zu sein wie ich schon sagte, jedoch hab ich hier ein 10 Gigabit Netzwerk aufgebaut, wo es vielleicht einfach nicht auffällt.

Die Switche sind alle nur Layer 2 ohne Protokollfunktionen und die Router meist irgendwelche Fritzboxen. Die können zwar loggen aber nur kurzzeitig.
Bis der Fehler bemerkt wird ist es meistens zu spät zum messen/loggen.

Das Problem bei Wireshark ist, dass es hunderte Einträge pro Sekunde erzeugt und das niemand weiß wonach eigentlich gesucht werden muss.
Oder gibt es dafür wiederum analyse Programme? Wir haben kein gutes gefunden welches Wireshark Logs auswertet und analysiert.

Wäre nur ein einzelnes Gerät betroffen wäre Prozessorlast etc. sicher möglich, aber das ist hier nicht der Fall.

UPDATE:
Wir haben eine ältere Fritzbox (nur für WLAN) vom Netz genommen und seit dem scheint es besser zu laufen. Es gibt deutlich weniger Probleme, aber auch nicht keine.
Außerdem haben wir alle Rechner (Windows/Mac) Virenscans und Malwarscans unterzogen und 2 kleinere Sachen gefunden, aber nichts kritisches.
 

ikosaeder

Teekannen-Agnostiker
#5
Wenn so viele verschiedene Rechner betroffen sind, dann kann man so etwas wie Prozessorlast mit hoher Wahrscheinlichkeit ausschließen. Die Ursache wird dann wohl in einer zentralen Komponente liegen, also Switch oder Router. Externe Ursachen beim Provider oder so sind auch noch möglich.
Du musst versuchen, das Problem weiter einzugrenzen.
Eine Idee die ich noch hätte, da es ja fast nur Internet betrifft: Check mal den DNS-Server, oder stell auf einen anderen DNS-Server um.
 

Fragenfrager

Erfahrenes Mitglied
#6
Als ich gerade nochmal las, dass ggf Handys im Netzwerk unterwegs sind:
IPhones sind bekannt dafür, dass sie ein anderen MTU Wert haben als "normale" Router. Die Apple-Geräte haben normalerweise einen MTU von 1500, die Router von 1492. Wenn dann etwas Last über die Handys geht, kann es unter Umständen zu Netzwerkproblemen führen...
 
Anzeige
Anzeige