Anzeige

 Mit Text verknüpfte Formel im benutzerdefinierten Format ausgeben


tklustig

Erfahrenes Mitglied
#1
Hallo Leute,
folgende VBA Formel gibt mir die Summe bestimmter Zellen im benutzerdefinierten Format([h]:mm:ss) aus
Code:
=SUMME(E40:E45)
Dasselbe benutzerdefinierte Format ist ineffektiv mit folgender Formel:
Code:
="∑:"&SUMME(E40:E45)
Ich bekomme folgende Ausgabe
Code:
∑:1,6180555 etc.etc.
anstatt
Code:
38:50:00
  1. Warum ist dem so?
  2. Was muss ich machen,damit auch die zweite Version benutzerdefiniert formatiert?
 

Yaslaw

n/a
Moderator
#2
Das Format wird auf die ganze Zelle angewendet. Nicht nur auf deine Summe.
Im Englischen Excel heisst die Funktion TEXT(), mit der du Teilstrings formatieren kannst.
Code:
="∑:" & TEXT(SUMME(E40:E45), "Dein Format")
 

tklustig

Erfahrenes Mitglied
#3
Klappt leider nicht. Zumindest wird folgende Formel vom Interpreter als fehlerhaft bezeichnet und folglich nicht ausgeführt
Code:
="∑:" & TEXT(SUMME(E40:E45), "[h]:mm:ss")
 

Yaslaw

n/a
Moderator
#4
Sorry, ; anstelle von ,
Das folgende funktionert im englischen Excel. Du musst ggf die BEfehle noch auf das deutsche Excel anpassen.
Code:
="∑:" & TEXT(SUM(A1:A2); "[h]:mm:ss")
2018-03-19_080130.jpg
 
Anzeige

Neue Beiträge

Anzeige