Mediawiki Visual Editor API-Error


Kalito

Erfahrenes Mitglied
#1
Hallo,

ich habe bei mir ein BlueSpice-Wiki (basiert auf einem Mediawiki) auf dem Server installiert und wollte dort den Visual-Editor aktivieren.

Meine Konfigurationen sehen wie folgt aus:

Parsoid\config.yaml
YAML:
mwApis:
        - # This is the only required parameter,
          # the URL of you MediaWiki API endpoint.
          uri: 'http://slm.slg.meineDomain/api.php'
          # The "domain" is used for communication with Visual Editor
          # and RESTBase.  It defaults to the hostname portion of
          # the `uri` property above, but you can manually set it
          # to an arbitrary string. It must match the "domain" set
          # in $wgVirtualRestConfig.
          domain: 'localhost'  # optional
          # To specify a proxy (or proxy headers) specific to this prefix
          # (which overrides defaultAPIProxyURI). Alternatively, set `proxy`
          # to `null` to override and force no proxying when a default proxy
          # has been set.
settings.d\020-VisualEditor.php
PHP:
//return; // Disabled. Needs Parsoid

//Config decription can be found here:
//https://www.mediawiki.org/wiki/Extension:VisualEditor
wfLoadExtension( 'VisualEditor' );

// Enable by default for everybody
$wgDefaultUserOptions['visualeditor-enable'] = 1;
$wgDefaultUserOptions['visualeditor-enable-experimental'] = 1;
$wgDefaultUserOptions['visualeditor-newwikitext'] = 1;

// Optional: Set VisualEditor as the default for anonymous users
// otherwise they will have to switch to VE
// $wgDefaultUserOptions['visualeditor-editor'] = "visualeditor";

// Don't allow users to disable it
$wgHiddenPrefs[] = 'visualeditor-enable';
$wgHiddenPrefs[] = 'visualeditor-newwikitext';

// OPTIONAL: Enable VisualEditor's experimental code features
#$wgDefaultUserOptions['visualeditor-enable-experimental'] = 1;

// Per default, the VisualEditor only works with Namespace 0 (NS_MAIN),
// i.e. the main article namespace. To change this, adapt the following example
// that enables namespaces 0 (main), 2 (user) and 102 (some user specific one)
$wgVisualEditorAvailableNamespaces = [
    NS_MAIN => true,
    NS_USER => true,
    102 => true,
    "_merge_strategy" => "array_plus"
];

// Linking with Parsoid
$wgVirtualRestConfig['modules']['parsoid'] = array(
    // URL to the Parsoid instance
    // Use port 8142 if you use the Debian package
    'url' => 'http://slm.slg.meineDomain.de',
    'domain' => 'localhost',
    'prefix' => 'localhost',
    'forwardCookies' => true
);

$wgVisualEditorEnableWikitext = true;
Wenn ich nun einen Artikel bearbeiten möchte bekomme ich die Fehlermeldung Fehler beim Laden der Daten vom Server: apierror-visualeditor-docserver-http: HTTP 404

Laut den Access-Logs werden alle Seiten korrekt geladen und auch der CURL-Aufruf der API-URL funktioniert (Es kommt kein 404). Ehrlicherweise stehe ich daher etwas auf dem Schlauch, warum dieser Fehler kommt. Habt Ihr eine Idee oder könnt einen Fehler in meiner Config sehen?

Danke und Gruß
Patrick