Localhost nicht offline erreichbar


Tommy57

Erfahrenes Mitglied
#1
Hallo,

auf dem Laptop habe ich Mint Debian installiert. Apache läuft und die angelegten Seiten funktionieren auch. Sobald ich aber das Internet trenne, sind die lokalen Seiten nicht mehr erreichbar. Bin da wirklich am Verzweifeln. Hat jemand eine Idee?

Gruß, Tommy
 
#2
Hi

Mint oder Debian?
Stable oder...?
Apache pur aus dem Repo oder...?
Was genau "trennst" du wo?
Iptables, UFW, ...?
Der Servicestatus vom Apache?
Syslogs und Apachelogs?
Geht ping?
Schreibst du "localhost" oder "127.0.0.1" oder...?
...

Mit den bisherigen Infos wird das nichts...
 

Tommy57

Erfahrenes Mitglied
#3
Das Betriebssystem heißt glaube ich Mint Debian Cinnamon. Apache habe ich über die Konsole installiert und der läuft auch.

Code:
sudo apt-get install apache2
Ping geht wohl. Ich schreibe die URL, die ich in /etc/hosts und ../sites-available angegeben habe. Wie gesagt, wenn das Internet geht, laufen die lokalen Seiten.

Meine Linux Kenntnisse sind nicht wirklich gut. Wenn du mir n paar Befehle nennst, zeig ich dir gerne den Output.

Gruß, Tommy
 
#6
und zu Befehlen:

Code:
dpkg --get-selections >aaa
service apache2 status >>aaa
Dann die Datei aaa herzeigen...

Außerdem zeigen, was du in /etc/hosts und in ../sites-available hast...

Und folgende Fragen sollten eigentlich beantwortbar sein:
Was genau "trennst" du wo?
Es gibt viele Möglichkeiten, bei einem Linux-Computer das Internet abzudrehen. Was machst du? Kabel ausstecken? Router ausschalten? ifconfig? In der GUI (Programm/Screenshot)?
Schreibst du "localhost" oder "127.0.0.1" oder...?
im Browser
 

Tommy57

Erfahrenes Mitglied
#7
Was genau "trennst" du wo?
Ich trenne das Netzwerkkabel.

Schreibst du "localhost" oder "127.0.0.1" oder...?
Ich schreibe www.test.com oder localhost

/etc/hosts
Code:
127.0.0.1   www.test.com
127.0.0.1   localhost       www.test.com
/etc/apache2/sites-available/test.conf
Code:
<VirtualHost *:80>
  ServerAdmin contact@test.com
  ServerName www.test.com
  ServerAlias www.test.com
  DocumentRoot /var/www/test
  <Directory /var/www/test/>
   Options Indexes FollowSymLinks MultiViews
   AllowOverride All
   Order allow,deny
   allow from all
  </Directory>
  ErrorLog /var/www/test/error.log
  # Possible values include: debug, info, notice, warn, error, crit,
  # alert, emerg.
  LogLevel crit
  CustomLog /var/www/test/access.log combined
 </VirtualHost>
 

Anhänge

  • 53,4 KB Aufrufe: 4

bofh1337

Erfahrenes Mitglied
#10
Das liegt wohl daran, dass der DNS-Server, welcher mit dem Router angesprochen wurde, hinterher nicht mehr verfügbar ist. Das Neustarten "~# service networking restart" sollte das Problem wohl lösen
 

Tommy57

Erfahrenes Mitglied
#11
Hi bofh1337, danke für die Antwort. Leider löst es aber nicht das Problem. Ich kann nach wie vor ohne Internverbindung nicht auf localhost zugreifen.
 

Tommy57

Erfahrenes Mitglied
#13
Ich kann auch offline localhost anpingen. Er sendet dann den Ping automatisch an die www.test.com


Ausgabe von ifconfig:
Code:
eth0      Link encap:Ethernet  Hardware Adresse 74:d0:2b:e6:cc:90 
          UP BROADCAST MULTICAST  MTU:1500  Metrik:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:19

lo        Link encap:Lokale Schleife 
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:65536  Metrik:1
          RX packets:4445 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4445 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:427615 (417.5 KiB)  TX bytes:427615 (417.5 KiB)
 

bofh1337

Erfahrenes Mitglied
#14
Also, localhost arbeitet, wie es sollte (Das ist die Schnittstelle lo), dann liegt es zumindest nicht an der /etc/hosts. Der Fehler liegt dann wohl irgendwo bei der Apache Konfig.

Ich habe hier mal eine ältere Konfiguration für einen virtuellen Server, dabei wird der "Standard-Server", wie er nach der Apache2-Installation vorhanden ist, einfach so belassen und eine neue Konfguration für den virtuellen Server angelegt:

Code:
<VirtualHost umbrella:80>
ServerName umbrella
DocumentRoot /hd_httpdocs
    IndexOrderDefault Ascending Name
    IndexOptions +FancyIndexing +FoldersFirst
    <Directory /hd_httpdocs>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
        Require all granted
    </Directory>
    AccessFileName .htaccess
    LogLevel debug
</VirtualHost>
Das ganze unter /etc/apache2/sites-available/umbrella abspeichern und von dort einen Symlink nach
/etc/apache2/sites-enabled/ machen:

ln -s /etc/apache2/sites-available/umbrella /etc/apache2/sites-enabled/umbrella

In der /etc/hosts muss dann natürlich auch der Eintrag gemacht werden:

127.0.0.1 umbrella

Danach den Apache neustarten: service apache2 restart


Dann sollte es eigentlich laufen,- wenn nicht, gibt mir mal bitte die Liste der installierten und aktivierten Apache-Module
 

bofh1337

Erfahrenes Mitglied
#16
Das geht mit:
apache2ctl -t -D DUMP_MODULES
oder
apache2ctl -M

Du kannst auch mit:

HOSTNAME=<neuer hostname>

instant einen neuen Namen vergeben, oder mit:

hostname

den aktuellen anzeigen lassen
 

Tommy57

Erfahrenes Mitglied
#17
Apache-Module:
Code:
Loaded Modules:
 core_module (static)
 so_module (static)
 watchdog_module (static)
 http_module (static)
 log_config_module (static)
 logio_module (static)
 version_module (static)
 unixd_module (static)
 unixd_module (static)
 access_compat_module (shared)
 actions_module (shared)
 alias_module (shared)
 auth_basic_module (shared)
 authn_core_module (shared)
 authn_file_module (shared)
 authz_core_module (shared)
 authz_host_module (shared)
 authz_user_module (shared)
 autoindex_module (shared)
 cgi_module (shared)
 deflate_module (shared)
 dir_module (shared)
 env_module (shared)
 fastcgi_module (shared)
 filter_module (shared)
 mime_module (shared)
 mpm_prefork_module (shared)
 negotiation_module (shared)
 php5_module (shared)
 rewrite_module (shared)
 setenvif_module (shared)
 status_module (shared)
Wofür genau brauche ich den Hostnamen? Also ich möchte ja nur lokal auf die Seiten zugreifen.

Gruß, Tommy
 

abdellaui

Erfahrenes Mitglied
#19
Zuerst:
Code:
sudo nano /etc/hosts
Bearbeite es so:
Code:
127.0.0.1   www.test.com
127.0.0.1   localhost
/etc/apache2/sites-available/localhost.conf
Code:
<VirtualHost *:80>
  ServerName localhost
  DocumentRoot /var/www/test
  <Directory /var/www/test/>
   Options Indexes FollowSymLinks MultiViews
   AllowOverride All
   Order allow,deny
   allow from all
  </Directory>
 </VirtualHost>
Führe aus:
Code:
sudo a2ensite localhost.conf
Code:
sudo service apache2 reload
Nun solltest du via Browser mit localhost Uugriff auf dein Server haben, falls dies nicht funktionieren sollte, versuche localhost:80
 

Tommy57

Erfahrenes Mitglied
#20
Habe es eben lösen können. Aus irgendeinem Grund kann Firefox den localhost nicht mehr aufrufen und wenn, lädt er ihn nur aus dem Cache. Anscheinend haben sich einige Bibliotheken im Laufe der Behebung verabschiedet, so dass PHP nicht mehr an die MySQL Datenbank ran kam, so wie Postgres und Memcache, obwohl diese noch liefen. Nachdem ich alles wieder zum Laufen gekriegt habe, kann ich mit Chrome hervorragend offline localhost erreichen.

Danke für die Hilfe