LAN-IP bei DynDNS


Monti

Mitglied
Hey,

ich habe folgendes Problem:
Ich würde gerne über DynDNS auf meinen Raspberry weiterleiten. Dazu habe ich in meinem Router (D-Link DIR-600) die nötigen Zugangsdaten eingetragen. Aus irgendwelchen Gründen trägt der Router aber immer nur seine eigene lokale IP ein, nicht meine Internet-IP.
Ich versuche schon eine ganze Weile das Problem zu lösen, weiß aber nicht, wo ich da ansetzen soll.

Hatte schonmal jemand ein ähnliches Problem?


MfG,
Monti
 

hendl

Erfahrenes Mitglied
Hmm hast du die Daten auch direkt beim Router eingetragen und nicht beim Raspi da dieser nur die lokale IP kennt?
Hmmm sonst ist eigentlich nichts einzustellen außer dem Usernamen und PW oder hast du noch weitere Einstellungen?
 

Monti

Mitglied
Ja, die Daten sind beim Router eingetragen. Sonstige Einstellungen habe ich nicht eingegeben. Als einzig relevanten Punkt fällt mir noch ein, dass vor dem Router noch ein Cisco-Modem sitzt.
 

hendl

Erfahrenes Mitglied
Ja dass wird der Hauptpunkt sein da der Router vill nur eine interne IP vom Modem bekommt.
Hast du vill die Möglichkeit die Daten beim Modem einzutragen.

Andererseits sollte es jedoch trotzdem funktionieren da bei mir auch vor dem Router ein Kabelmodem hängt und er die richtige IP bekommt.
 

Monti

Mitglied
Frohes Neues!

Ja, beim Modem kann ich ebenfalls die Zugangsdaten für DynDNS.org eintragen. Aber auch hier steht, dass die momentan gesetzte IP aktuell ist und deshalb keine Änderung vorgenommen wurde.

Beim Router steht auf der Status-Seite unter WAN-IP tatsächlich die LAN-IP. Er macht also soweit nichts falsch, da er es ja nicht besser wissen kann.
 

drucko

Erfahrenes Mitglied
Hallo Monti,

wenn du bei deinem Modem DynDNS Zugangsdaten eingeben kannst... handelt es sich vielleicht doch auch um einen Router bzw Router-Modem-Kombiding? :)
 

Monti

Mitglied
Hallo Monti,

wenn du bei deinem Modem DynDNS Zugangsdaten eingeben kannst... handelt es sich vielleicht doch auch um einen Router bzw Router-Modem-Kombiding? :)
Das ist auch gut möglich. Ich werde mal meinen Provider anrufen, da ich wohl nicht der einzige Kunde mit derartiger Gerätekonstellation bin. Wenn ich da neues erfahre, gebe ich hier Feedback. ;)
 

Monti

Mitglied
So, ich habe mich die letzten Tage nochmal intensiv mit der Problemstellung beschäftigt. Zumindest weiß ich jetzt, woran es liegt:
Bei Unitymedia bekommen Neukunden mittlerweile nur noch Dual Stack-Lite-Anschlüsse, also ohne echte IPv4-Adresse. Ohne diese sind sämtliche Portforwardings etc aber wohl nicht mehr denkbar, womit die Sache wohl gegessen ist.

Oder sieht da jemand eine andere Lösung?
(Ausgenommen Anbieterwechsel oder andere drastische Maßnahmen)
 

Harrier

Erfahrenes Mitglied
Ein Dual-Stack Proxy Server wäre natürlich möglich. Sprich, dein Rapberry meldet sich regelmäßig bei einem Server (per IPv6) der eine globale IPv4 Adresse hat. Der Server könnte alle Anfragen, die ihn über IPv4 erreichen an deine IPv6 Adresse weiterleiten. Wenn du keine eigene Domain zahlen willst, kann der Server natürlich auch seine IPv4 Adresse bei DynDNS anmelden. (Allerdings dürften die Serverkosten höher sein als die für die Domain).

Vielleicht bietet auch DynDNS selbst so etwas an, aber das weiß ich nicht. Providerwechsel wäre aber vielleicht keine so schlechte Idee.