IntelliJ IDEA Render Problem

jimb0p

Erfahrenes Mitglied
Hallo Zusammen,

immer wenn ich mir die Preview meines UIs anzeigen lasse in IntelliJ, erhalte ich ein Render problem. Genau steht hier:

Code:
Failed to find style 'coordinatorLayoutStyle' in current theme
Tip: Try to refresh the layout.

Das refreshen bringt natürlich nichts. Zudem habe ich im folgenden Code auch zwei Fehler (Zeile 25 & 29: 'Cannot resolve symbol ...') :

XML:
<?xml version="1.0" encoding="utf-8"?>
<android.support.design.widget.CoordinatorLayout
        xmlns:android="http://schemas.android.com/apk/res/android"
        xmlns:app="http://schemas.android.com/apk/res-auto"
        xmlns:tools="http://schemas.android.com/tools"
        android:layout_width="match_parent"
        android:layout_height="match_parent"
        android:fitsSystemWindows="true"
        tools:context=".DetailActivity">

    <android.support.design.widget.AppBarLayout
            android:id="@+id/app_bar"
            android:fitsSystemWindows="true"
            android:layout_height="@dimen/app_bar_height"
            android:layout_width="match_parent"
            android:theme="@style/AppTheme.AppBarOverlay">

        <android.support.design.widget.CollapsingToolbarLayout
                android:id="@+id/toolbar_layout"
                android:fitsSystemWindows="true"
                android:layout_width="match_parent"
                android:layout_height="match_parent"
                app:toolbarId="@+id/toolbar"
                app:layout_scrollFlags="scroll|exitUntilCollapsed"
                app:contentScrim="?attr/colorPrimary">

            <android.support.v7.widget.Toolbar
                    android:id="@+id/toolbar"
                    android:layout_height="?attr/actionBarSize"
                    android:layout_width="match_parent"
                    app:layout_collapseMode="pin"
                    app:popupTheme="@style/AppTheme.PopupOverlay" app:layout_collapseParallaxMultiplier="1.0"/>

        </android.support.design.widget.CollapsingToolbarLayout>
    </android.support.design.widget.AppBarLayout>

    <include layout="@layout/content_detail"/>

    <android.support.design.widget.FloatingActionButton
            android:id="@+id/fab"
            android:layout_width="wrap_content"
            android:layout_height="wrap_content"
            android:layout_margin="@dimen/fab_margin"
            app:layout_anchor="@id/app_bar"
            app:layout_anchorGravity="bottom|end"
            app:srcCompat="@android:drawable/ic_dialog_email"/>

</android.support.design.widget.CoordinatorLayout>

Kann mir jemand sagen wo genau der Fehler liegt? Den ersten Renderfehler habe ich bei allen Activities die ich hinzufüge. Hier hat es einmal geholfen die compileSdkVersion im Gradle Build Skript von 28 auf 27 herunterzusetzen. Leider hat dies auch nur kurzfristig geholfen.