1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

HTTP WWW -> HTTPS

Dieses Thema im Forum "Hosting & Webserver" wurde erstellt von phwert, 11. April 2018.

  1. phwert

    phwert Erfahrenes Mitglied

    Hallo,

    ein SEO-Tool bemängelt, dass die Webseite über unterschiedliche Wege erreichbar ist.
    Ich habe daraufhin beim Hoster "HTTPS erzwingen" gestellt, aber das reicht wohl noch nicht.
    Wenn ich in der .htaccess noch zusätzlich ein Redirect einbaue, erscheint die Seite gar nicht mehr:
    Code (Text):
    1. Forbidden
    2. You don't have permission to access / on this server.
    Jemand eine Idee?

    Gruß

    PS: Die zwei Redirect-Varianten, die ich versucht habe:
    Code (Text):
    1. #<IfModule mod_rewrite.c>
    2. #RewriteEngine On
    3. #RewriteCond %{HTTPS} off
    4. #RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    5. #RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
    6. #RewriteRule ^ https://%1%{REQUEST_URI} [R=301,L]
    7. #</IfModule>
    8. ------------------------------------
    9. #<IfModule mod_rewrite.c>
    10. #RewriteEngine On
    11. #RewriteCond %{HTTPS} off
    12. #RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    13. #</IfModule>
     
    Zuletzt bearbeitet: 11. April 2018
  2. sheel

    sheel I love Asm Administrator

    Hi

    ich nehme an, vor den ganzen Änderungen waren http und https beide fehlerfrei aufrufbar?

    Dann, erstens, mach diese Erzwingen-Option wieder weg. Ganz egal, was der Hoster damit genau meint, für einen Redirect Http->Https ist es nicht nötig. Und evt. ist auch nur das der Grund für das Forbidden; die Rewritezeilen machen sowas nämlich nicht.

    Zu den Rewrites, wenns nur um Http/s geht sollte Variante zwei reichen.

    301-Redirects mit einem Browser testen ist aber problematisch, weil die gecached werden - einmal falsch, und es bleibt vorerst so.
    Daher eher Tools wie zB. wget verwenden, und wenn es fehlerfrei funktioniert dann noch die Brwosercaches leeren und schließen+wiederöffnen vom Programm.

    ...
    Zum ursprünglichen Problem der Mehrfach-Erreichbarkeit: Bist du dir überhaupt sicher, dass es an Http/s liegt und nicht (auch) an was anderem? Die Erklärung wegen Http/s könnte einfach ein Standardtext sein, weil das oft (aber nicht immer) der Grund ist.
     
  3. phwert

    phwert Erfahrenes Mitglied

    Hej,

    ich kann nur sagen, was das SEO-Tool sagt.

    Ich hatte das Redirect in der .htaccess schon vorher auf zig verschiedene Varianten versucht, ohne es bei Strato zu erzwingen, war aber kein Unterschied. Die Seite war dann egal wie - HTTP, HTTPS, www, ohne www - nicht mehr erreichbar.

    Wie gesagt, das mit der Mehrfacherreichbarkeit kommt von dem SEO-Tool (https://freetools.seobility.net/de/seocheck/). Deshalb kam ich überhaupt da drauf.

    Ohne Redirect in der .htaccess komme ich immer auf HTTPS://meineDomain.de oder HTTPS://www.meineDomain.de. So ist der Stand auch momentan.

    Mit Redirect und egal welcher Variante kommt immer das eingangs erwähnt "ForbiddenYou don't have permission to access / on this server."

    Momentan habe ich die SSL-Erzwingung bei Strato und nichts im .htaccess. Klappt wunderbar - nur das SEO-Tool moppert. Vielleicht schreibe ich die mal an. Vielleicht ist ja mit deren Tool was nicht in Ordnung.
     
    sheel gefällt das.
Die Seite wird geladen...