hilfe apache cfg bringt mich um

H

He||cow

seit gerstern häng ich drann,
ich muss damit cgi's lokal testen

also hab den zigmal installiert usw
auch perl (nebenbei noch mysql und php und so sachen)
naja zum 1st try hab ich des ikonboard gezogen, des ja auf cgi basiert,
was mich verwirrt:
die cgi-bin liegen ja ausserhalb on htdocs
wenn ich dann lokal drauf will sagt mir der browser-server - nix

habs mal testweise ein cgi-bin in htdocs gemacht, nur darf ich da drinn dann nicht in einen unterordner - access denied

ich bin wirklich am ende ich weiss nichtmehr weiter, hab sämtliche tutorals angeguckt ein buch durchgemacht (des ist aber ******** (am rand) was mit 'mit' apache-webserver-administrator bibel - der typ schmarrt nur komisches zeug - und nix vonwegen windows)
achja auf win2k läufts

bitte bitte helft mir

thx
 

lexi

Gesperrt
Ich empfehle dir auch den vorkonfigurierten Server, wenn du dich nicht intensiv mit dem Manual auseinandersetzen willst.. ;)
 
H

He||cow

jo thx, habs gezogen,
aber so weit war meiner auch :(
des access prob hab ich immer noch
 
H

He||cow

lang halt ichs nimmer aus

jo ich nochmal :(
also habs gestern noch sehr sehr lange probiert
aber nix
dann noch den komischen server mit q und x ? irgendsowas??

naja jetzt wieder auf der arbeit, und seit 2h bau ich weiter drann rum, hab mir für hir auch den kompletten da mit perl usw gezogen,

nur:
ich krieg immer noch bei dem script das ich ausführen-öffnen will

Forbidden
You don't have permission to access /user1/cgi-bin/install.cgi on this server.
Apache/1.3.20 Server at localhost Port 80

hab alles druchprobiert, und gemacht und getan, und kopiert und was weis ich, naja der trottel aus dem buch (des angeblich ja auch wür win taugt) erwähnt da kein wort :(
naja hier ein eintrag aus der cfg: (falls es jemand nützt)
z.B.:

<Directory c:/apache/cgi-bin>
ScriptInterpreterSource registry
AllowOverride All
allow from 192.168.0
</Directory>

war nur für temp umstellen
und wenn ich des alles nach
c:/apache/user1/cgi-bin/ bla kopier (natürlich so per access.conf freigegeben)
und dann dort meinw wichtiges install.cgi ausführen will sagt mir der indianer wieder forbidden

ich kann nixmehr
´bitte bitte'
 

Arne Buchwald

Erfahrenes Mitglied
Hallo He||cow,

ich habe mal meine httpd.conf-Datei angehängt.

Ich erstelle immer z.B.: c:\apache\htdocs\MEINVERZEICHNIS\cgi-bin\install.cgi und alles funzt perfekt. Das neue CGI-BIN trage ich aber in keiner Konfigurationsdatei erneut ein.
Ich habe mal gehört, dass das mit WildCards funktioniert, d.h. dass das komplette /htdocs-Verzeichnis für Perl-Scripte freigegeben ist.
Funktioniert bei dir denn das Perl-/PHP-Beispiel-Script?
 

Anhänge

  • httpd.zip
    10,3 KB · Aufrufe: 41
H

He||cow

jo thx
hat ansatzweise auch gefunzt
nur dann kamen interpreter fehler
da denk ich dasses an mir liegt,
weil ich aus lauter verzweiflung noch diesen mit q und noch einen apache installiert hab :>
hab jetzt erstmal aufgeräumt und fang nochmal bei 0 an.
dann hoff ich mal dasses funzt, und wenns klappt könnt ich nen tut schreiben (vor allem für mich)
btw thx :)
 

lexi

Gesperrt
Die Directory freigeben zum Ausführen vcon CGIs kann man mit

<Directory "G:/public/server_res/sc/">
AllowOverride None
Options ExecCGI
Allow from all
</Directory>
 
A

apache

Hast Du schan mal unter http://www.apache-service.de nachgesehen? Die Site ist zwar noch sehr neu aber dafür gibt es schon eine ausführliche Anleitung zur Installation des Apache auch WAMP und LAMP unter win und Linux

Viel Göück
:)
 

Neue Beiträge