Flash Object, bei IE funktionierts, Firefox Darstellungsproblem


wavetraxx

Erfahrenes Mitglied
Hallo Zusammen,

ich komme bei einem Problem einfach nicht weiter. Und zwar; ich habe ein Flash-Objekt, das beim IE richtig dargestellt wird. Beim Firefox macht es aber Probleme.

Bild hier: http://img188.imageshack.us/img188/706/firefoxfrage.jpg

Code:
                <tr>
                  <td valign="top"><script src="http://www.stephanstern.ch/assets/flash/swfobject_modified.js" type="text/javascript"></script>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="1000" height="243" id="FlashID" title="Navi">
  <param name="movie" value="http://www.stephanstern.ch/assets/flash/Navi.swf">
  <param name="quality" value="high">
  <param name="wmode" value="opaque">
  <param name="swfversion" value="8.0.35.0">
  <!-- Dieses param-Tag fordert Benutzer von Flash Player 6.0 r65 und höher auf, die aktuelle Version von Flash Player herunterzuladen. Wenn Sie nicht wünschen, dass die Benutzer diese Aufforderung sehen, löschen Sie dieses Tag. -->
  <param name="expressinstall" value="Scripts/expressInstall.swf">
  <!-- Das nächste Objekt-Tag ist für Nicht-IE-Browser vorgesehen. Blenden Sie es daher mit IECC in IE aus. -->
  <!--[if !IE]>-->
  <object type="application/x-shockwave-flash" data="http://www.stephanstern.ch/assets/flash/Navi.swf" width="1000" height="243">
    <!--<![endif]-->
    <param name="quality" value="high">
    <param name="wmode" value="opaque">
    <param name="swfversion" value="8.0.35.0">
    <param name="expressinstall" value="Scripts/expressInstall.swf">
    <!-- Im Browser wird für Benutzer von Flash Player 6.0 und älteren Versionen der folgende alternative Inhalt angezeigt. -->
    <div>
      <h4>F&uuml;r den Inhalt dieser Seite ist eine neuere Version von Adobe Flash Player erforderlich.</h4>
      <p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Adobe Flash Player herunterladen" width="112" height="33" /></a></p>
    </div>
    <!--[if !IE]>-->
  </object>
  <!--<![endif]-->
</object>
<script type="text/javascript">
<!--
swfobject.registerObject("FlashID");
//-->
</script>
</td>
 </tr>

Ich sehe da keinen Fehler, es hat ja auch kein Leerzeichen oder sonstwas drinnen. An was kann das liegen?
 
M

Maik

Hi,

versuch es mal mit der display:block-Eigenschaft für das Inline-Element <object>.

mfg Maik