Eigenartige Font-Anzeige

Alice

Erfahrenes Mitglied
Hallo.

Ich weiss gar nicht ob ich hier richtig bin...

Ich habe auf einer Webseite einen Font über Google eingebunden. An meinen PC´s (z.B. MacBook Pro der neusten Generation) sieht alles sehr gut aus. Egal ob Firefox, Opera oder sogar der IE. Alles schön.

Auf den PC´s auf meiner Arbeitsstelle sieht jedoch alles total komisch aus. Irgendwie Verfranst und nicht glatt. Bei allen installieren Browsern an 10 verschiedenen (XP) Rechnern! Selbst "Lokal" (Schrift) sieht genauso bescheiden aus.

Habe sämtliche Windows und Browser Einstellungen verändert, aber es ändert sich NICHTS.

Die Google Schrift nennt sich: Montserrat
 

Anhänge

  • bs1.png
    bs1.png
    2,1 KB · Aufrufe: 64
  • bs2.png
    bs2.png
    809 Bytes · Aufrufe: 64
Zuletzt bearbeitet:

Alice

Erfahrenes Mitglied
Ich habe eben festgestellt dass das Problem auch mit meinem Hauptrechner und Opera auftritt. Mit FF und IE absolut in Ordnung.

Das ist echt eigenartig.

Edit:

Wenn ich mit Opera manuell zoome, verbessert sich die Schriftdarstellung plötzlich und sieht gut aus.

Hööö?
 
Zuletzt bearbeitet:

Cromon

Erfahrenes Mitglied
Hallo Alice

Das Problem kenn ich selber auch. In meinen OpenGL-Programmen sehe ich genau dieses Verhalten ebenfalls, siehe:
http://i.imgur.com/BCvUW8A.jpg
vs
http://i.imgur.com/Rn5wwpY.jpg

Problem war, dass bei NVIDIA-Karten der Treiber Probleme hat, wenn bei 2D-Elementen die Koordinaten keine Ganzzahlen sind und entsprechend sieht das Ergebnis nicht gut aus. Inwiefern du darauf Einfluss nehmen kannst und ob das auch bei dir der Fall ist kann ich jedoch nicht 100% sagen.

Viele Grüsse
Cromon
 

Alice

Erfahrenes Mitglied
Meine Rechner haben NVIDIA und ATI Grafikkarten. Das sind Grafikkarten aus den verschiedensten Generationen. Der eine PC auf der Arbeit hat nicht mal eine richtige Grafikkarte, sondern nur eine OnBoard-Grafikkarte und die ist nicht einmal von Intel oder so.
 

Alice

Erfahrenes Mitglied
Ich konnte das Problem lösen...

Um Fehler zu vermeiden sollten Google-Fonts einzeln eingebunden werden und nicht wie es Google vorschlägt. Auch die unterschiedlichen Schriftstärken müssen einzeln geladen werden. Wenn man eine Favorit-Schriftart hat, sollte diese als erstes eingebunden werden.

Webdesign macht so echt kein Spaß mehr...
 

DexXxtrin

Erfahrenes Mitglied
Ich hatte dieses Problem auch mal. Soviel mir ist hatte es etwas mit dem Rendern zu tun und ich muste das noch einstellen. Allerdings kann ich dir leider nicht mehr sagen, wie der Code dazu aussah. Aufjedenfall das Textrendering im CSS anpassen, dann hats geklappt. ;)
 

Alice

Erfahrenes Mitglied
Ich kenne den einen oder anderen Code zum Rendern. Jedoch sind es meistens ganz andere Probleme. Google-Fonts sind allgemein als "Zickig" bekannt.
 

Neue Beiträge