Debian Jessie FTP TLS / SSL


exestend

Mitglied
Hallo :)

Ich benötige mal eure Hilfe.

Ich habe folgendes gemacht:
Ich habe VSFTP installiert, ein Zertifikat generiert mit openssl und die vsftpd conf bearbeitet. aber ich bekomme in Filezilla immer das Ergebnis:
Code:
Status:    Verbinde mit 188.68.xx.xx:21...
Status:    Verbindung hergestellt, warte auf Willkommensnachricht...
Status:    Initialisiere TLS...
Status:    Überprüfe Zertifikat...
Status:    TLS-Verbindung hergestellt.
Status:    Der Server unterstützt keine Nicht-ASCII-Zeichen.
Status:    Angemeldet
Status:    Empfange Verzeichnisinhalt...
Befehl:    PWD
Antwort:    257 "/"
Befehl:    TYPE I
Antwort:    200 Switching to Binary mode.
Befehl:    PASV
Antwort:    227 Entering Passive Mode (188,68,xx,xx,47,158).
Befehl:    LIST
Fehler:    Zeitüberschreitung der Verbindung nach 20 Sekunden Inaktivität
Fehler:    Verzeichnisinhalt konnte nicht empfangen werden

Die vsftpd conf sieht so aus:
# Run standalone vs. from an inetd – start daemon from an initscript
listen=YES
#
# Disallow anonymous FTP.
anonymous_enable=NO
#
# Allow local users to log in.
local_enable=YES
#
# Allow per-user configuration for local users.
user_config_dir=/etc/vsftpd_user_conf
#
# Enable FTP write commands – controlled with cmds_allowed list.
write_enable=YES
#
# Don’t allow recursive listing – prevents excessive I/O usage.
ls_recurse_enable=NO
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Display directory listings with the time in your local time zone.
# Default is to display GMT.
use_localtime=YES
#
# Activate logging of uploads/downloads, but not in xferlog format
xferlog_enable=YES
xferlog_std_format=NO
log_ftp_protocol=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# Uploaded files are owned by the uploader.
chown_uploads=NO
#
# Default log – enable and change for custom location/name
xferlog_file=/var/log/vsftpd.log
#
# You may change the default value for timing out an idle session.
idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
data_connection_timeout=120
#
# Don’t allow ASCII mangling on files when in ASCII mode.
# ASCII mangling is a horrible feature of the protocol.
ascii_upload_enable=NO
ascii_download_enable=NO
#
# Customize the login banner string:
ftpd_banner=Welcome to our FTP service.
#
# Customization
#
# Some of vsftpd's default settings don't fit the filesystem layout.
#
# Empty directory which isn’t writable by the ftp user. This directory is used
# as a secure chroot() jail when vsftpd does not require filesystem access.
secure_chroot_dir=/var/run/vsftpd/empty
#
# This string is the name of the PAM service vsftpd will use.
pam_service_name=vsftpd
#
# Location of the RSA certificate to use for SSL encrypted connections.
rsa_cert_file=/etc/ssl/private/vsftpd.pem
#
# Allow PASV (passive ftp)
pasv_enable=YES
pasv_min_port=12000
pasv_max_port=12500
port_enable=YES
# enter your IP address on the line below – example: 184.37.445.210
pasv_address=188.68.xx.xx
pasv_addr_resolve=NO
#####################################################
listen_ipv6=NO
nopriv_user=www-data
chroot_local_user=YES
allow_writeable_chroot=YES
#rsa_private_key_file=/etc/ssl/private/vsftpd.pem
ssl_enable=YES
######################################################
#
# set chmod correctly for apache, see
# http://en.gentoowiki.com/wiki/Vsftpd
file_open_mode=0666
# Default umask for local users is 077 – replace with 022
local_umask=0022
#

So, wenn ich jetzt
Code:
ssl_enable=YES
auskommentiere, dann klappt es. Dann kann ich mich einloggen.

Ich habe mich an das Thema gehalten:
https://forum.netcup.de/administrat...er/8127-ftp-server-installieren-ubuntu-14-04/

Aber ich glaube irgendwie nicht, dass ich das so richtig gemach thabe bzw. die Anleitung in dem Thema da so richtig ist.

Ich habe aber die gleiche Problematik:

Ich benötige einen FTP Server, der User mit dem ich mich einlogge soll und muss Lese und Schreibrechte im Ordner /html/ haben, dem der nginx Webserver gehört etc.

Kann mir da jemand auf die Sprünge helfen