Content "springt" - Inhalt wird im FF komplett neu geladen

08154711

Erfahrenes Mitglied
Hallo,
Folgendes Problem. Ich habe das Gefühl das der Seiteninhalt komplett neu geladen wird, dies tritt allerdings nur im FF auf. Der IE verhält sich wie es sein soll. Kann das Leider nicht hochladen, deshalb poste ich hier den Code. Habe mehrmals getestet, mir scheint als würde es auch manchmal funktionieren, es tritt sporadisch auf...

HTML:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Home</title>
<link href="css/layout.css" rel="stylesheet" type="text/css" />
<script type="text/javascript" src="../includes/Creative_Menus/menuDisplay.js"></script>
<script type="text/javascript" src="../includes/Creative_Menus/swfobject.js"></script>
</head>
<body>
<div id="wrapper">
  <div id="head"></div>
  <div id="leftcolumne"><img src="websiteimg/uebersicht.jpg" width="200" height="70" alt="linkleiste" />
   <div id="navPlaceholder"><!-- Creative menu Menu2 begin -->
    <div id="CMPH_Menu2"> <img src="../includes/Creative_Menus/spacer.gif" width="150" height="285" alt="" /></div>
    <div id="creative_menu_Menu2" >
      <div id="menu_holder_Menu2">
        <!--(start menu data)<div id="menu_options" contenttype="Static + Dynamic" menu_type="V" menuzindex="1000"  totalwidth="150" totalheight="285" fittopage="false" skin="Notched Menu" skincustom="" skinfiles="" mainColors="#535559,#CCCCCC" subColors="#202020,#FFFFFF" resizeOptions="" cutRoundCorners="false">
          <div id="main_menu" mainButPos="Top,10"  mainButResize="fit to largest text" ></div>
          <div id="main_button" mainButSpacing="1" mainBESettings="Fade,10" mainButReverse="true"  mainArrow="0,0" showMainArrow = "true" mainMinSize="100" ></div>
          <div id="main_text" mainFont="Trebuchet MS,12"  mainUpFmt="#FFFFFF,,,"  mainOverFmt="#FFFFFF,bold,,"  mainDownFmt="#000000,bold,,"  mainHTSettings="Center,10" mainVTSettings="Middle,0" mainVTSpace="10" ></div>
          <div id="sub_menu" subButPos="Middle,8" subMESettings="FreeSlideH,10" subMenuReverse="true" openEvent="Rollover" delays="8,8"  vSubMenuAlign="Top" hSubOverlap="0" subMinSize="130" submenualpha="100" fixalphatext="true" ></div>
          <div id="sub_button" subButSpacing="1"  subBESettings="Fade,10" subButReverse="false" showSubArrow = "false" subArrow="" subButResize="fit to largest text" ></div>
          <div id="sub_text" subFont="Trebuchet MS,12"   subUpFmt="#FFFFFF,,,"   subOverFmt="#000000,bold,," subDownFmt="#000000,,," subHTSettings="Center,10" subVTSettings="Middle,0"  subHTSpace="10" subVTSpace="10" > </div>
        </div> (end menu data)-->
<div id="creative_menu_structure" >
  <div><a href="welcome.html" target="_top" title="">Home</a></div>
  <div><a name="empty" href="" target="_blank" title="">Über uns</a></div>
  <div><a name="empty" href="" target="_blank" title="">Fotos</a>
    <div><a name="empty" href="" target="_blank" title=">">1</a></div>
    <div><a name="empty" href="" target="_blank" title=">">2</a></div>
    <div><a name="empty" href="" target="_blank" title=">">3</a></div>
    <div><a name="empty" href="" target="_blank" title=">">4</a></div>
    <div><a name="empty" href="" target="_blank" title=">">5</a></div>
  </div>
  <div><a name="empty" href="" target="_blank" title="">Termine</a></div>
  <div><a name="empty" href="" target="_blank" title="">Links</a></div>
  <div><a name="empty" href="" target="_blank" title="">Gästebuch</a></div>
  <div><a name="empty" href="" target="_blank" title="">Presse</a></div>
  <div><a href="empty" target="_blank" title="">Kontakt</a></div>
  <div><a href="impressum.html" target="_top" title="">Impressum</a></div>
</div>
      </div>
    </div>
    <!-- Creative menu Menu2 end --></div> 
  </div>
  <div id="container"><h1 class="h1">Servus und Hallo</h1>
    <p>Similique sunt in culpa qui officia deserunt mollitia animi, cumque nihil impedit quo minus quia voluptas sit aspernatur. Sed ut perspiciatis unde omnis magnam aliquam quaerat voluptatem. Quis nostrum exercitationem excepturi sint occaecati cupiditate non provident, qui ratione voluptatem sequi nesciunt. Cum soluta nobis est eligendi optio velit esse quam nihil molestiae consequatur, ut aut reiciendis voluptatibus maiores alias.<br />
      <br />
    </p>
    </div>
</div>
<!-- Creative Menus - menu rendering scripts start -->
<script type="text/javascript"> buildMenu() </script>
<noscript>
This menu requires JavaScript in order to be properly displayed. Viewing requirements can be found at <a href="www.extendstudio.com">Extend Studio</a> (Flash components and extensions, Dreamweaver extensions, Tools for web design and development)
</noscript>
<!-- Creative Menus - menu rendering scripts end -->
</body>
</html>
Code:
@charset "utf-8";
html, body {
	margin:0;
	padding:0;
	height:100%;
	background:#535559;
}
div#wrapper {
	position:relative;
	margin:0 auto;
	width:900px;
	min-height:100%; 
	height:auto !important; 
	height:100%;
	background:#fff;
}
div#wrapper p {
	font-family:Georgia, "Times New Roman", Times, serif;
	font-size:13px;
	margin:0;
}
div#head {
	background-image:url(../websiteimg/header.jpg);
	display:block;
	height: 220px;
}
div#leftcolumne {
	width:200px;
	background-color:#fff;
	height: auto;
	float: left;
}
div#container {
	width: 650px;
	margin-left: 210px;
} 
div#navPlaceholder {
	margin-left: 25px;
}
.h1 {
	font-size:20px;
	font-family: Georgia, "Times New Roman", Times, serif;
	padding-top: 5px;
	text-align: center;
}
.h2 {
	font-size:16px; padding-bottom:10px;
	font-family: Georgia, "Times New Roman", Times, serif;
	padding-top: 5px;
	text-decoration:underline;
	font-weight: bolder;
}
 
M

Maik

Hi,

mit deinem gezeigten HTML- und CSS-Code verhält sich bei mir Firefox sowas von mucksmäuschenstill ;-)

Kein neuer Ladevorgang, geschweige denn ein sprunghafter Content ist in ihm zu registrieren.

Vielleicht solltest du daher mal besser die Seite online zur Verfügung stellen, damit sie auch in ihrem vollständigen Umfang begutachtet werden kann, denn beispielsweise die eingebundenen Javascripts fehlen hier, und könnten demnach eventuell die Ursache sein.

mfg Maik
 

08154711

Erfahrenes Mitglied
Hi Maik,
Danke für die schnelle Antwort. Kann leider nix hochladen, die alte Seite ist noch aktiv. Gibt es vielleicht Hoster wo man sein eigenes FTP Programm zum Uploaden nutzen kann?
Danke
 
M

Maik

Ähm, kannst du auf deinem Server für die Testseite kein gesondertes Unterverzeichnis anlegen, das die Produktivumgebung nicht tangiert? :eek:

Ansonsten gibt es im Netz doch genügend Webspace-Anbieter, die ihre Unkosten durch Werbung finanzieren, und so als kostenlose Testumgebung alle mal gut sind ;-)

Und ja, auch die ermöglichen den Datei-Upload über ein FTP-Programm.

mfg Maik
 

08154711

Erfahrenes Mitglied
Geht leider nicht, hab nur die FTP Daten zum hochladen. Ich werde sehen, ob ich den die alte Webseite mal schnell rauswerfen kann:) , dann werde ich sehen was passiert...
Danke
Habe den Cache geleert, und jetzt gehts. Die Flashnavigation ist das was jetzt noch ständig neu geladen wird. Mist sehe gerade das im IE eine "Border" ist die ich vorhin nicht gesehen habe und auch nicht dahin gehört.
 
Zuletzt bearbeitet:

08154711

Erfahrenes Mitglied
Nochmal ich, habe mal schnell die Seite hochgeladen und es klappt alles sowohl im FF als auch im IE:). Bis auf die Flashnavigation sieht alles gut aus, da diese neu geladen wird. Ist es möglich die Flash Navigation so einzubinden das diese nicht ständig neu geladen werden muß?
Danke
 
M

Maik

Freut mich, dass du die Seite, wo auch immer, hochgeladen hast, und uns den Link verschweigst - so kann ich mich ja jetzt beruhigt zurückziehen, und meine kostbare Freizeit mit sinnvolleren Aktivitäten verbringen :p

Wenn aus dem Navigationsmenü heraus eine neue Seite aufgerufen wird, bleibt es bei diesem Markup nicht aus, dass die eingebundenen Dateien vom Browser neu geladen werden.

mfg Maik
 
M

Maik

Ist dir die ganze Zeit etwa nicht aufgefallen, dass für das "Springen" der Seite der vertikale Scrollbalken am rechten Fensterrand verantwortlich ist?

In der "Home"-Seite existiert er nicht, und beim Aufruf des "Impressums" erscheint er, womit der Inhalt des Dokumentskörpers um seine Breite nach links verrückt wird. Ein ganz normales Verhalten, das in der Sache der Natur liegt, und in jeder x-beliebigen Website im Netz auftritt.

Dass dies in der IE-Familie (6 bis 8) nicht der Fall ist, liegt daran, dass sie grundsätzlich ohne eine spezielle overflow-Formatierung den Scrollbalken auch dann im Fenster bereithalten, wenn es darin überhaupt nichts zum Scrollen gibt, in diesem Fall dann als inaktives Steuerelement (ausgegraut), aber damit sie was zum Scrollen haben, sorgst du ja mit dem Hinweis am oberen Fensterrand, der auch nur in ihnen erscheint :suspekt:

Viele Webauftritte haben bereits die Unterstützung für den von Ihnen verwendeten Browser eingestellt, da dieser Fehler und Sicherheitslücken hat. Einige Inhalte werden auf Ihren Browser fehlerhaft oder sogar gar nicht mehr angezeigt.
Um die beste Darstellung, alle Inhalte und mehr Sicherheit zu erhalten, empfehlen wir Ihnen die Aktualisierung Ihres Browsers auf eine neuere Version. Diese Seite verwendet Flash. Um Darstellungsfehler zu vermeiden aktivieren Sie bitte Javascript.

Wenn du in den standardkonformen Browsern (Firefox, Opera, Safari, u.ä.) ebenfalls den inaktiven Scrollbalken erscheinen lassen willst, um das Springen zu vermeiden, ist overflow:scroll die Regel deiner Wahl.

mfg Maik
 

08154711

Erfahrenes Mitglied
Hi,
Sorry, ist mir nicht aufgefallen (bei mir kein Scrollbalken zu sehen). Mal sehen was man hier vielleicht noch machen kann. Ich habe die alte Seite erstmal wieder aktiviert. Danke erstmal