APK öffnen und starten

Status
Dieses Thema wurde gelöst! Zur Lösung gehen…

mediamat

Erfahrenes Mitglied
Also da passiert dann was (aber es wartet wohl trotzdem auf das Device).
Ich hab beides eingegeben, zweimal, weil ich dachte, der gezeigte Error liegt dran, weil Android Studio parallel nicht lief...

Code:
C:\Users\mail\AppData\Local\Android\Sdk\platform-tools>adb devices
List of devices attached
* daemon not running; starting now at tcp:5037
* daemon started successfully

C:\Users\mail\AppData\Local\Android\Sdk\platform-tools>
C:\Users\mail\AppData\Local\Android\Sdk\platform-tools>adb install timer_v3.0_apkpure.com.apk
error: no devices/emulators found
adb: error: failed to get feature set: no devices/emulators found
- waiting for device -

Code:
C:\Users\mail\AppData\Local\Android\Sdk\platform-tools>adb devices
List of devices attached

C:\Users\mail\AppData\Local\Android\Sdk\platform-tools>
C:\Users\mail\AppData\Local\Android\Sdk\platform-tools>adb install timer_v3.0_apkpure.com.apk
error: no devices/emulators found
adb: error: failed to get feature set: no devices/emulators found
- waiting for device -

Mein Device, was ich im AVD Manager sehe heißt Nexus 5X API 28

PS: Dass ich den Ordner "Sdk" in einem versteckten Ordner "AppData" fand, fand ich übrigens seltsam, denn installiert habe ich es eigentlich ganz normal bei den Programmen auf C:/. Und gibt dort auch noch einen Ordner "Android" aber dort liegt nur ein Ordner "Android Studio" und kein "Sdk"-Ordner drin.
 

zerix

Hausmeister
Moderator
Läuft der Emulator denn auch?

Das mit dem SDK ist richtig, das wird im Userverzeichnis in einem Ordner gespeichert

Viele Grüße
Sascha
 

mediamat

Erfahrenes Mitglied
Achso, nein, ich dachte weil ich das nicht mit dem grünen Playbutton starten sollte.
Also jetzt habe ich das gemacht.
Nun kommt nach adb install timer_v3.0_apkpure.com.apk
Success


Aber auf dem Emulator läuft es trotzdem nicht.

In Android Studio zeigt es immernoch ein rotes Ausrufezeichen bei "RunTask" und wenn ich es aufklappe steht der Fehler bei "Application:mergeDebugResources"

Ausschnitthaft steht da in den Fehlermeldungen unter anderem Folgendes:
(Es fehlen da von Android Studio irgendwelche Dateien oder?!)
Code:
Failed to capture fingerprint

aused by: org.gradle.api.internal.artifacts.ivyservice.DefaultLenientConfiguration$ArtifactResolveException: Could not resolve all files for configuration ':Application:_internal_aapt2_binary'

Caused by: org.gradle.internal.resolve.ModuleVersionNotFoundException: Could not find com.android.tools.build:aapt2:3.3.1-5013011.
 

zerix

Hausmeister
Moderator
Weil du es nicht mit Android Studio so starten kannst. Du hast die App jetzt im Emulator installiert und kannst diese im Emulator starten, wie an einem normalen Smartphone.

Um die App mit Android Studio starten zu können, müsste das Debuggable Flag gesetzt sein.
 

mediamat

Erfahrenes Mitglied
Oh mann jetzt hab ich das durch Zufall kapiert...ich hab irgendwie kurz mit dem Mausrad gescrollt und dann kamen im Emulator plötzlich eine Liste mit allen Apps und das zu meiner App gehörige Icon. Ich hab vorher nämlich permanent nur den leeren "Smartphone Desktop" mit Mail-, SMS-Icon etc. gesehen und nix wo ich sonst noch klicken könnte.

Ok, also riesigen Dank für deine Mühe! Jetzt läuft es!

PS: Gibt es "Baukästen" für native Apps? Sowas wie WordPress, wo man verschiedene Elemente hat und auch Parameter untereinander übergeben kann...z.B. die Blogbeiträge an Stelle X werden an Stelle Y als Carousel reingeladen, aber man muss erstmal weder die Blogbeitragsfunktion noch das Carousel programmieren, da es schon existiert?
Und das Ganze so, dass es ein Programmierer aber noch individuell bearbeiten kann, also kein "geschlossener Baukasten" wo man nichts individuell dran rumprogrammieren kann.
 
Zuletzt bearbeitet:
Status
Dieses Thema wurde gelöst! Zur Lösung gehen…

Neue Beiträge