Anwendung läuft nur auf Entwicklungsrechner

CopWorker

Erfahrenes Mitglied
Hallo zusammen,

mein Programm habe ich auf C# geschrieben.
Dieses Projekt greift auf mehrere DLLs zu. Diese DLLs sind teils mit .NET Framework 4.0 und teils mit 4.6.1 erstellt.
Mein Projekt ist mit .NET Framework 4.6.1 als Zielframework erstellt.

Die Situation ist folgende:
Im Release läuft das ganze Programm korrekt aber nur auf meinem Entwicklungsrechner.
Da sind verschiedene .NET Frameworks von 4.5 bis 4.8 drauf.

Auf dem Zielrechner läuft das Programm nicht korrekt.
Was nicht funktioniert ist die RPC Kommunikation, warum auch immer.
Muss da noch was eingestellt werden?
Auf dem Zielrechner habe ich das .NET Framework 4.8 installiert.
Ich sehe aber in den Windows Features nur folgendes:

1608129381811.png


Erst dachte ich installiere auch noch .NET Framework 4.61. Das wird aber verweigert.
Die Windows Meldung sagt aus, dass bereits ein gleichwertiges oder späteres Framework bereits drauf ist.

Warum sehe ich das .NET Framework 4.8 nicht?.
Sind die Frameworks überhaupt abwärts Kompatibel?

Vielen Dank.
Grüße von CopWorker
 

Spyke

Premium-User
Du könntest mal in die Ereignisanzeige reinschauen, ev. ist dort ein Fehler für dein Programm protokolliert der dir weiterhelfen könnte.

Ev. auch mal Firewall prüfen.
 

Neue Beiträge