403 zur Startseite weiterleiten per htaccess

diel2001

Mitglied
Gibt es da eine Möglichkeit das zu realisieren ?

Ich habe im Internet schon einige Beispiele gefunden, aber irgendwie funktionieren das nicht .

Hier ist das Beispiel

Code:
     ErrorDocument 403 index.php

Alle anderen Weiterleitungen funktionieren in der Datei.
 

tombe

Erfahrenes Mitglied
Genauso wird es auch auf dieser Seite angegeben.

Wenn alle anderen Weiterleitungen innerhalb der htaccess funktionieren, kann es dann daran liegen das es vielleicht kein 403-er ist?

Oder wird der Fehler nicht in dem Verzeichnis ausgelöst wo die index.php liegt?
 

diel2001

Mitglied
Doch es ist das gleiche Verzeichnis. Aber irgendwie habe ich es noch nie hinbekommen Fehlercodes weiter zu leiten.
Muss ich vielleicht noch in der httpd.conf etwas einstellen ?
 

diel2001

Mitglied
Nein das funktioniert leider so auch nicht.

Finde ich auf dem Server irgendwo eine log datei, um Anfragen zu sehen ?

Vielleicht sollte ich noch erwähnen, dass ich diese Weiterleitung für den Fall brauche, wenn der Get Request zu lang ist. Ich weiß nicht, ob das relevant ist.
 
Zuletzt bearbeitet:

tombe

Erfahrenes Mitglied
Also ich habe es eben mit 404 (da ich keinen 403 nachstellen kann!? !?) versucht.

Wenn ich nur "index.php" angebe, wird mir das als Text im Browser angezeigt. Gebe ich aber "/index.php" an, wird umgeleitet. Hier allerdings auf die Seite ein Vezeichnis weiter oben.

Was bei mir klappt ist wenn ich die komplette URL eintrage.
 

tombe

Erfahrenes Mitglied
Code:
# die .htaccess befindet ebenfalls im Verzeichnis "test"
ErrorDocument 404	http://localhost/test/index.php

# das geht auch nur wird eben auf ein Verzeichnis weiter oben umgeleitet
ErrorDocument 404 	/index.php

Das zweite Beispiel leitet bei mir dann vom Verzeichnis "test" um ins Stammverzeichnis, aber gehen tut es. Aber ich habe hier auch wie gesagt auf den Fehler 404 und nicht auf 403 geprüft, aber das sollte keinen Unterschied machen.


Was passiert eigentlich bei dir wenn du es mit deinem Code versuchst, wäre ja auch mal gut zu wissen!
 

diel2001

Mitglied
Das scheint alles nicht zu funktionieren. Ich muss mal wieder irgendwas falsch machen.
Wenn ich es mit meinem Code versuche, bekomme ich weiterhin den Fehler 403
(Forbidden
You do not have permission to access this document.

).
Hier ist meine Datei :

Code:
RewriteEngine On
Options +FollowSymlinks 
# Deflate Compression by FileType
<IfModule mod_deflate.c>
 AddOutputFilterByType DEFLATE text/plain
 AddOutputFilterByType DEFLATE text/html
 AddOutputFilterByType DEFLATE text/xml
 AddOutputFilterByType DEFLATE text/css
 AddOutputFilterByType DEFLATE text/javascript
 AddOutputFilterByType DEFLATE application/xml
 AddOutputFilterByType DEFLATE application/xhtml+xml
 AddOutputFilterByType DEFLATE application/rss+xml
 AddOutputFilterByType DEFLATE application/atom_xml
 AddOutputFilterByType DEFLATE application/javascript
 AddOutputFilterByType DEFLATE application/x-javascript
 AddOutputFilterByType DEFLATE application/x-shockwave-flash
</IfModule>
RewriteCond %{REQUEST_FILENAME} !-f
ErrorDocument 403   /index.php
RewriteRule ^category/([0-9]+)/([0-9]+)/.*$ redirect.php?category=$1&limit=$2 [L]
 

tombe

Erfahrenes Mitglied
Hast du es auch mal mit der kompletten URL für die index.php versucht?

Oder erstelle mal eine neue .htaccess und gib nur die Anweisung für die Fehlerseite ein. Nicht das es gar nicht daran liegt sondern an einer der anderen Anweisungen.
 

Neue Beiträge