Zweimal verzweifelt beim Mapping

tifix

Grünschnabel
Hallo,

mittlerweile bin ich echt verzweifelt:confused: beim Mapping.

2 unlösbare Probleme stellen sich mir auch nachdem ich schon stunden lang in der 3d max bible gewälzt habe...

Also, alles eigentlich recht simple: Ich möchte auf meinen helm mit dynamischen Texturen belegen, die ich in Photoshop gebastelt habe und als PSD gespeichert hab.

Ich lade die Textur als Bitmap in mein arch+ design mental ray material als individual layer. Mein Ausgangsmaterial ist Weiß, nachdem ich die Textur reingeladen habe wird sie warum auch immer schwarz(!).

Zur Hintergrund Info
Ich nutze einen UV map modifier
meine PSD Datei ist durchsichtig
Tiling ist off
und image Alpha ist aktiviert.

und dann noch was
wie bekomme ich es hin, dass die Textur nicht durch das gesamte Objekt gedrückt wird, sondern nach der ersten Abbildung aufhört, sprich nur einseitig gemappt wird?

Hilfe...

Vielen Dank
 

Sneer

Erfahrenes Mitglied
wie bekomme ich es hin, dass die Textur nicht durch das gesamte Objekt gedrückt wird, sondern nach der ersten Abbildung aufhört, sprich nur einseitig gemappt wird?

Wenn Du mit "Abbildung" die Faces/Polys meinst, solltest Du Dein Objekt entweder in Einzelobjekte aufteilen - so kannst Du jedem Objekt einen eigenen MaterialSlot zuweisen.
Oder Du arbeitest mit verschiedenen IDs und einen Multi/Sub-Objekt Material.
So kannst Du die Polys gruppieren und mit verschiedenen Texturen belegen.
Mehr zur ID-Einteilung findest Du in der 3dsmax Hilfe (F1).

Ich lade die Textur als Bitmap in mein arch+ design mental ray material als individual layer...
...Zur Hintergrund Info
Ich nutze einen UV map modifier
meine PSD Datei ist durchsichtig
Tiling ist off
und image Alpha ist aktiviert.
Ist denn "Show in View Port" im MaterialEditor angeklickt? :)

Zum arch+design sollte Deine Textur unter Diffuse in den Color-Kanal gelegt werden, die ausgewählte Farbe wird (bei 100% Einblendung) dann keine Rolle mehr spielen.
Die ausgewählte Ebene aus der PSD-Datei sollte nun auf dem Objekt zu sehen sein.
Was in der PSD als transparant angezeigt wird, ist in 3dsmax schwarz und muss jetzt mit Hilfe des Alpha-Kanals ausgeblendet werden.
Wie man mit Alpha-Kanälen arbeitet findest Du auch in der 3dsmax Hilfe.
 

Zinken

Erfahrenes Mitglied
Das Problem mit dem Alpha-Kanal bei A&D-Materialien ist mir auch schon aufgefallen. Im Gegensatz zu Standard-Materialien wird hier nicht die Grundfarbe angezeigt, sondern einfach schwarz.
Eine Lösung wäre, ein Blend-Material zu benutzen - einmal A&D mit Textur, einmal A&D nur Grundfarbe und den Alpha-Kanal der Textur als Maske (AlphaSource: Image Alpha, Mono Channel Output: Alpha).

Das zweite Problem könntest Du mit einem Double-Sided Material lösen. Hier kannst Du für Vorder- und Rückseite der Polygone unterschiedliche Materialien anlegen.
Vielleicht reicht es aber auch schon, im Bitmap-Rollout den Haken bei "Show Map on Back" zu entfernen.
 

Neue Beiträge