Weiterleitung funktioniert nicht


phwert

Erfahrenes Mitglied
Hallo,

beim ISP liegen 2 Domains:
Domain1.de ohne SSL​
Domaint2.de mit SSL​

Unter dem Pfad für Domain1.de liegt eine .htaccess mit folgendem Inhalt:
Code:
RewriteCond %{REQUEST_URI} (.*)
RewriteRule ^(.*)$ https://domain2.de/$1 [L,R=301]

Struktur:
/
- D1
- ---- .htaccess (wie zuvor)
- D2
- ---- .htaccess (anderer Inhalt)
- ---- index.html
- ---- weitere Dateien...

Wenn man im Browser http://domain1.de eingibt, wird auf domain2.de umgeleitet.
Wenn man Browser https://domain1.de eingibt, wird nicht auf domain2.de umgeleitet.
Meldung bei https...:
Code:
Die Website ist nicht erreichbar
Die Webseite unter https://domain1.de/ ist eventuell vorübergehend nicht verfügbar 
oder wurde dauerhaft an eine neue Webadresse verschoben.
ERR_SSL_UNRECOGNIZED_NAME_ALERT
Woran liegt das? Was müsste geändert werden?

Grüße
 
Zuletzt bearbeitet:

merzi86

Erfahrenes Mitglied
Hi phwert,
das klingt fast so als würde der vHost für die HTTPS der ersten Domain auf einen anderen Ordner zeigen und in diesen liegt nicht diese .htaccess.

Bei einigen ISPs gibt es für den Https-Content auf dem FTP einen extra Ordner.
Dort müsste dann die .htaccess mit rein.
 

merzi86

Erfahrenes Mitglied
Die Fehlermeldung sagt, dass etwas nicht mit dem SSL-Zertifikat stimmt, welches für die domain1 genutzt wird. Genauer gesagt scheint der Domainname nicht in dem Zertifikat enthalten zu sein.

Testen, ob es daran liegt kannst du z.B. hier: SSL Server Test (Powered by Qualys SSL Labs)

Das könntest du dann nur beheben indem du ein Zertifikat für die Domain einstellst, welches auch für diese Domain ausgestellt ist.
 

phwert

Erfahrenes Mitglied
Ich habe nicht vor, ein SSL-Zertifikat für Domain1 zu kaufen.
Merkwürdig ist, dass es bei einer andere Kombination (Domain3 und Domain4) bei demselben ISP mit genau derselben Konstellation wunderbar funktioniert.
Oh nein, stimmt doch nicht, habe es gerade noch mal gecheckt. Ist aber auch zu blöde, dass die Browser immer mehr URI-Bestandteile nicht darstellen, wenn man etwas eingibt.
Es gibt also keine Möglichkeit, dass, wenn jemand https:domain.de im Browser eingibt, und es existiert kein SSL-Zertifikat, man trotzdem auf eine andere Seite umgeleitet wird?
 
Zuletzt bearbeitet: