W3C HTML-Validator lokal installieren ?

gOmax

Mitglied
Tachschön an euch :)

Vorweg mal eins, falls dieses Thema im falschen Forum ist bitte ich um Schiebung und Entschuldigung. Habe leider kein passenderes gefunden und das Thema hat doch so einiges mit HTML zu tun..."denk" ich mal ;) :rolleyes:

So nun ansEingemachte ;-)

Da ich nicht immer das Internet zur Verfügung habe und ich doch (sehr) gern Validen HTML-Code tippeln möchte war ich auf der suche nach einem freien HTML-Validator und stiess auf diesen vom W3C den man sich auf einen lokalen HTTP-Server + Perl installieren kann. Ja und das mit dem "kann" ist so eine Sache, das tu ich leider nicht koennen :confused:

Ich hab schon diverse Anleitungen beäugt (SelfHTML, W3C is leider auf engl., myhpi is ja das gleiche wie SelfHTML, und bjoernsworld) doch leider steig ich nicht so recht dahinter.

Ich hab: WinVista + XAMPP 1.6.7 + PerlAddon 5.10

Läuft auch alles soweit, wenn ich mir nun die PerlAddons von ActiveState mit hilfe des PPM-GUI auflisten lasse fehlen dort ein paar die ich laut dieser Anleitungen benoetige.
Das wären:
- Encode::JIS2K
- HTML-Encoding
- HTML-Tidy
- SGML-Parser-OpenSP
- XML-LibXML
- XML-LibXML-Common

Wo bekommt man die nun her ? :confused:
Für die Version 5.8 gibt es ja das zip zum downloaden, nur funktionieren diese ppm´s auch mit der 5.10 ?

Hat wer den W3C-Validator schonmal lokal installiert und würde mir dabei etwas helfen ?

Danke schonmal im vorraus :)

M.f.G
gOmax
 

crazy_root

Mitglied
Es hat zwar nichts mit deinem Vorschlag zutun, aber ich habe einen anderen Tipp für dich:
Wenn du deinen Code im Browser überprüfen willst und du vielleicht FF benutzt, kann ich dir dieses Add-On empfehlen

LG
crazy_root
 

gOmax

Mitglied
Nabend

Vielen Dank für die Tipps, hab mir diese Plugins auch gleich mal installiert und komme ganz gut damit zurecht :)

Da es diverse benötigte Perl::plugins (siehe Liste im 1. Post) für die v5.10 noch nicht zu geben scheint (jedenfalls nicht für Windows) werde ich wohl mit den Firefox-Plugins vorlieb nehmen um Validen Code zu schreiben. ;)

Schade eigentlich, da ich vorhatte den W3C-Validator in meinem Intranet zur Verfügung zu stellen :(

Falls doch noch jemand hilfreiche Tipps hat wie ich den Validator unter der XAMPP 1.6.7+Perl 5.10 zum laufen bekomme, währe das echt klasse :)

In dem Sinne...danke nochmal an euch beide

hf
gOmax
 
Zuletzt bearbeitet:

ZodiacXP

Erfahrenes Mitglied
Ha. Wenn der Thread schon mal da ist:

Kann Firebug die Größe vom FF-Fenster ändern? Z.b. auf 800x600 (oder 1024x768) damit man sieht wie jemand mit solch einer Auflösung die Seite sieht.

Nutze dazu das AddOn WebDeveloper, was auch schön alle CSS-Styles gleichzeitig ausschaltet über Hotkeys ;)

Hab seit Wochen Firebug auch noch dabei und beide gleichzeitig muss doch nicht sein ^^
 

gOmax

Mitglied
Hallo, Ich nochmal zum Abschluss :)

Ich hab es nun endlich geschafft den W3C-Validator lokal zu installieren *juhu freu*

Musste mir zwangsweise doch Perl 5.8 installieren das es die besagten Module für 5.10 nirgend zu geben scheint.

Also für jeden der sich den Validator auch lokal installieren möchte und XAMPP 1.6.7 verwendet der muss sich PERL 5.8 zusätzlich von ActivePerl runterladen und installieren da es für XAMPP 1.6.7 kein Perl 5.8 Plugin gibt ;)

Danke euch nochmal für eure FirefoxPluginTips...funktionieren Natürlich auch sehr gut :)