Virutelles Hosten verschiedener Verzeichnisse

NetBull

Erfahrenes Mitglied
Hallo Leute,

um in Zukunft nicht alle meine Webprojekte im htdocs machen zu müssen und beim nächsten System Restore nicht böse baden zu gehen weil ich die Verzeichnisse schlichtweg vergessen hatte zu sichern, möchte ich jedes WebProjekt in ein eigenes Verzeichnis legen, wo es auch vom Webserver aufgerufen wird.

Dazu habe ich folgende Ändernungen an der vhosts im Windows Systemverzeichnis angelegt

problem: alle hosts zeigen auf das gleiche verzeichnis
auch der localhost der weiterhin im XAMP verzeichnis sein soll

hosts datei im windows system
Code:
# Copyright (c) 1993-2006 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

127.0.0.1       localhost
::1             localhost

### ab hier meine Änderungen
#127.0.0.1       xWebDevelopement.loc www.xWebDevelopement.loc
#127.0.0.1       TestDomain.loc www.TestDomain.loc

Und diese Änderungen an der hosts-conf im XAMPP-Apache Verzeichnis
Code:
#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at 
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
##NameVirtualHost *:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any <VirtualHost> block.
#
##<VirtualHost *:80>
    ##ServerAdmin postmaster@dummy-host.localhost
    ##DocumentRoot "C:/xampp/htdocs/dummy-host.localhost"
    ##ServerName dummy-host.localhost
    ##ServerAlias www.dummy-host.localhost
    ##ErrorLog "logs/dummy-host.localhost-error.log"
    ##CustomLog "logs/dummy-host.localhost-access.log" combined
##</VirtualHost>

##<VirtualHost *:80>
    ##ServerAdmin postmaster@dummy-host2.localhost
    ##DocumentRoot "C:/xampp/htdocs/dummy-host2.localhost"
    ##ServerName dummy-host2.localhost
    ##ServerAlias www.dummy-host2.localhost
    ##ErrorLog "logs/dummy-host2.localhost-error.log"
    ##CustomLog "logs/dummy-host2.localhost-access.log" combined
##</VirtualHost>

### ab hier meine Änderungen
<VirtualHost 127.0.0.1>
    ServerName www.xWebDevelopement.loc
    ServerAlias xWebDevelopement.loc
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@domain.dd
    DocumentRoot "D:/Dokumente/xWebDevelopement"
    ScriptAlias /cgi-bin/ "c:/xampp/htdocs_domain/cgi-bin/"

    <Directory "D:/Dokumente/xWebDevelopement">
    Options Indexes FollowSymLinks
    Options +Includes
#   Options +
    AllowOverride FileInfo
    AllowOverride None
    Order allow,deny
    Allow from all
    DirectoryIndex index.php index.shtml index.html index.htm
    </Directory>
</VirtualHost>

<VirtualHost 127.0.0.1>
    ServerName www.TestDomain.loc
    ServerAlias TestDomain.loc
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@domain.dd
    DocumentRoot "D:/Dokumente/xWebDevelopement/TestDomain"
    ScriptAlias /cgi-bin/ "c:/xampp/htdocs_domain/cgi-bin/"

    <Directory "D:/Dokumente/xWebDevelopement/TestDomain">
    Options Indexes FollowSymLinks
    Options +Includes
#   Options +
    AllowOverride FileInfo
    AllowOverride None
    Order allow,deny
    Allow from all
    DirectoryIndex index.php index.shtml index.html index.htm
    </Directory>
</VirtualHost>

Problem:
Egal was ich nun eingebe ich lande immer im Verzeichnis:
D:/Dokumente/xWebDevelopement

Dabei möchte ich das
1. localhost weiter unter xampp/htdocs bleibt
2. xWebDevelopement unter D:/Dokumente/xWebDevelopement
und 3. TestDomain unter D:/Dokumente/xWebDevelopement/TestDomain"

Wo ist mein Fehler das der alle im gleichen Root aufruft?

LG NetBu||
 

NetBull

Erfahrenes Mitglied
In der http-conf für XAMP war alles auskommentiert. Nun lautet der Inhalt:
Code:
<VirtualHost 127.0.0.1>
    ServerName localhost.loc
    ServerAlias localhost
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@xWebDevelopement.loc
    DocumentRoot "C:/xampp/htdocs"
    ScriptAlias /cgi-bin/ "c:/xampp/htdocs_domain/cgi-bin/"

    <Directory "C:/xampp/htdocs">
		Options Indexes FollowSymLinks
		Options +Includes
		AllowOverride FileInfo
		AllowOverride None
		Order allow,deny
		Allow from all
		DirectoryIndex index.php index.shtml index.html index.htm
	</Directory>
</VirtualHost>

<VirtualHost 127.0.0.2>
    ServerName www.xWebDevelopement.loc
    ServerAlias xWebDevelopement.loc
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@xWebDevelopement.loc
    DocumentRoot "D:/Dokumente/xWebDevelopement"
    ScriptAlias /cgi-bin/ "c:/xampp/htdocs_domain/cgi-bin/"

    <Directory "D:/Dokumente/xWebDevelopement">
		Options Indexes FollowSymLinks
		Options +Includes
		AllowOverride FileInfo
		AllowOverride None
		Order allow,deny
		Allow from all
		DirectoryIndex index.php index.shtml index.html index.htm
	</Directory>
</VirtualHost>

Trotzdem wird jetzt nur noch das XAMP Verzeichnis aufgerufen.
 

NetBull

Erfahrenes Mitglied
*grummel* natürlich hätte ich in der Windows Hosts Datei auch unterschiedliche IP Adressen verwenden müssen. lol. Erledigt. Selber gelöst...