verzeichnisstruktur nicht anzeigen !

Sebastian

Erfahrenes Mitglied
Wie kann ich es bei nem Apache Webserver machen das der die Verzeichnisstruktur nicht anzeigt wenn keine index vorhanden ist ???
 

Sebastian

Erfahrenes Mitglied
Ich will das sowas dann kommt !!!


Forbidden
You don't have permission to access /images/ on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
 

Marcus Roffmann

Erfahrenes Mitglied
Da musst Du eine .htaccess reinsetzen in der die Permissions gesetzt werden.
Da kann ich Dir aber leider nicht weiterhelfen. Such mal im Netz nach Tuts!
 

JanDelay

Mitglied
moinmoin

also ...

das kannst du entweder für jedes seperate verzeichnis über die

.htaccess datei händeln...

oder du gehst in die httpd.conf

udn suchst folgende zeile:

<Directory DEIN_ROOTVERZEICHNIS>Options Indexes usw..

wenn du jetz vor das Indexes ein - machst

also -Indexes dann ist der zugriff auf das Verzeichnis verboten
genauso legst du das in der .htaccess fest
<Directory>
Options -Indexes
</Directory>

wenn du noch fragen hast mail mir

SamRAgga@gmx.net

bye

Jan
 

Marcus Roffmann

Erfahrenes Mitglied
@JanDelay: Dafür musst Du aber Rechte über den Server haben, sprich Admin des Servers sein, denn da musst Du in die Konfig von Apache rein. Das wird Dir normal (ausser es ist Dein eigener WebServer) nicht erlaubt. Da ist die Lösung mit .htaccess schon besser.

.htaccess = http://www.ideenreich.com/projektpflege/htaccess.shtml und die Links die man am Schluss der Seite findet geben Dir Auskunft über den Gebrauch und die Benutzung davon!
 

Sebastian

Erfahrenes Mitglied
Hi irgend wie geht das nicht !

Hab Apache 1.3.20 auf WinXP ! In der http.conf findet der nur das:

<Directory "C:/Programme/Apache Group/Apache/icons">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

Wenn ich das dann so gemacht aber es funzt nicht !

<Directory "C:/Programme/Apache Group/Apache/icons">
Options -Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>
 

Marcus Roffmann

Erfahrenes Mitglied
Du darfst da ja nicht in der httpd.conf rumpfuschen. Die würde ich so lassen wie sie ist und nur diese .htaccess, das heisst unter WinXP würde ich sie -htaccess nennen erstellen.

Dafür musst Du halt noch in der httpd.conf noch die AccessFile auf -htaccess umstellen und lies vor allem die Tuts die ich Dir als Link gestellt habe, sonst wird das nichts!
 

JanDelay

Mitglied
sebastian:

das is auch nich der richtige directory tag...


das is nur der tag wo die icons drinliegen

du musst das in dem tag machen wo deine htdocs drinstehen...

also der pfad den du als document root angegeben hast...

aber das mit den -Indexes stimmt schon ma ....wenn ich zeit hab poste ich ma die komplette syntax...bin nur im mom bissi im stress

so long

Jan
 

Neue Beiträge