Verkrüppeltes Bild und Problem mit XViD beim Zugriff über VfW

matmike

Grünschnabel
Hallo Leute,

ich habe mir die Nacht um die Ohren geschlagen mit einer Funktion, die aus einem Videofile (xvid-codiert) einzelne Frames als Dateien speichert. Das soll der Einfachheit halber ein RAW-Format werden, dann brauche ich mich nicht um Infoheader zu kümmern.
Das auslesen der AVI-Datei mit VfW geht schon mal, allerdings nur, wenn es sich NICHT um eine xvid-Datei handelt (uncompressed, msmpeg4, ... klappt alles).
Der Codec scheint aber richtig installiert zu sein, da VirtualDub das ohne Probleme anzeigen kann. Weiß dafür jemand eine Lösung? Was muss ich denn machen, damit ich auch xvid in Einzelbildern ausgeben kann?
Außerdem ist mir noch ein eigenartiger Effekt aufgefallen, wenn ich die Dateien rausschreibe: Dass sie auf dem Kopf stehen ist klar. Was aber wirklich stört: Einige Pixel (10-20) vom rechten Rand werden am linken Rand dargestellt.
Im Anhang findet ihr die ganzen Dateien zu meinem Projekt. Da ist einmal ein BMP dabei, wie es aussehen soll und dann noch ein bmp, wie es aussieht.
Vielleicht kann mir jemand helfen.
Die Dateien des Prokektes liegen unter http://www.matthias-mielke.de/vfw_project.rar (<400KB)
Danke im Voraus,
MatMike
 

matmike

Grünschnabel
Ich habe das jetzt mal noch ein wenig genauer untersucht. Wenn man die rausgeschriebenen Bilder genau anschaut, kann man am oberen linken Rand (also die ersten paar geschriebenen Pixel) erkennen, dass die irgendwie eigenartig sind. Wenn ich einfach einen Offset von 14 Pixeln draufaddiere, kommt das der Sache schon näher.
Jetzt sind die falschen Pixel am unteren rechten Rand des Bildes. Woher kommt dieser Effekt?
Ich habe die Dateien wieder unter dem gleichen Link wie oben abgelegt.

MatMike
 

matmike

Grünschnabel
Ich habe inzwischen gemerkt, an was es liegt und eine aktualisierte Version hochgeldaden. Tut mir leid, dass ich vergessen habe, das hier zu posten.
Nur mit xvid-Videos klappt es eben noch nicht.

Danke,
MatMike
 

Neue Beiträge