TCP Dup-Acks / sehr langsam


Bratkartoffel

gebratene Kartoffel
Premium-User
Hallo,

ein paar Freunde und ich hatten letztes Wochenende mal wieder eine LAN. Hier hatten wir auch endlich mal Gelegenheit, einen gebraucht gekauften GBit-Switch auszuprobieren.

Die anfängliche Freude über den Geschwindigkeitsboost ließ allerdings schnell nach. Nach gut 2 TB welche den Benutzer gewechselt hatten fiel die Geschwindigkeit auf gut 2-5 MB/s runter. Kein Vergleich mehr mit den 120 MB/s welche vorher von meinem PC weggeschickt wurden.

Habe dann mal testweise den Switch ausgesteckt und wieder angesteckt, aber nach ein paar Sekunden mit Fullspeed war er wieder auf ein paar MB/s herunten. Wireshark hat mir dann ein Schwarz-Rotes Bild geliefert, also quasi nur noch TCP Fehler.

Größtenteils waren es TCP Dup-Acks, kaum noch normale Pakete dazwischen. Laut Google tauchen Dup-Acks dann auf, wenn ein Paket in der Sequenz verloren geht, soweit so klar. Nun stellt sich aber die Frage, ob und wo bei uns ein Hardwaredefekt vorliegt.

Zu Auswahl stehen:
  • Meine On-Board Netzwerkkarte
  • Das Kabel
  • Ein Rechner mit einem Ubuntu im Netz
  • Der Switch
  • Das Programm DC++, welches für den Datenaustausch verwendet wurde

Hattet ihr schon mal ähnliche Probleme? Jemand eine Ahnung, woran das liegen kann?

Gruß
BK
 

Bratkartoffel

gebratene Kartoffel
Premium-User
Hallo tutorials.de,

Ich weiß dass das pushen von Threads eigentlich nicht erlaubt ist, aber nach über 6 Wochen warten hat sich das Problem für mich immer noch nicht gelöst.

Gruß
BK