Simpleviewer album


bloodytriker

Mitglied
hi leute,

ich arbeite zur zeit an einer gallerie mit simpleviewer.

simpleviewer arbeitet mit einer xml datei die, die pfade zu den thumbs und den richtigen bildern enthält

beispiel:
Code:
  <image imageURL="http://www.tutorials.de/forum/images/123.jpg" thumbURL="thumbs/123.jpg" imageLinkURL="" imageLinkTarget="">
    <caption><![CDATA[<a href="http://www.tutorials.de/forum/images/123.jpg"><u>123</u></a>]]></caption>
  </image>

jetzt hab ich eine datei geschrieben mit der man eine übersicht der alben bekommt.
wenn man dann auf ein album klickt, wird meine "gallery.php" geladen und der bestimmt wird welches album angezeigt werden soll und die index.php
des albums läd.

funktioniert so weit auch ganz gut,
allerdings findet der simpleviewer die benötigte gallery.xml nicht :(

index.php des albums:
Code:
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js"></script>
		<script type="text/javascript">
			var flashvars = {};
			flashvars.galleryURL = "kategorie/testgallerie/gallery.xml";
			var params = {};			
			params.allowfullscreen = true;
			params.allowscriptaccess = "always";
			params.bgcolor = "222222";
			swfobject.embedSWF("simpleviewer.swf", "flashContent", "100%", "100%", "9.0.124", false, flashvars, params);
		</script>



      <p><div style='height:500px;'><object width="100%" height="100%"><param name="movie" value="./simpleviewer.swf"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><param name="bgcolor" value="222222"></param><embed src="simpleviewer.swf" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="100%" height="100%" bgcolor="222222"></embed></object>
   </div>

egal was ich als galleryURL angebe, der viewer sagt immer xml cannot found.
wenn ich die index.php direkt aufrufe geht alles, trotz des pfades oben o_O (index.php ist im selben ordner wie die gallery.xml)

jetzt such ich eine möglichkeit, die datei zu laden.

die gallery wird 2 ordner vorher aufgerufen.
die datei soll aber geladen werden als wär man in den gallery ordner gewechselt.

sprich ähnliche befehle wie "include","require" usw...

EDIT:


hat sich erledigt^^

mit einem einfachen IFRAME kann man das problem lösen :)
hab das ding ewig nicht benutzt, deswegen ist es mir erst jetzt eingefallen^^
 
Zuletzt bearbeitet:

Forum-Statistiken

Themen
272.355
Beiträge
1.558.606
Mitglieder
187.827
Neuestes Mitglied
kanagawez