Realflow Simulaton einfrieren

cinema4d11

Grünschnabel
Hallo,

ich möchte eine Animation erstellen, in der eine hochviskose Flüssigkeit nach und nach zum Stillstand kommt.
Hab schon ein bisschen mit den Deamons experimentiert, aber hat noch nichts funktioniert.

Wäre toll wenn mier jemand weiterhelfen könntet.
 

Christian_Z

Erfahrenes Mitglied
Hallo !

Eine Möglichkeit wäre der k-speed Daemon. Dabei die Option "Limit & Keep" einschalten und den Parameter "Max speed" animieren, d.h. von einem höheren Wert im Laufe der Simulation auf 0 kommen lassen mit keyframes setzen. Auf diese Art wird die Flüssigkeit zwar nicht sofort gestoppt, aber ihr die Bewegungsenergie entnommen. Uebrigens: Bei hochviskösen Flüssigkeiten solten die minimalen Simulationsschritte (Min substeps in den Simulations-Optionen) immer sehr hoch eingestellt werden, sonst fliegen einzelne Partikel chaotisch weg.
 

cinema4d11

Grünschnabel
Vielen Dank,

dass funktioniert schon ziemlich gut, man muss allerdings aufpassen den Keywert 0 in einer ganz sanften Kurve zu erreichen, da sonst die Flüssigkeit in einem Ruck zum Stehen kommt.
Und der Tip mit den Min substeps war auch sehr hilfreich, dass wäre auch meine nächste
Frage gewesen.

Vielen Dank nochmal.
 
Zuletzt bearbeitet:

Christian_Z

Erfahrenes Mitglied
Gern geschehen :)

Die andere Möglichkeit wäre mit Scripting. Zum Thema Schmelzen und Einfrieren gibt's auch schon ein paar Beispiele auf der Tutorial-Seite bei Nextlimit.
 

cinema4d11

Grünschnabel
OK,

mit Scripten wäre warscheinlich das Beste, aber ich bin noch Anfänger im Thema Realflow und
mit Phyton kenne ich mich garnicht aus, werd es aber trotzdem mal iirgendwann probieren. Nochmal vielen Dank.
Ich hätte aber noch ein anderes Problem. Und zwar habe ich eine relativ große Wassersimulation erstellt und Realflow stürtzt andauernd ab. Die Partikelanzahl ist 504051. Bis zum Frame 150 war alles super, aber beim Nächsten geht Realflow immer nur bis 76% und nicht weiter. Manchmal kommt auch nur ne Fehlermeldung in der sowas Ähnliches steht wie: "The action requested can`t be completed because of a memory problem" oder manchmal auch "Unrecoverable error thread 15" (bei der 2. Meldung stürzt das Programm immer ab)
Am Rechner kann es nicht liegen da ich 8 GB RAM habe und 8 Kerne. Wäre super, wenn Du auch dafür eine Antwort prat hättest.
...Den K Volume Deamon hab ich schon probiert, das problem ist dann, dass die Partikel immer weniger werden.
 
Zuletzt bearbeitet:

Christian_Z

Erfahrenes Mitglied
Den kVolume Daemon würde ich in diesem Fall aber so einrichten, dass er einen Kubus in einem grösseren Abstand um die eigentliche Szene bildet, der wirklich nur die verirrten Partikel abschneidet, dann sollten auch nicht so viele gelöscht werden. Die ganzen 8 GB RAM kannst du nur mit der 64bit Version von RF nutzen, das ist ja klar (ich bin da auf dem Mac etwas limitiert, weil die GUI-Version von RF immer noch 32 bit ist, es gibt aber eine Mac command line version für 64bit). Oft stürzt RF auch in einem bestimmten Moment ab, weil es zu extremen Bedingungen in der Berechnung kommt, nicht nur bei mangelndem RAM. In diesem Fall kann das erhöhen der Substeps helfen, oder auch eine höhere FPS-Zahl, z.B. 60 FPS, sodass die ganze Simulation in feineren Schritten berechnet wird.
 

cinema4d11

Grünschnabel
Kann das Erhöhen der Framerate denn nicht dazu führen, dass nachher die Simulation nicht mehr glatt lauft. ZB. bei 25 FPS schnell und dann 60 FPS aufeinmal langsamer ?
 

Christian_Z

Erfahrenes Mitglied
So ist es in der Tat. Es hängt davon ab, wie schnell ein Movie abgespielt wird bzw. kann, aber Standard sind ja z.B. 25 oder 30 frames per second beim Abspielen in einem Movieplayer oder DVD. Das heisst, dass eine mit 60 fps simulierte Animation einen deutlichen "slow motion"-effekt aufweist. Oft ist das aber gerade erwünscht bei Flüssigkeits-Simulationen wie Tropfen oder Splashes. Du kannst aber auch mit 60 fps simulieren und danach beim Zusammensetzen eines Movies aus gerenderten Einzelbilder eine schnellere Ausgabe wählen (dabei aber Bilder absichtlich verwerfen).
 

cinema4d11

Grünschnabel
OK, dass is klar. jetzt hab ich aber schon die Simulation bis zum Frame 150. Es kann doch nicht sein, dass man eine höhere Bilderrate verwenden muss, damit das klappt....dauert auch viel zu lange.
Ich hab zB. Videos bei Youtube gesehen mit 3 mal so vielen Partikeln.
Was ich jetzt natürlich nicht weiss, aber vielleicht Du, ob es normal ist, mit einer extra hohen Bilderrate zu arbeiten?
... Das Erhöhen der Substeps hatte ich auch probiert aber leider ohne Erfolg.
 

Christian_Z

Erfahrenes Mitglied
Habe schon Simulationen mit mehreren Millionen Partikel für eine Woche laufen lassen ohne Absturz, aber es dauert, das liegt in der Natur der Sache.
Bei solchen Problemen ist es schwierig einen Rat zu geben, ohne die Szene selbst zu haben. Es gibt so viele Parameter-Kombinationen in RF....