Problem mit Codierung, Datenbank und Umlautausgabe mit Mac-erstellten Skripten

Promaetheus

Mitglied
Hallo liebe Forumskollegen!

Ich bin vor einiger Zeit auf Mac umgestiegen und erstelle nun auch mit diesem meine Skripte. Das Problem ist, dass die Umlaute nicht korrekt dargestellt werden. Um dieses Problem zu "umgehen", bzw. zu lösen habe ich schon folgende Aktionen durchgeführt:

  • MySQL-Datenbank mit der Kollation "utf_8_general_ci" formatiert.
  • Im Headerbereich der Seiten
Code:
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
eingefügt.
  • Im Editor (Editra Version 0.7.08) die Dateiausgabe auf "utf-8" umgestellt.

Trotz allem werden die Umlaute (zumindest in Safari und Firefox) falsch dargestellt. Anbei einige Screenshots. Ich bin am Ende meiner Weisheit und wäre Euch bezüglich Tipps hierzu SEHR dankbar.
 

Anhänge

  • Bildschirmfoto 2012-07-29 um 11.00.31.png
    Bildschirmfoto 2012-07-29 um 11.00.31.png
    7,5 KB · Aufrufe: 12
  • Bildschirmfoto 2012-07-29 um 11.01.12.png
    Bildschirmfoto 2012-07-29 um 11.01.12.png
    7,9 KB · Aufrufe: 15
  • Bildschirmfoto 2012-07-29 um 11.01.26.png
    Bildschirmfoto 2012-07-29 um 11.01.26.png
    70,1 KB · Aufrufe: 24
  • Bildschirmfoto 2012-07-29 um 11.01.47.png
    Bildschirmfoto 2012-07-29 um 11.01.47.png
    16,1 KB · Aufrufe: 14
  • Bildschirmfoto 2012-07-29 um 11.03.02.png
    Bildschirmfoto 2012-07-29 um 11.03.02.png
    7,6 KB · Aufrufe: 10

Promaetheus

Mitglied
Danke für den Hinweis, werde mich da gleich mal einlesen und das überprüfen. Ich melde mich mit dem Resultat. Danke inzwischen!
 

Ultrasick

Grünschnabel
bekommst du anstatt 1 umlaut 2 andere zeichen angezeigt?

Wenn ja, dann würde das bedeuten, dass deine Quelle UTF-8 kodiert ist, da UTF-8 2 Byte für 1 Umlaut benötigt. Das Anzeigeprogramm geht in diesem Fall allerdings davon aus, dass das, was es anzeigen soll, nicht UTF-8 kodiert ist, sondern sonst wie (zum Beispiel ISO 8859-1).

Wenn du nur 1 anderes Zeichen angezeigt bekommst,dann bedeutet das, dass deine Quelle vermutlich nicht UTF-8 kodiert ist, aber dein Anzeigeprogramm vermutlich davon ausgeht, dass es UTF-8 kodierte Daten liest, die aber in Wirklichkeit sonst wie kodiert sind.
 
Zuletzt bearbeitet: