Ping vom DNS selbst landet im nirgendwo


Zvoni

Erfahrenes Mitglied
Hallo Leute,

in Bezug auf diesen Thread
bei welchem mir Brati grosse Hilfe geleistet hat, sehe ich mich mit folgendem Problem konfrontiert.

Ich habe auf meinem DebianLaptop (Aufbau siehe anderer Thread) jetzt auch BIND9 in die Gänge bekommen, und das sogar mit ddns (Kann mal nicht jemand eine Beispiel-Confi gmachen? Ich habe sicher 20 Seiten/Varianten konsultiert, bei welchen am Ende eine Mischung aus allem funktioniert hat).

Alle clients, welche sich von meinem Laptop per DHCP eine IP abholen (192.168.3.0/24-er Netz), können weiterhin sauber ins Internet (NAT-Regeln).
alle clients können sich gegenseitig anpingen per hostname (Bsp. auf host1: ping host2 erfolgreich). alle clients können gegenseitig per ssh user@hostname dort einloggen.

Alle, bis auf den DNS selbst.
Auf meinem DebianLaptop (welcher gleichzeitig DHCP- als auch DNS-Server ist), funktioniert kein ping host, kein ssh user@host, kein nslookup host.meine.domain, nada.
Auffallend: mache ich einen nslookup host, kann ich aus dem Protokoll erkennen, dass der Aufruf an den DNS der WLAN-Karte geleitet wird (Mein Inet-Router)
auch ping, ssh oder nslookup per FQDN schlägt fehl.
Was meine Recherche bisher ergab: In der Ausgabe des nslookup erscheint bei mir ein NXDOMAIN, was ein ziemlich sicherer Hinweis auf eine Fehlkonfiguration ist.
Die config selbst erzeugt aber keine Fehler, also in dem Sinne, ist die config nicht fehlerhaft, aber murks ;).
Die clients finde ich ja sogar in den Forward/Reverse-Dateien sauber aufgelistet.

Hilfe?
Das Problem ist jetzt nicht unbedingt lebenswichtig für mich, eher in der Art "Huh? Das find ich jetzt seltsam. Warum ist das so?"
Config-Dateien etc. kann ich zur Verfügung stellen.

EDIT: Meine Vermutung geht in Richtung /etc/resolv.conf
 
Zuletzt bearbeitet: