phpNuke5.1

A

anarki

ahoi!

ich hab mir auf meinem rechner einen apache installiert, und
phpNuke5.1 raufgespielt. (Ich hab WinXP - sollte es daran liegen!)

Läuft gut, aber nicht ganz so toll sonst würd ich ja net Hilfe brauchen ;) .

Also das Problem ist, wenn man sich registrieren möchte (nachdem abschicken des formulares) kommt
folgende Fehlermeldung:


Warning: crypt() is not supported in this PHP build in C:\apache\htdocs\html\user.php on line 136

Warning: Failed to Connect in C:\apache\htdocs\html\user.php on line 151

Du bist jetzt angemeldet. Das Passwort wird an die angegebene email-Adresse gesandt.


Es wird keine E-Mail verschickt, und der User wird nur in der Memberliste angegeben.

Beim Einloggen (auch mit dem god oder mit dem admin account) kommt folgende Fehlermeldung:


Warning: crypt() is not supported in this PHP build in C:\apache\htdocs\html\user.php on line 402

Warning: Cannot add header information - headers already sent by (output started at C:\apache\htdocs\html\user.php:402) in C:\apache\htdocs\html\user.php on line 392

Warning: Cannot add header information - headers already sent by (output started at C:\apache\htdocs\html\user.php:402) in C:\apache\htdocs\html\user.php on line 409


und eingeloggt ist man dann natürlich auch nicht :( .

Aber als Admin (also über die admin.php) - natürlich nur wenn man die nötigen Rechte hat, kann man sich trotzdem einloggen.


Ich brauche das PHP Portal für ein Projekt, bitte um baldige Antwort,

mit freundlichen Grüssen! :)
 

evoc

Mitglied
das sind zwei probleme, zum einen, hast du eine php version installiert in der der crypt befehl nicht implementiert ist. hol dir eine neuere version und installier die.

das zweite problem ist, das du unter windows auch nie eine mail erhalten wirst ;). die installation von apache, mysql und php beinhaltet keinen mailclient. als mail client auf einem server wird z.b. sendmail verwendet. ich weiss leider nicht, ob das unter windows überhaupt möglich ist.

mfg
evoc
 
A

anarki

*heul*

ok, thx...*HEUL*...ich glaub aber vom apache is des die neichste version...arrr...des is bled...danke auf jeden fall :)
 

evoc

Mitglied
das hat ja mit dem apachen nicht viel zu tun. das ist halt die php version die nicht so ganz passt.

wenn du das für die firma machst, werdet ihr doch auch irgendwo nen schönen linux rechner rumstehen haben oder? da kannst dann alles schön draufziehen und hast nen schönen kleinen feinen webserver ;)
 
A

anarki

tztz

nein keine firma lol, ich geh noch in die handelsschule :)

aeh...gut...weisst du wo ich für den apache eine neuere php version krieg (vielleicht gleich die neueste :rolleyes: )

thx & mfg %)
 

evoc

Mitglied
na wo wohl:

http://www.php.net - gerade eine ganz neue version erschienen. ich würd mich im download bereich ein wenig umschauen und die letzte php version für windows nehmen. ich hab z.b. version 4.0.6 da ist crypt auf alle fälle drin. ich würde für windows nicht die aktuelle nehmen, da die meisten noch nicht so stabiel sind wie die etwas älteren versionen. die 4.0.6 läuft bei mir sehr gut.

mfg
evoc
 
A

anarki

hmm

oki thx, werds probieren


thx, ich meld mich natürlich wieder wenn ich fragen haben sollte :)

mfg :)
 

Neue Beiträge