Objekte verdecken

D

Digger

Hallo zusammen,

erstmal kurz zur Erläuterung:

Ich habe 2 Objekte. Das eine(ein Vogel) wirft
1. Schatten auf sich selbst(durch bsw. die Flügel) und
2. Schatten auf eine Ebene

Die Ebene soll selber nur den Schatten erhalten, allerdings selbst nicht sichtbar sein(da der Schatten später auf einer realen Fläche, genauer einem Flipchart zu sehen sein soll).

Aufgrund des Kamerawinkels verdeckt die Ebene teilweise den Vogel.

Nun möchte ich den Vogel + Eigenschatten und den Schatten den er auf die Ebene wirft seperat rendern.

Hab also der Ebene das Material Mattheit/Schatten zugewiesen, "Schatten erhalten"-Häkchen gesetzt und unter "Elemente rendern" den Schatten hinzugefügt.

Wenn ich das Ganze starte, habe ich also 2 Renderings: 1. nur Schatten 2. Vogel mit Eigenschatten und Schatten auf Ebene.

Genau das ist das Problem: Ich möchte beim 2.Rendering den Schatten auf der Ebene nicht dabei haben, da ich das Ganze ja später seperat im After Effects bearbeiten will(hin und herschieben, weichzeichnen etc.)

Hat jemand ne Ahnung, wie ich nun die Ebene zwar den Vogel verdecken lasse, sie selbst aber nicht mit rendern lasse(auch nicht den Schatten, der auf sie geworfen wird), quasi wie eine Maske?

Vielen Dank im Voraus.
 

Jan-Frederik Stieler

Monsterator
Moderator
Hi,
wenn du ein Objekt nur mit dem Schatten rendern lassen möchtest dann sollte das mit dem Matte/Shadow-Material funktionieren.
Wenn du Objekte nicht rendern lassen möchtes kannst du dir mal die Eigenschaften dieses ansehen. ich bin mir jetzt grad nicht ganz sicher aber dort sollte es eine Checkbox dafür geben.

Viele Grüße
 
D

Digger

Achso:

Ich dachte, das geht ganz einfach, wenn man bei dem Mattheit/Schatten-Material der Ebene einfach das Häkchen "Schatten erhalten" wegnimmt. Allerdings ist dann die Ebene komplett zu sehen... :-(
Und nun passiert bei Allem was ich versuche entweder
- Ebene verdeckt Vogel nicht mehr oder
- Ebene ist komplett opak
 
D

Digger

@DirtyWorld:

Ja diese Checkboxen gibt es, allerdings verdeckt die Ebene dann wie gesagt den Vogel nicht mehr, wird also überhaupt nicht gerendert
 

Jan-Frederik Stieler

Monsterator
Moderator
Hi,
also manche Sachen kann man schneller in der Post erledigen.
Ich weiß jetzt nicht ob du nur ein Still render willst oder eine Animation.
Wenns nur ein Bild ist dann rendere alle Elemente einzeln und baue sie entsprechend in Photoshop wieder zusammen. Das erspart dir einiges an Ärger.

Gruß
 

Zinken

Erfahrenes Mitglied
Zunächst einmal sollte man wissen, welchen Renderer Du benutzt. Es gibt sowohl für den Scanline-Renderer, als auch für Mental-Ray unterschiedliche Matte/Shadow-Materialien, die sich auch etwas unterschiedlich verhalten.
Alle Haken in den jeweiligen Materialien, die etwas mit "Alpha" oder "Background" zu tun haben, sollten Dir weiterhelfen.