Neu im Forum und schon ein Problem

AlexanderLind

Grünschnabel
Erstmal "Heidiho" an alle im Forum!
(Man muss sich ja ordentlich vorstellen :) !)

Ähmmm,ja....! Also Ich bin gerade dabei mein Abschlussprojekt als Fachinformatiker zu machen und stehe jetzt vor nem komischen Problem.

Also das Progie das ich schreibe ist eine Art "MotherBoardMonitor" nur das man die ausgelesenen Daten übers Web abrufen kann.

Also ich habe zum auslesen der Werte die guten "performanceCounter" genommen und dehnen dynamisch den jeweiligen Rechnername mit:

string maschinename=System.Enviroment.MaschineName;
PerformanceCounter1.MaschineName=maschinename;

zugewiesen.

Also eigentlich müsste das funzen!
Aber wenn ich das Programm auf nen anderen Rechner ausführen lassen will schmiert mir das Teil immer mit der fehlermeldung ab:
"Zugriff performanceCounter.. ... verweigert".

Irgendjemand ne Ahnung woran das liegen könnte?

im vorraus.

Ach ja, der Soucecode hängt am Thread an
 

Anhänge

  • remoteinfoclientsource.rar
    10,6 KB · Aufrufe: 16

Argbeil

Grünschnabel
Moin,

ich arbeite auch gerade an meinen Projekten. Hab mir den Source nicht angesehen, aber erst mal könnte es daran liegen das man Machine ohne s schreibt. Das nächste ist, das der Wert da nur drin steht ( einfach mal in der Hilfe gucken ) wenn der Computer Teil eines Clusters ist. Als nächstes ( wieder mal in die Hilfe gesehen ) darfst du den Wert nur lesen wenn du die Permissions dazu hast, wie du die bekommst steht, rate mal, in der Hilfe.

Der Manu
 

AlexanderLind

Grünschnabel
Hat sich erldigt

Hab das Problem schon gelöst. :)

Ich hab zwar den Rechnernamen dynamisch zugewiesen aber bei den "Intialize Components" hatte VS die Counter auf meinen Rechner festgenagelt.

trotzdem. :)