Netbeans und xdebug

bofh1337

Erfahrenes Mitglied
PHPMyAdmin und xdebug

Guten Morgen :)
Es gibt ein kleines Problemchen, wo ich zur Zeit nicht weiter weiß, aber schon einiges Versucht habe, um das Problem zu lösen,- jedoch ohne Erfolg:

Wenn ich (unter Linux) das xdebug in der /etc/php5/conf.d/xdebug.ini einschalte, läuft alles, wie es sollte, aber beim Aufrufen von PHPMyAdmin ist xdebug auch aktiv und ich warte ewig auf die HTML-Ausgabe.

Ich habe bei mir 2 virtuelle Domains am laufen:
dev.local und
silex.local

Selbst wenn ich den PHPMyAdmin auf silex.local packe, ist beim Aufrufen xdebug aktiv, obwohl er nur auf "dev.local" zugreifen sollte (dev.local und silex.local haben unterschiedliche IPs)

Gibt es da nicht eine Möglichkeit, das Xdebug auf ein bestimmtes Project oder Verzeichnis begrenzt wird?

Das ist die Konfig, wie ich sie vor 3 Tagen noch hatte:

Code:
zend_extension=/usr/lib/php5/20090626/xdebug.so

; Remote settings
xdebug.remote_autostart=on
xdebug.remote_enable=1
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_host=localhost
xdebug.remote_port=9000

; Profiling
xdebug.profiler_enable_tigger=1
xdebug.profiler_append=1
;xdebug.profiler_enable=1
xdebug.profiler_enable_trigger=1
xdebug.profiler_output_dir=/tmp
xdebug.profiler_output_name=crc32

; General
xdebug.dump.SERVER=REMOTE_ADDR,REQUEST_METHOD
xdebug.force_display_errors=1
xdebug.dump.COOKIE=1
xdebug.dump.ENV=1
xdebug.dump.FILES=1
xdebug.dump.GET=1
xdebug.dump.POST=1
xdebug.dump.REQUEST=1
xdebug.dump.SESSION=1
xdebug.dump_globals=1
xdebug.dump_undefined=1

xdebug.auto_trace=1
xdebug.collect_includes=1
xdebug.collect_vars=1
xdebug.collect_params=4
xdebug.collect_return=1
xdebug.default_enable=1
xdebug.extended_info=1
xdebug.manual_url=http://www.php.net
xdebug.show_local_vars=1
xdebug.show_mem_delta=0
xdebug.max_nesting_level=100
;;;;;xdebug.idekey=

; Trace options
xdebug.trace_format=0
xdebug.trace_output_dir=/tmp
xdebug.trace_options=0
xdebug.trace_output_name=crc32
xdebug.file_link_format=xdebug://%f@%l
 
Zuletzt bearbeitet:

saftmeister

Nutze den Saft!
Wenn htaccess erlaubt ist:

Code:
php_value xdebug.profiler_enable Off

Diese in dein phpMyAdmin-Verzeichnis packen und schon ist für PMA der Profiler deaktiviert.

EDIT: Natürlich sollte das auch anders rum gehen. Du deaktivierst den Profiler pauschal und schaltest ihn per htaccess für ein bestimmtes Verzeichnis ein.

Aber was das konkret mit Netbeans zu tun hat...
 

bofh1337

Erfahrenes Mitglied
wow, das Funktioniert sogar :D

Serverweit (in der xdebug.ini) ist xdebug est mal abgeschaltet, im Projekt.-Verzeichnis eine .htaccess anlegen und diese Werte eintragen:

Code:
php_value xdebug.remote_enable on
php_value xdebug.profiler_enable_tigger on
php_value xdebug.profiler_enable on
php_value xdebug.force_display_errors on
php_value xdebug.auto_trace on
php_value xdebug.default_enable on

Funktioniert echt gut, Danke :)