mongoDB unter Debian automatisch starten


jimb0p

Erfahrenes Mitglied
#1
Hallo Zusammen,

ich muss meine mongoDB auf meinem Debian Server immer manuell starten mit dem Befehl:

Code:
sudo mongod -f /etc/mongod.conf
Wie kann ich die Datenbank automatisch starten lassen? Ich habe schon

Code:
sudo update-rc.d mongod defaults
probiert, leider ohne Erfolg.

Gruß!
 

jimb0p

Erfahrenes Mitglied
#3
Hi,

bekomme folgendes zurück:

Code:
libsystemd0:amd64                               install
systemd                                         install
systemd-sysv                                    install
systemd-sysv                                    install
sysv-rc                                         install
sysvinit-utils                                  install
 
#4
/lib/systemd/system/jimb0pmdb.service erstellen
Code:
[Unit]
		Description="Mein Script"

		[Service]
		Type=oneshot
		ExecStart=mongod -f /etc/mongod.conf
		TimeoutSec=0
		StandardInput=tty
		RemainAfterExit=yes

		[Install]
		WantedBy=multi-user.target
Dann ausführen:
Code:
sudo systemctl enable jimb0pmdb
 

jimb0p

Erfahrenes Mitglied
#7
Habe es autoMongoDb.service genannt. Der Befehl gibt folgendes zurück:

Code:
● autoMongoDb.service - "MongoDB Autostart Skript"
   Loaded: error (Reason: Invalid argument)
   Active: inactive (dead)
 

jimb0p

Erfahrenes Mitglied
#10
Doch nicht das gleiche Ergebnis, jetzt ist es active, aber die Datenbank läuft nicht.

Code:
 autoMongoDb.service - "MongoDB Autostart Skript"
   Loaded: loaded (/lib/systemd/system/autoMongoDb.service; enabled)
   Active: active (exited) since Sun 2016-09-25 11:53:48 EDT; 1min 48s ago
  Process: 486 ExecStart=/usr/bin/mongod -f /etc/mongod.conf (code=exited, status=0/SUCCESS)
Main PID: 486 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/autoMongoDb.service

Sep 25 11:53:43 sneakengine systemd[1]: Starting "MongoDB Autostart Skript"...
Sep 25 11:53:48 sneakengine systemd[1]: Started "MongoDB Autostart Skript".
Die mongoDb lässt sich auf dem Server auch nur mit diesem Befehl bei mir starten:

Code:
mongod --dbpath /var/lib/mongodb/
Habe es entsprechend auch mit absolutem Pfad in der .service Datei versucht. Leider auch ohne Erfolg.
 
Zuletzt bearbeitet:

jimb0p

Erfahrenes Mitglied
#11
Habe die Datenbank nochmal neu aufgesetzt da es auch andere Probleme gab. Anschließend hat das mit dem Script funktioniert. Das Problem lag wohl darin dass die Datenbank einmal als root ausgeführt wurde. Danke für die Hilfe!
 

Neue Beiträge