Module Problem

Pitchblack

Mitglied
Hi,

immer wenn ich meinen Rechner neu starte haut Apache eine Fehlermeldung raus die aussagt, dass er das Module php_mysql.dll nicht laden kann.
Ich hab es aber in dem Modules Ordner drinn.

Kann mir jemand weiterhelfen?
 

Sinac

Erfahrenes Mitglied
Schau dir mal die httpd.conf an was da fürn Pfad für das Modul angegeben ist und überprüf das.

Greetz..
Sinac
 

Pitchblack

Mitglied
Also da ist kein Pfad für dieses Module angegeben.
Wie muss ich es einfügen? Muss ich es überhaupt einfügen? Apache startet nämlich ganz normal und ich habe sonst auch keine Verweise über dieses Modul. Also, brauch ich es überhaupt?
 

Pitchblack

Mitglied
Ok, ich denke ich hab das Problem ziemlich schwammig beschrieben. Ich probiers mal etwas detailierter :)


ich habe den Apache 2.0.50 Webserver und PHP5 RC3 installiert. Leider kommt immer beim Start des Webservers folgende Fehlermeldung:

-----------------------------------
Warning
PHP Startup: Unable to load dynamic library "X:\Apache Group\Apache2\modules\php_mysql.dll" - Das angegebene Modul wurde nicht gefunden.
-----------------------------------

Apache läuft bis jetzt normal allerdings steht in meiner Ereignisanzeige, dass der Webserver nicht ordnungsgemäß gestartet worden ist.
Wie behebe ich dieses Problem?

Vielen Dank schon mal.
 

won_gak

Erfahrenes Mitglied
Beispiel 3-7. PHP and Apache 2.0 as Module

; For PHP 4 do something like this:
LoadModule php4_module "c:/php/sapi/php4apache2.dll"
AddType application/x-httpd-php .php

; For PHP 5 do something like this:
LoadModule php5_module "c:/php/sapi/php5apache2.dll"
AddType application/x-httpd-php .php

Da du X:\Apache Group\Apache2\modules\php_mysql.dll angegeben hast, weiß ich jetzt nicht genau, ob du die DLL auch in dieses Verzeichnis kopiert hast...
 

won_gak

Erfahrenes Mitglied
*g* da muss man immer nachfragen, sorry.

If you would like to use PHP as a module in Apache 2.0, be sure to move php4ts.dll for PHP 4, or php5ts.dll for PHP 5, to winnt/system32 (for Windows NT/2000) or windows/system32 (for Windows XP), overwriting any older file. You need to insert these two lines to your Apache httpd.conf configuration file to set up the PHP-Module for Apache 2.0:

könnte auch noch interessant sein...
 

won_gak

Erfahrenes Mitglied
und:
Copy libmysql.dll (whereever you can find it) to \WINDOWS\system32 (I could not find another place to put libmysql.dll and have php/apache2 work properly). If you don't move libmysql.dll to \WINDOWS\system32 you are likely to get "can't load c:\php-5b4\ext\php_mysql.dll".