Midi aufnahme für Anfänger

Mairhofer

Erfahrenes Mitglied
Schönen Guten Tag,

ich habe es getan und ich könnte mich dafür steinigen, weil nichts funktioniert.

Ich habe mir von Aldi (!) das tolle Keyboard gekauft und wollte nun, nur mal so zum testen, mit ein paar Tönen eine Melodie komponieren.
DENKSTE!
Das scheiss Ding will nicht wirklich funktionieren.

Nun aber das ganze mal von Anfang an.

Ich hab einen AMD Athlon XP mit ner Via Onboard Soundkarte auf einem Epox Board.
Das Keyboard ist wie gesagt, das von Aldi und ich habe PC und Keyboard per Midi Kabel verbunden (Gameport, nicht USB).

Dann habe ich im Bios die Midi funktion aktiviert und es wird unter Windows auch ein "MPU-401" kompatibles Gerät erkannt.
Da Midi keine direkten Töne transportiert sondern nur Informationen zu Tönen brauche ich eine Software, die mir diese Informationen zu Tönen "umwandelt".
Ich habe mir daher die Demo von Magix Samplitude und eine unbekannte Shareware gezogen.
Da diese Programme sehr komplex sind, habe ich zwar ein paar Stunden gebraucht den "Midi Record" Knopf zu finden, aber laut Anleitung kann ich nun Midi aufnehmen. Nur es funktioniert nicht.
In den Einstellungen der Programme habe ich natürlich das Gerät eingestellt.

Ich bin nicht ganz dumm, also habe ich den Fehler natürlich erstmal bei meinem PC gesucht. Treiber neu installiert, Volumes nach oben gedreht (dabei viel mir auf, es gibt kein Volume für MPU) und das ganze dann mal per DirectX getestet.
Beim Musiktest des MPU Gerätes kam auch Musik aus den Boxen des Keyboards (PC->Keyboard). Es scheint also, als wäre das Gerät MPU auf dem PC korrekt installiert und erkannt worden.
Nur die andere Richtung, Keyboard zu PC funktioniert nicht. Ich habe daher mir von einem Kollegen, der viel mit Musik macht und auch selbst aufnimmt, diese Software "Propellerhead Reason 2.5" ausgeliehen um zu testen, ob es an der Software liegt.
Per Telefonkonferenz mit meinem Bekannten habe ich dann die Einstellungen in dieser Software vorgenommen. Erschlagen von den Funktionen musste ich feststellen, das uach hier die aufnahme nicht geht.
in den Optionen von Reason gibt es "MIDI" und "Advanced Midi". Dort habe ich jeweils das MPU 401 eingestellt und alle 16 Kanäle durchprobiert, doch eine Aufnahme hat nicht funktioniert.
Nun dachte ich, ich muss was am Keyboard umstellen. Doch entweder bin ich blind oder es steht nichts im Handbuch, einen Knopf für "Mach die Leitung auf für Daten zum PC" gibt es nicht.

Wenn mir einer einen Tipp geben könnte, warum das ganze nicht klappt wäre ich sehr dankbar. Wenn jemand weitere Informationen brauch, ich suche gerne alle Treiberversionen raus, krame Daten raus usw. alles nur für einen Tipp ;)

Ich würde mich freuen, wenn jemand antwortet.
Mfg
Mairhofer
 

BeaTBoxX

Erfahrenes Mitglied
Zunächst wär es hilfreich zu wissen, was das genau fuer ein Keyboard ist.
Mit " Das vom Aldi" kann ich leider nix anfangen (ich kauf bei Lidl :) :) :) )

Ich glaube es gibt mehrere Fehlerquellen:

1. bei den meisten Geräten, die mir bisher untergekommen sind, konnte man wählen , ob die Midiinformation, die man mit der Tastatur erzeugt an die interne Klangerzeugung geschickt werden soll (sofern vorhanden) ODER an eine externe (das willst du haben) ODER an beides.
Es ist denkbar, dass dieses wieder für ALLE Midikanäle oder fuer jeden einzelnen einstellbar
ist (am Gerät).

Da solltest du mal das handbuch zu rate ziehen und rausfinden ob und wenn ja wie dein keyboard da Fähigkeiten besitzt.

2.
Da du z.B. Reason mal zum Test hast:
Es ist zum Test nicht gleich nötig Mididaten _aufzunehmen_
Eigentlich sollten sich die virtuellen klangerzeuger (mit mehr oder weniger grosser Latenz) live spielen lassen. Ich hab das mit Reason auch schon geamcht.. aber ich kann mich nicht entsinnen, dass es da irgendwelche Probs gab.
Midi-input-device ausgewählt. Und ein Empfangskanal denk ich. und dauf diesem dann auch am Keyboard gesendet und schon dudelte der Malström nach meiner Pfeife.
Beim testen Ruhig mal langer die finger aquf den Tasten lassen. Da du ne Onboard Soundkarte hast, die wohl nicht ASIO faehig ist, wird die Latenz recht hoch sein.Will sagen es dauert evtl ne halbe Sekunde vom Taste-druecken bis Sound-hören.

3.
Hast du evtl irgend eine Software am laufen die MidiRouting macht.. und evtl Filterfunktionen dabei hat? wird da evtl irgendwo irgendwas geblockt ?
Ich hab z.b. u.A. ein EES Midiinterface, bei der mitgelieferten Software sind solche Midifilter realisierbar! Evtl ist bei dir irgendwas Default geblockt (auch wenns unsinnig wäre)

4.
Hast du evtl(oder Bekannter) ein anderes Midigerät (Klangerzeuger) mit dem du testen kannst ob aus dem Keyboard was raus kommt ? Evtl hat das Kabel nen Treffer?

das faellt mir nun so auf die Schnelle ein.

Gruß
Frank
 

Mairhofer

Erfahrenes Mitglied
Hallo!
Danke für deine Antwort, doch leider krieg ich immer noch nichts vom Keyboard richtung PC!

Ich hab alles, was du alles mögliche Fehlerquellen bezeichnest versucht herauszufinden oder zu lösen, doch leider alles ohne Erfolg :(

zu 1.: mehrmals habe ich das Handbuch durchgelesen, doch da finde ich nichts
zu 2.: auch hier kein Erfolg, kann sein das ich irgendwie diese ganzen Geräte falsch angeschlossen habe, aber irgendwann hätte ich ja mal durch Zufall das hinbekommen sollen
zu 3.: ich hab keine Programme gefunden, die mit Sound zu tun haben. Habe dafür alle möglichen Dateien, die Windows beim starten abklappert abgesucht, aber keine lädt irgendwas an Programme. Nur natürlich die Treiber
zu 4.: Leider nein

Ich bin nun echt am verzweifeln.
Ich schnapp mir nachher einfach mal nen anderen Rechner. Der hat derzeit auch nur Onboard Sound, aber vielleicht ist da irgendwas anders eingestellt.
Ansonsten versuch ich es noch mit dem Creative Soundblaster 128 PCI (oder so) die hab ich hier irgendwo noch rumfliegen. Falls ich irgendwas herausfinde melde ich mich natürlich nochmal.

Falls du, BeaTboxX, oder jemand anders noch einen Tipp für mich hat, wäre ich sehr dankbar!

Mfg und frohe Weihnachtstage
 

Mairhofer

Erfahrenes Mitglied
So ich nochmal!

Mit nem anderen Rechner gings nun!
Ich weiss leider nicht obs am System selber liegt oder einfach nur dadran, das da ne Creative Onboard Soundkarte diesmal drin ist.

Werde meine Creative PCI mal in den Rechner bauen, wo der Via Chip drin ist und den Via deaktivieren. Ma guggn

Schöne Weihnachtstage

Mfg