Mehrfarbige EPS

konem

Mitglied
Hallo,

ich möchte eine Mehrfarbige EPS Datei erstellen. Und zwar so: Ich habe in Photoshop CS5 den Buchstaben A als Pfad in schwarz und das Loch im A habe ich als zweiten Pfad in weiß. Ich schaffe es nicht, beides als eine EPS zu exportieren. Es fehlt immer das dreickige Loch. Ich habe schon mehrfarbige EPS gesehen. Ich habe es zumindest schon geschafft, ein transparentes EPS zu erstellen, also eins mit frei schwebendem A. Das war schon ein kleiner Akt.

Der Umweg über Illustrator funktioniert irgendwie auch nicht. Ich öffne die PSD in Illustrator und speichere sie dann als EPS, kommt sie in PS wieder ohne das weiße A-Loch (Spaß muss sein) an.

Kann ich in Photoshop verschiedenfarbige Pfade zu einem mehrfarbigen Pfad kombinieren?

Zur Info, die EPS soll nachher zum Layouten benutzt werden und von daher möchte ich keine PNG benutzen um zoomtechnisch flexibel zu bleiben. Eines riesiges PNG bliebe als Notlösung, aber ich möchte das mit dem mehrfarbigen EPS so gern wissen.

Beste Grüße
 

konem

Mitglied
Hi,

danke für die Antwort und für die Dateil. Ok, verschiedene Formebenen zu erstellen ist kein Problem. Aber ich habe ein Problem, ein mehrfarbiges EPS zu exportieren. Ich kann im "Pfade"-Panel auf beide der Pfade klicken, dann im Aufklappmenu sagen "Pfad Speichern" wodurch mir die Funktion "Beschneidungspfad" zugänglich wird. Wenn ich auf einen Pfad klicke (immer noch im "Pfade"-Panel) und dann "Beschneidungspfad" anwende, wirde der Name des Pfades fetter angezeigt. Das geht leider nur bei einem Pfad. Will ich das mit dem anderen Pfad auch machen, wird dessen Name fett und der andere wird wieder normal. Wie dem auch sei, je nach dem welcher Pfadname fett ist, dieser Pfad wird nach dem Speichern im EPS angezeigt, der andere nicht. Die ganze Aktion mit dem Beschneidungspfad ist nötig, damit der Pfad auf transparentem Hintergrund liegt. Ansonsten liegt er auf Weiß, egal bei welcher eingestellten Hintergrundfarbe. Zumindest bei mir.

Hier ist ein EU-Logo EPS-Datei.

http://www.nbank.de/_downloads/Publikationen_und_Dokumente/Logos/EU_farbig.eps

Ich habe es mit 6400 Pixel Breite geöffnet und es ist immer noch scharf. Ich wollte sehen, ob es insgeheim eine Pixeldatei ist, weil sowas ja mehrfarbig kein Problem ist. Aber nein, es scheint komplett aus Vektordaten zu bestehen. Scheint... Ich hatte die Vermutung, dass die blaue Flagge Vektordaten sind, mit ausgeschnittenen Sternen, und dahinter einfach eine gelbes Rechteck liegt, als Pixeldaten. Aber auch hier nein. Ich habe so etwas mit dem A probiert und es kommt nur das A ohne Loch an. Ich bin ratlos :)

Allerbeste Grüße
 

Jan-Frederik Stieler

Monsterator
Moderator
Hi,
als erstes solltest du wissen das in PS die Vektorfunktionen sehr limitiert sind.
Wenn du ein EPS öffnest, je nach dem in welchem Programm kann es sein das dir ein Vorschau Bitmap angezeigt wird, InDesign ist so ein Fall.
Das mal so am Rande.

Was willst du den mit einem Beschneidungspfad?
Wenn ich die PSD von mir als EPS speichere habe ich die Pfade auf transparenter Ebene liegen und diese sind auch entsprechend anwählbar, zumindest in einem Grafikprogram.
Wenn du natürlich die EPS wieder in PS öffnest gehen die Vektordaten verloren.

Grüße
 

Anhänge

  • buchstabe.zip
    36,8 KB · Aufrufe: 15

Martin Schaefer

Administrator
Wenn du natürlich die EPS wieder in PS öffnest gehen die Vektordaten verloren.

Das ist nicht ganz richtig bzw. nicht der richtige Weg. :)
Wenn du die EPS in Photoshop öffnest, dann wird sie in der entsprechenden Dokumentgröße gerastert und verliert damit ihre Vektorinformationen, richtig.

Aber wenn du in Photoshop ein neues, leeres Dokument erstellst und dann die EPS Datei platzierst, dann erzeugst du damit ein Smartobjekt, das die Vektorinformationen weiterhin enthält und damit auch nachträglich skalierbar bleibt. Dies natürlich nur dann, wenn du diese Option in den allgemeinen Voreinstellungen von Photoshop aktiviert hast.

ps-platzieren.jpg

Gruß
Martin
 

konem

Mitglied
Hi,

wenn ich die EPS öffne, dann ist sie auf weißem Hintergrund. Mit dem Beschneidungspfad schaffe ich es, zumindest eine der beiden Formen auf transparentem Hintergrund zu speichern. Aber leider nur eine. Ich habe eben getestet, ob es an Photoshop liegt, aber in InDesign kommen die EPS-Dateien auch intransparent an.

Dass die Daten dann zu Pixeln werden ist dann ok. Ich suche mir beim öffnen eine Auflösung aus und bin dann froh damit. Das mit dem Platzieren geht ganz gut - dort kann ich bis zum jüngsten Tag skalieren und es bleibt scharf.

Also mehrfarbig und auf weißen Hintergund speichern geht, oder einfarbig mit transparentem Hintergrund geht auch. Beides lässt sich pixelig öffnen oder smart platzieren. Aber mehrfarbig mit transparentem Hintergrund geht nicht... Seltsam :)

Danke Jan-Frederik und Martin!
 

Anhänge

  • A 05.zip
    40 KB · Aufrufe: 14

Jan-Frederik Stieler

Monsterator
Moderator
Hi,
@martin: ja im PS CS6 stimmt das. im CS4 gab es die Einstellung noch nicht.
Und ich hab mit die PS CS6 bisher nicht installiert.

Nicht destotrotz verstehe ich nicht warum du einen weißen Hintergrund bekommst.
Egal wie ich die EPS in PS öffne ich habe einen transparenten Hintergrund.

Aber ich habe so ein doofes Gefühl das ich immer noch nicht so ganz verstehe was du eigentlich erreichen willst.

Grüße
 

Another

Erfahrenes Mitglied
Mal abgesehen das ich mich hier anschließe..
[...] ich habe so ein doofes Gefühl das ich immer noch nicht so ganz verstehe was du eigentlich erreichen willst.

Nur nebenbei..
Hi,
@martin: ja im PS CS6 stimmt das. im CS4 gab es die Einstellung noch nicht.
Und ich hab mit die PS CS6 bisher nicht installiert.
Als Voreinstellung zwar nicht, aber via einfachem 'Datei'>'Plazieren' bleibts dennoch direkt ein Smart-Object, wie Martin beschrieb. Und das bei CS3.

Aber back to topic.
 

konem

Mitglied
Ok...

Jan-Frederik, ich habe keine Ahnung, warum ich einen weißen Hintergrund bekomme :( Beim EU-Logo ist er transparent. Ich weiß nicht, wo ich welche Einstellung vornehmen muss. Wie speicherst du dein EPS? Ok, es liegt vielleicht auch an meinem CS5... Aber ernsthaft, so alt ist das auch nicht.

Ich mache mir beide Formen ö und ö Kopie (ist das Loch). Ich speichere es als EPS ( Vprschau TIFF (8 Bit/Pixel), Kodierung Ascii85, check bei "Mit Vektordaten" )und beim Öffnen wähle ich eine Größe und ist knackig scharf aber es ist ein weißer Hintergrund da. Beim Platzieren ist es super zoombaer aber hat auch einen weißen Hintergrund.

Öffne mal bitte bitte meine EPS-Datei. Vielleicht erzeuge ich etwas, dass ich nicht vernünftig öffnen kann. Wobei ich dazu sagen muss, dass der einfarbige Buchstabe (der ohne andersfarbiges Loch) bei mir transparent ist nach dem Öffnen...

Sonnigste Grüße
 
Zuletzt bearbeitet: