Lightbox 2.05 lässt sich absolut nicht einbinden... warum auch immer...

tobm_knows_best

Erfahrenes Mitglied
Hey liebe Community...

folgendes Problem habe ich momentan.... und zwar:

Ich habe versucht ein unter Lightbox 2.05 laufen zu lassen - allerdings will mir das nicht gelingen... ich bin mir sicher, ich habe alles richtig gemacht... na wobei - anscheinend doch nicht... :/

Bin jede verda******** Seite mit sämtlichen Beschreibungen durchgegangen, und es mag und mag nicht funktionieren. Bei mir wird lediglich ein normaler Link auf das gewünschte Bild generiert... und das Bild erscheint nicht wie gewünscht in der Lightbox an sich... :(

Kann mir jemand dazu helfen?

Hier mal die angehende HP um welche es sich handelt.... Klick mich! Die *Gallerie* weisst bisher nur ein Bild auf..... damit wär mir schon mal geholfen wenn der Thumbnail hier in der Lightbox aufgehen würde... :S...

Bin über jede Hilfe dankbar!

MFG
 

CPoly

Mitglied Weizenbier
Du hast jQuery und Prototype auf der gleichen Seite. Deshalb funktioniert dein Skript nicht (Siehe dazu Fehlerkonsole deines Browsers).

Du solltest dich für eine der beiden Bibliotheken entscheiden. Wenn du dich für jQuery entscheidest, dann verwende einfach http://fancybox.net/ anstelle der Lightbox.

Edit: Es heißt übrigens Galerie. Galle gibt's in der Leber.
 

tobm_knows_best

Erfahrenes Mitglied
Hallo CPoly,

vielen Dank für dein Hilfe - zumindest weiss ich jetzt das Lightbox2 nicht mit jQuery *harmoniert*...
ich habe mich jetzt für das jQuery light Box plugin entschieden - ähm... die Fancybox hat ebensowenig funktioniert wie die lighbox :(

Tja - und jetzt selbes Problem... es geht wieder nicht? ....

Was zur Hölle... mach ich falsch...?

Edit: Das Galeriebild soll erst mal nur zum Testen genommen werden... :p
 
Zuletzt bearbeitet:

Zenti

Erfahrenes Mitglied
Hi,..

Momentan sieht dein IMG Link so aus:

HTML:
<a href="http://www.tutorials.de/images/logo_jochen_schweizer.jpg"><img src="http://www.tutorials.de/images/logo_jochen_schweizer.jpg" width="72" height="72" alt="" /></a>

Wie soll das Script erkennen das dieser Link das Bild in der Lightbox öffnet ?!

Versuchs mal so,..

HTML:
<a href="http://www.tutorials.de/images/logo_jochen_schweizer.jpg" rel="lightbox"><img src="http://www.tutorials.de/images/logo_jochen_schweizer.jpg" width="72" height="72" alt="" /></a>

Ich hatte früher ähnliche Probleme, aber letztendlich liegt es immer daran, das man nicht richtig liest bzw. etwas übersieht :). Schau dir doch einnfach noch mal die Hilfestellungen auf dieser Seite an: http://lokeshdhakar.com/projects/lightbox2/

mit freundlichen Grüßen,
Zenti

EDIT: Das gleiche bei der Fancybox,.. (rel="").
Bei diesen Scripten ist immer ne Demo dabei. die man sogar lokal einfach testen kann. Geht nicht gibts nicht ;) An irgendwas liegts immer,.. einfach alle Möglichkeiten durchprobieren ;)
 
Zuletzt bearbeitet:

tobm_knows_best

Erfahrenes Mitglied
hmm... ich hab´s jetzt nochmal angepasst.... die scripte reinkopiert wo sie hingehören, Bilder rein wo sie hinsollen und die entsprechenden Codes eingefügt....
... irgendwas blockiert da bei mir :((((((

Aber hats bei dir dann funktioniert... ******!
 

Zenti

Erfahrenes Mitglied
Schick mir mal den Ordner mit allen Dateien inkl. index etc. an ******
Ich werde es mal auf meinen Space testen und umschreiben,.. dann wirds schon funktionieren,..
 
Zuletzt bearbeitet von einem Moderator:

Zenti

Erfahrenes Mitglied
So,.. ;)
http://ze-tech.de/test/

hoffe es passt so,..
Das ist nicht die lightbox! Die lightbox verträgt sich mit einem Script von dir nicht,..
Aber um das umzuschreiben,.... naja ;) Gibt einfachere Wege,..

Ich habe jetzt die Slimbox verwendet da diese nahezu identisch ist :)

mit freundlichen Grüßen,
Zenti
 

tobm_knows_best

Erfahrenes Mitglied
Ja wie geil ist das denn.... ?!

OK - sollte ich´s also dann mit der Slimbox versuchen werde ich alle anderen Lightbox-Scriptgeschichten entfernen... oder soll ich´s fürs erste mal so übernehmen... ?!

MFG

und vielen vielen Dank... ;)
 

Zenti

Erfahrenes Mitglied
Ich würde die Lightbox und deren Daten entfernen. Da du sonst später wieder das selbe Problem hast. benutze einfach die Slimbox,.. die macht das selbe ;) Hab dir grad noch eine E-Mail gesendet mit der überarbeiteten Webseite + SlimBox,..

Ich denke es dürfte alles klar sein ;)

Brauchst mir nicht Danken,.. Habe ich gerne gemacht!
Hatte auch schon einige Probleme und die lieben User von Tutorials haben mir geholfen :)

Grüßle,..