Lamp installation

DragonOdem

Grünschnabel
hallo habe probleme einen lamp server zu installieren es hängt immer
wieder wenn ich make ausführe. Von daher habe ich mich dazu
entschloßen die rpm packete von Suse(8.0) zu benutzen, die
funktionieren auch alles läuft super bis auf die kleinigkeit das php3
nicht funktioniert. ok, dachte ich! ;(( aber suse8.0 liefert kein
rpm packet für php3 mit, also gut Quellen runtergeladen ./configure
mit den erforderlichen Parametern eingetipt und funktionierte dann
noch schnell den make Befehl dachte ich ;(( und es kam eine
Fehlermeldung!:#

Die Fehlermeldung woran ich ca. 3Wochen dran verzweifel:

gcc -shared -o libphp3.so mod_php3.o libmodphp3-so.a -L/usr/local/lib -lgd lpng
solv -Wl,--version-script=/usr/local/src/lamp/php-3.0.18/php.map
/usr/i486-suse-linux/bin/ld: cannot find -lpng
collect2: ld returned 1 exit status
apxs:Break: Command failed with rc=1
make: *** [libphp3.so] Fehler1


Ich hasse es! :# egal was ich gemacht hab es kommt immer wieder!

werde schon ganz :{} %)


hoffe echt das mir hier einer helfen kann, danke schon mal im Voraus!
MFG D.O.
 

DragonOdem

Grünschnabel
ich beiß mich da schon seit 3Wochen mit rum, glaub es mir auch dein tutorial funzt net bei mir das von baach auch net und das von phpwelt hat auch nicht geklappt, allerdings benutzen alle nicht das neue suse 8.0 vieleicht liegt ja daran, ich mein suse hat da ja ein paar veränderungen vorgenommen... und mal davon abgesehen brauche ich php3 und php4. Trodzdem gutes toturial was du da hast und danke nochmal für die versuchte hilfe. :(
 
Zuletzt bearbeitet:

DragonOdem

Grünschnabel
...muß aber dazusagen das nur php3 nicht funzt! ;(( der rest funktioniert.

hat da jemand einen plan? bin für jede hilfe dankbar.

P.S.: Die Anleitung oben ist mit die beste!
 

Christian Fein

Erfahrenes Mitglied
naja fehler 1 sagt mir nichts :)

Mal ne andere Frage:
Wozu php3 ?
Parse die extension php3 einfach auf dein php4 das dürfte kein problem darstellen wenns um kompatibilität geht.
 

DragonOdem

Grünschnabel
schon probiert, funktioniert nicht.

...aber danke für die hilfe.


...weil die Scripte die ich benutze nur unter php3 funktionieren. :confused:
 

Marcus Roffmann

Erfahrenes Mitglied
Das kann allerdings nicht so ganz sein.
PHP4 kann die Skripte auch interpretieren, nur müssen einige Dinge beachtet werden:
- Umstellung der Register Globals)
- Neue Funktionen
- Umstrukturierung insgesamt

Ich frage mich allerdings was Du mit PHP3 willst? PHP4 ist doch inzwischen weiter verbreitet und (fast) auf jedem WebServer zu verwendbar...